OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by nudelkiste - 02.01.2020

FS#2711 - logread -r gives wrong return-code

what I am doing:

root@ffsaar-HammelsbergVa:~# logread -?
    -r    <server> <port>    Stream message to a server
root@ffsaar-HammelsbergVa:~# logread -r syslog.ffsaar 515
root@ffsaar-HammelsbergVa:~# echo $?
0
root@ffsaar-HammelsbergVa:~#

Due to the return-code “0”, I was thinking that everything went fine and my log was perfectly streamed to the server, but:

root@ffsaar-HammelsbergVa:~# logread -l 1
Wed Jan  1 21:52:47 2020 daemon.info logread[3904]: failed to send log data to syslog.ffsaar:515 via tcp
root@ffsaar-HammelsbergVa:~# 

expected behaviour: If there is some trouble sending the data, then the return-code of logread -r should be anything but “0”, right?

ENV:
OpenWrt 18.06-SNAPSHOT, r7835+25-89808e211c
gluon-ffsaar 1.8.0 / gluon v2019.1

nudelkiste commented on 02.01.2020 08:22

originally this bug was reported here:
https://github.com/freifunk-gluon/gluon/issues/1902

was told that "the upstream Bugtracker is the better place for this issue".
As I have no idea what/where this might be, I hope here there is the right place to do so?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing