OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by opengsos - 16.12.2019

FS#2678 - Wireless client cannot connect to open wireless network (encryption:none) after encrypted connection

Wireless client won’t connect to an open wireless network (encryption set to none) after previous encrypted connection. A reboot fixes the problem. Sounds similar to OpenWISP problem: https://github.com/openwisp/netjsonconfig/issues/113

I’m using Comfast CF-E110N-V2 8MB
OpenWRT SNAPSHOT r11676-a15f658ed0
target: ath79/generic mips_24kc

Steps to reproduce:
1. Connect to an encrypted wireless network, eg.
config wifi-iface ‘wifinet0’ option ssid ‘homewifi’ option device ‘radio0’ option mode ‘sta’ option network ‘wwan’ option key ‘versecurepassword’ option encryption ‘psk2’ 2. Confirm it’s working.
3. Disable ssid ‘homewifi’ option disabled ‘1’ 4. Connect to an open wireless network, eg.
config wifi-iface ‘wifinet1’ option ssid ‘airport free wifi’ option device ‘radio0’ option mode ‘sta’ option network ‘wwan2’ option encryption ‘none’ 5. Confirm that the device doesn’t connect to the ‘airport free wifi’ network
6. restart device
7. confirm that the device now connects to the ‘airport free wifi’ network.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing