OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Javier Marcet - 01.12.2019

FS#2646 - Kernel panics with docler on openwrt x86-64

I have been setting up openwrt for an i7-3770 server. I have it booting from uefi, with dual rootfs partition so I can upgrade with sysupgrade safely from openwrt itself. It’s really cool building openwrt from inside itself.

All seems to work wonderfully, but one important detail, which renders the whole thing unusable. The kernel panics again and again when using docker. The back traces are so different that I have no clue what the problem really is.

All I know for sure is it happens when docker is running. The usually are (if not always) general protection faults, but the hardware is rock solid, has been for 6+ years. The same dockers work fine on ubuntu on the same hardware, so I suspect the kernel, but as I said, I haven’t been able to stabilize it at all. I tried both 4.14 and 4.19, and I even tried to build openwrt with a newer kernel, but that’s not a 2 hours job, it’s way more involved.

Javier Marcet commented on 01.12.2019 21:28

A picture taken from the TV the serve is connected to. Those messages didn't make to the syslog server.

Javier Marcet commented on 01.12.2019 21:40

I'd like to change the priority to very high or critical, I cannot do it now.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing