OpenWrt/LEDE Project

  • Status Waiting on reporter
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by ogura.org.ua - 29.11.2019
Last edited by Baptiste Jonglez - 13.01.2020

FS#2641 - Device file for USB does not appear /dev/ttyUSB*

With new version 19.07.0rc I could not make my USB cellular (3g) modem dongle to work due to it simply no any serial device like /dev/ttyUSB* file appear with insertion.
In kernel log it appears report about new device insertion and nothing happenings after.
I made several attempts, with ‘modeswitch’ or without and several other ‘mods’ the result is the same no any /dev/ttyUSB*
With other version it was not such problem it appeared exactly three /dev/ttyUSB0 /dev/ttyUSB1 /dev/ttyUSB2 es well as on my Ubuntu 19.04 And Ubuntu 16.04 Ubuntu 18.04

Both router and dongle are USB-2
Actually router is Asus RT-N16
and modem dongle is Alcatel One Touch X090S

P.S. I need this one to be solved to report other bugs. :)

ogura.org.ua commented on 06.12.2019 21:36

It's already 19.07.0-rc2, same problem remains.
I just "forgot", that it is good idea to add a log

Just ones again it's a log after removing and insertion of a usb cellular modem dongle withsame namings of 'kmods' installed as I used with 18.06. (I need 19.07 because of 'tor' 4.*.)

begin

Fri Dec 6 19:12:31 2019 kern.info kernel: [ 89.334470] usb 1-2: USB disconnect, device number 3
Fri Dec 6 19:12:36 2019 kern.info kernel: [ 94.891669] usb 1-2: new high-speed USB device number 4 using ehci-platform
Fri Dec 6 19:12:37 2019 kern.err kernel: [ 95.973497] usb usb1-port2: disabled by hub (EMI?), re-enabling...
Fri Dec 6 19:12:37 2019 kern.info kernel: [ 95.979817] usb 1-2: USB disconnect, device number 4
Fri Dec 6 19:12:38 2019 kern.info kernel: [ 96.361757] usb 1-2: new high-speed USB device number 5 using ehci-platform

end

Project Manager
Baptiste Jonglez commented on 13.01.2020 16:25

Are you sure you don't need additional packages to make it work? Sysupgrade does not preserve installed packages.

Can you post a log of the same actions when using 18.06?

ogura.org.ua commented on 13.01.2020 22:12

Unfortunately I had been de-bricking it yesterday with tftp after attempt to simply upgrade from rc2 to stable release. I do not think it's good idea to downgrade to 18.06
It seams I installed every kmod 3g and USB.b but I remember logs under 18.* very much resembled logs under ubuntu. it very easy occupied /dev/ttyUSB0 , /dev/ttyUSB1 and /dev/ttyUSB2
May be after some while I'll downgrade it to 18.06 to send logs. Or may be I will change it another router.
But I just insrted USB flash drive, and it is the only what found in logs, no any device appeared as well.

begin

Mon Jan 13 22:09:27 2020 kern.info kernel: [ 8652.923467] usb 1-2: new high-speed USB device number 2 using ehci-platform

end

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing