OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by harvester - 19.11.2019
Last edited by Baptiste Jonglez - 13.01.2020

FS#2618 - [WNDR3700v4] [WI-FI 5G] : Could not find PHY for device 'radio1'

  • Device problem occurs on NETGEAR WNDR3700
  • OpenWRT Release : SNAPSHOT 19.07 (kernel 4.19.
  • Steps to reproduce

Upgrade form 18.06 (ar71xx target) to 19.07 (new ath79 target), the WLAN2.4 is working fine but the WLAN5.0 hang each time with

netifd: radio1 (18289): Could not find PHY for device ‘radio1’ netifd: radio1 (18306): WARNING: Variable ‘data’ does not exist or is not an array/object

Suspecting also this firmware error in the kernel debug :
[ 15.460151] ath9k 18100000.wmac: Direct firmware load for ath9k-eeprom-ahb-18100000.wmac.bin failed with error -2 [ 15.470625] ath9k 18100000.wmac: Falling back to syfs fallback for: ath9k-eeprom-ahb-18100000.wmac.bin


Closed by  Baptiste Jonglez
13.01.2020 17:24
Reason for closing:  Not a bug
Project Manager
Baptiste Jonglez commented on 13.01.2020 17:23

Keeping the configuration when upgrading from ar71xx to ath79 is not guaranteed to work.

See the migration guide: https://openwrt.org/docs/guide-user/installation/ar71xx.to.ath79

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing