Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#2615 - mac80211: add support for dynamically reconfiguring wifi - unable to add encrypted mesh interface #7448

Open
openwrt-bot opened this issue Nov 18, 2019 · 3 comments
Labels

Comments

@openwrt-bot
Copy link

bluewavenet:

Unable to add encrypted mesh interface

Tested today on OpenWrt snapshot of Nov 18th
Hardware gl-ar300m
wpad-mesh-openssl installed

Mesh interface fails to come up, sometimes with segfault.

Works fine before commit https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=155ede4f1fdb192b11f8ae2dbffda5f7ef4903bd

@dangowrt and @blogic Thankyou for the all the hard work so far, much appreciated.

Reproducible as follows:

Config:
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/ahb/18100000.wmac'
option country 'GB'
option htmode 'HT40'
option noscan '1'
option disabled '0'
option txpower '20'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'none'
option ifname 'wlan0'
option disabled '0'
option ssid 'OpenWrt'
option wds '1'

config wifi-iface 'mesh0'
option device 'radio0'
option ifname 'wlan0-1'
option mode 'mesh'
option mesh_fwding '1'
option disabled '0'
option network 'lan'
option mesh_rssi_threshold '-70'
option key 'meshkey'
option mesh_id 'mesh'
option encryption 'psk2/aes'

Logread after reboot:
Mon Nov 18 10:39:59 2019 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy0.conf (phy wlan0) --> new PHY
Mon Nov 18 10:39:59 2019 kern.info kernel: [ 28.336276] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Mon Nov 18 10:39:59 2019 kern.info kernel: [ 28.386759] br-lan: port 2(wlan0) entered blocking state
Mon Nov 18 10:39:59 2019 kern.info kernel: [ 28.392257] br-lan: port 2(wlan0) entered disabled state
Mon Nov 18 10:39:59 2019 kern.info kernel: [ 28.398173] device wlan0 entered promiscuous mode
Mon Nov 18 10:39:59 2019 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Mon Nov 18 10:39:59 2019 daemon.err hostapd: Using interface wlan0 with hwaddr e6:95:6e:43:c2:4b and ssid "OpenWrt"
Mon Nov 18 10:39:59 2019 kern.info kernel: [ 28.657731] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Mon Nov 18 10:39:59 2019 kern.info kernel: [ 28.664528] br-lan: port 2(wlan0) entered blocking state
Mon Nov 18 10:39:59 2019 kern.info kernel: [ 28.670081] br-lan: port 2(wlan0) entered forwarding state
Mon Nov 18 10:39:59 2019 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->ENABLED
Mon Nov 18 10:39:59 2019 daemon.notice hostapd: wlan0: AP-ENABLED
Mon Nov 18 10:40:01 2019 user.notice root: ip link set dev wlan0 up
Mon Nov 18 10:40:01 2019 user.notice root: ip link set dev wlan0-1 up
Mon Nov 18 10:40:01 2019 kern.info kernel: [ 29.852996] IPv6: ADDRCONF(NETDEV_UP): wlan0-1: link is not ready
Mon Nov 18 10:40:01 2019 daemon.notice netifd: radio0 (1065): command failed: Link has been severed (-67)
Mon Nov 18 10:40:02 2019 daemon.notice netifd: radio0 (1065): command failed: Link has been severed (-67)
Mon Nov 18 10:40:02 2019 kern.info kernel: [ 30.797131] br-lan: port 3(wlan0-1) entered blocking state
Mon Nov 18 10:40:02 2019 kern.info kernel: [ 30.802810] br-lan: port 3(wlan0-1) entered disabled state
Mon Nov 18 10:40:02 2019 kern.info kernel: [ 30.808940] device wlan0-1 entered promiscuous mode
Mon Nov 18 10:40:02 2019 kern.info kernel: [ 30.914895] br-lan: port 2(wlan0) entered disabled state
Mon Nov 18 10:40:03 2019 kern.info kernel: [ 31.747149] do_page_fault(): sending SIGSEGV to wpa_supplicant for invalid read access from 000005b8
Mon Nov 18 10:40:03 2019 kern.info kernel: [ 31.756745] epc = 004840c9 in wpad[400000+b4000]
Mon Nov 18 10:40:03 2019 kern.info kernel: [ 31.761534] ra = 004840b3 in wpad[400000+b4000]
Mon Nov 18 10:40:05 2019 kern.info kernel: [ 34.587715] br-lan: port 2(wlan0) entered blocking state
Mon Nov 18 10:40:05 2019 kern.info kernel: [ 34.593215] br-lan: port 2(wlan0) entered forwarding state
Mon Nov 18 10:40:05 2019 daemon.notice netifd: Network device 'wlan0' link is up

Supply the following if possible:

  • Device problem occurs on
  • Software versions of OpenWrt/LEDE release, packages, etc.
  • Steps to reproduce
@openwrt-bot
Copy link
Author

KrazyIvan:

Same issue crash: do_page_fault(): sending SIGSEGV to wpa_supplicant for invalid read access from ....

RUN:

/usr/sbin/wpa_supplicant -B -s -b br-lan -P /var/run/wpa_supplicant-mesh1.pid -D nl80211 -i mesh1 -c /var/run/wpa_supplicant-mesh1.conf -C /var/run/wpa_supplicant

Config:
cat /var/run/wpa_supplicant-mesh1.conf

country=US network={ ssid="meshID001" key_mgmt=SAE mode=5 mesh_fwding=1 fixed_freq=1 frequency=5180 ht40=1 vht=1 max_oper_chwidth=1 sae_password="saomepassword" beacon_int=100 }

@openwrt-bot
Copy link
Author

bluewavenet:

@KrazyIvan
Yes, encrypted mesh seems to have reverted to a broken state again.
We have also lost the ability to add mesh_param options via uci eg mesh_hwmp_rootmode, mesh_gate_announcements, et al - although mesh_rssi_threshold does still work.

bugs.openwrt.org does not seem to be a very good way of reporting bugs, anyone know any other ways?

@openwrt-bot
Copy link
Author

hexa-:

You always have the option to bisect an issue yourselves and talk to the author of the broken commit, if you can find it. That usually speeds things up alot.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant