OpenWrt/LEDE Project

  • Status Researching
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Sławomir Szewczyk - 18.11.2019
Last edited by Baptiste Jonglez - 13.01.2020

FS#2614 - ath10k 5 GHz connectivity issues for some client devices

* - Device problem occurs on TP-Link Archer C2600.

* - Software version of OpenWrt 19.07-rc1 and older 19.07.

* - From the first version, which I tested after the release of 19.07, I have a problem with 5GHz radio / Wi-Fi. On two devices: LG OLED B8 55 “OTT and Cyfrowy Polsat STB OTT does not work internet. Both devices connect to the network, but do not have access to the Internet. In the connection diagnostics on the TV, the message pops up that it is a DNS error. On 2.4 GHz Wi-Fi everything is fine.

* - I have reverted to the 18.06 to fix the problem for now.


Sławomir Szewczyk commented on 07.12.2019 07:24

/etc/config/network

config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'

option ula_prefix 'fde7:5be6:d62d::/48'

config interface 'lan'

option type 'bridge'
option ifname 'eth1.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'

option ifname 'eth0.2'
option proto 'dhcp'

config interface 'wan6'

option ifname 'eth0.2'
option proto 'dhcpv6'

config switch

option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan

option device 'switch0'
option vlan '1'
option ports '1 2 3 4 6t'

config switch_vlan

option device 'switch0'
option vlan '2'
option ports '5 0t'
Sławomir Szewczyk commented on 07.12.2019 07:26

/etc/config/wireless

config wifi-device 'radio0'

option type 'mac80211'
option hwmode '11a'
option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
option htmode 'VHT80'
option txpower '23'
option channel '40'

config wifi-iface 'default_radio0'

option device 'radio0'
option network 'lan'
option mode 'ap'
option key 'xxxxxxxx'
option ssid 'xxxxxxxx'
option encryption 'psk2+ccmp'

config wifi-device 'radio1'

option type 'mac80211'
option hwmode '11g'
option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
option txpower '30'
option htmode 'HT40'
option channel '6'

config wifi-iface 'default_radio1'

option device 'radio1'
option network 'lan'
option mode 'ap'
option key 'xxxxxxxx'
option ssid 'xxxxx'
option encryption 'psk2+ccmp'
Sławomir Szewczyk commented on 07.12.2019 07:27

/etc/config/firewall

config defaults

option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option flow_offloading '1'
option flow_offloading_hw '1'

config zone

option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'

config zone

option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config forwarding

option src 'lan'
option dest 'wan'

config rule

option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule

option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule

option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'

config rule

option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule

option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'

config rule

option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule

option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule

option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'

config rule

option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'

config include

option path '/etc/firewall.user'
Sławomir Szewczyk commented on 07.12.2019 07:29

root@C2600:~# ip route show
default via 192.168.8.1 dev eth0.2 src 192.168.8.187
192.168.1.0/24 dev br-lan scope link src 192.168.1.1
192.168.8.0/24 dev eth0.2 scope link src 192.168.8.187

Sławomir Szewczyk commented on 07.12.2019 10:58

I found a solution:

1) Download: firmware-5-ct-full-community.bin (newest) 9980 –» https://www.candelatech.com/downloads/ath10k-10-4/firmware-5-ct-full-community.bin

2) Then we do: cp firmware-5-ct-full-community.bin /lib/firmware/ath10k/QCA99X0/hw2.0/firmware-5.bin

3) Restart.

4) Problem solved!

Project Manager
Hauke Mehrtens commented on 26.12.2019 13:33

This ath10k FW is from December 2018, please check also these FW releases done in between to find where it broke:
https://www.candelatech.com/downloads/ath10k-10-4b/

Sławomir Szewczyk commented on 27.12.2019 01:22

1) firmware-5-ct-full-community-12.bin-lede.001 - [GOOD]

2) firmware-5-ct-full-community-12.bin-lede.002 - [GOOD]

3) firmware-5-ct-full-community-12.bin-lede.003 - [GOOD]

4) firmware-5-ct-full-community-12.bin-lede.004 - [GOOD]

5) firmware-5-ct-full-community-12.bin-lede.005 - [GOOD]

6) firmware-5-ct-full-community-12.bin-lede.006 - [GOOD]

7) firmware-5-ct-full-community-12.bin-lede.007 - [GOOD]

8) firmware-5-ct-full-community-12.bin-lede.008 - [FAIL]

9) firmware-5-ct-full-community-12.bin-lede.009 - [FAIL]

10) firmware-5-ct-full-community-12.bin-lede.010 - [FAIL]

11) firmware-5-ct-full-community-12.bin-lede.011 - [FAIL]

12) firmware-5-ct-full-community-12.bin-lede.012 - [FAIL]

13) firmware-5-ct-full-community-12.bin-lede.013 - [FAIL]

14) firmware-5-ct-full-community-12.bin-lede.014 - [FAIL]

Sławomir Szewczyk commented on 13.01.2020 17:42

Another solution that also works is:

1) Uninstalling the package: ath10k-firmware-qca99x0-ct

2) Instaslling the package: ath10k-firmware-qca99x0

Working!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing