OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Packages
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Darius - 17.11.2019

FS#2609 - Dependency issues in feeds/packages on clean install

Hi.
There is a problem with dependency in packages/feeds in clean install of OpenWRT 19.07.0-rc1. Here is what I do:

git checkout openwrt-19.07
git pull
make distclean
./scripts/feeds update -a
./scripts/feeds install -a
make menuconfig (and select target)
make defconfig

and after last command I get these warnings:

WARNING: Makefile 'package/feeds/luci/luci-app-cifsd/Makefile' has a dependency on 'cifsd-tools', which does not exist
WARNING: Makefile 'package/feeds/luci/luci-proto-modemmanager/Makefile' has a dependency on 'modemmanager', which does not exist
WARNING: Makefile 'package/feeds/packages/python-zipp/Makefile' has a dependency on 'python3-more-itertools', which does not exist
tmp/.config-package.in:104681:error: recursive dependency detected!
For a resolution refer to Documentation/kbuild/kconfig-language.txt
subsection "Kconfig recursive dependency limitations"
tmp/.config-package.in:104681:	symbol PACKAGE_nfs-kernel-server depends on NFS_KERNEL_SERVER_V4
For a resolution refer to Documentation/kbuild/kconfig-language.txt
subsection "Kconfig recursive dependency limitations"
feeds/packages/net/nfs-kernel-server/Config.in:4:	symbol NFS_KERNEL_SERVER_V4 depends on PACKAGE_nfs-kernel-server
#
# configuration written to .config
#

If I do exactly the same steps on 18.06 then no warnings/faults are received. So, I guess there are some kind of dependency issues in feeds/packages.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing