OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by John Doe - 17.11.2019
Last edited by Baptiste Jonglez - 14.05.2021

FS#2608 - sysntpd cannot acquire time on IPv6 only network

I’ve encountered an issue with ntpd in OpenWrt where it cannot acquire the time on an IPv6 only network, it seems that the issue lies in dns resolution by ntpd as specifying an IPv6 address instead of a domain works as expected.

By the way, I believe only 2.pool.ntp.org returns IPv6 addresses in case anyone tries to reproduce my issue.

Possibly relevant: https://dev.archive.openwrt.org/attachment/ticket/12167/0001-busybox-make-ntpd-prefer-IPv6-addresses.patch

Closed by  Baptiste Jonglez
14.05.2021 14:07
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in https:/ /git.openwrt.org/7fea9d9f5dd282a7049d77c c6b75e0a703ead26c

SimonIremonger commented on 28.12.2020 20:25

I can confirm this issue does exist, in Master 2020-12-28 ...

When configured with IPv6-only networking (at least, no IPv4-default-route), there seems to be no attempts to ipv6 timesync, even though 2.openwrt.pool.ntp.org has AAAA-records!.

Installing 'ntpd' package seems to 'fix' this issue, i.e. would appear that the openwrt busybox ntp client build is where the problem lies...

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing