OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Pedro - 14.11.2019

FS#2594 - Kernel panic when configuring network on mvebu ( Turris Omnia )

- Latest snapshot from today
- Does not happen on 18.0.6.x
- Router enters reboot loop

Several ways to trigger bug but it essentially revolves around bringing up a VLAN interface inside a bridge.

Some configuration examples that triggers the bug:

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option delegate '0'
        option igmp_snooping '1'
        option ifname 'lan0 lan1 lan2 lan3 lan4.12'
        option ipaddr '192.168.88.254'


another one:

config interface 'iptv'
        option proto 'none'
        option type 'bridge'
        option ifname 'eth2.12 lan4.12'

The output is:

[   16.828573] device lan3 entered promiscuous mode
[   16.876458] mv88e6085 f1072004.mdio-mii:10 lan4: configuring for phy/gmii link mode
[   16.884237] IPv6: ADDRCONF(NETDEV_UP): lan4: link is not ready
[   16.891531] br-lan: port 5(lan4.12) entered blocking state
[   16.897098] br-lan: port 5(lan4.12) entered disabled state
[   16.904047] device lan4.12 entered promiscuous mode
[   16.908940] device lan4 entered promiscuous mode
[   16.918101] Unable to handle kernel NULL pointer dereference at virtual address 00000518
[   16.926236] pgd = 6295ce7a
[   16.928948] [00000518] *pgd=2da78831, *pte=00000000, *ppte=00000000
[   16.935252] Internal error: Oops: 17 [#1] SMP ARM
[   16.939965] Modules linked in: ath9k ath9k_common pppoe ppp_async ath9k_hw ath10k_pci ath10k_core ath pptp pppox ppp_mppe ppp_generic nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_tabs
[   17.011450]  nf_reject_ipv4 nf_nat_rtsp nf_nat_ipv4 nf_nat_ftp nf_nat nf_log_ipv4 nf_flow_table_hw nf_flow_table nf_conntrack_rtsp nf_conntrack_rtcache nf_conntrack_netlink nf_conntrat
[   17.082567]  nfnetlink nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 ip_gre gre ifb ip6_udp_tunnel udp_tunnel ip_tunnel autoc
[   17.140899] CPU: 1 PID: 1968 Comm: netifd Not tainted 4.19.82 #0
[   17.146917] Hardware name: Marvell Armada 380/385 (Device Tree)
[   17.152856] PC is at br_vlan_enabled+0x0/0x10
[   17.157224] LR is at dsa_port_vlan_add+0x40/0x88
[   17.161851] pc : [<c06678c0>]    lr : [<c066d100>]    psr: 60000013
[   17.168130] sp : ed5abca0  ip : 00000001  fp : ed5abdb6
[   17.173364] r10: 00000001  r9 : edb93500  r8 : ec1e6800
[   17.178599] r7 : ed5abd04  r6 : ed5abd24  r5 : ee864000  r4 : ee94424c
[   17.185140] r3 : 00000004  r2 : ed5abd04  r1 : 00000000  r0 : 00000000
[   17.191682] Flags: nZCv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment none
[   17.198832] Control: 10c5387d  Table: 2d5c004a  DAC: 00000051
[   17.204590] Process netifd (pid: 1968, stack limit = 0xab1173e4)
[   17.210609] Stack: (0xed5abca0 to 0xed5ac000)
[   17.214976] bca0: ed5abd24 ed5abd04 00000000 00000004 ffffffa1 c0674dbc ffff916c c068efc0
[   17.223173] bcc0: 00000000 ffffffa1 ec1e6800 ed5abd24 ed5abd04 c0674de4 ee937ea0 ec1e6868
[   17.231370] bce0: 00000001 ec7b7840 ec1e6800 ed5abd24 eda5e000 c0674e94 ef3cda40 ffffffff
[   17.239566] bd00: ef08c000 ed5abd04 ed5abd04 c0945001 ec7b7840 ec7b7840 ef1783c0 c066b5bc
[   17.247763] bd20: c0a03db0 ec1e6800 00000001 00000000 00000000 00000000 00010006 00000001
[   17.255959] bd40: 00000000 c0668f64 eeb9c544 00000006 00000001 00000000 eda5e080 00000036
[   17.264156] bd60: ed5abd84 c0148948 ef0f304c ef0f3040 ef0f304c 00000000 00000000 ef1783c0
[   17.272354] bd80: ec7b7840 eda5e000 00000001 00000000 00000006 c066780c ed5abdb6 c0669df0
[   17.280551] bda0: ffffffa1 ee864000 ed5abe23 ed5abe04 00000000 000148ac ef1783c0 ed5abdb6
[   17.288747] bdc0: 00020003 00000008 00001000 01010000 00000000 00000000 c066780c 00020003
[   17.296943] bde0: 00000008 00001000 01010000 00000000 00000000 c066780c ef178418 00000000
[   17.305140] be00: ef1783c0 eda5e000 00000000 00000000 eda5e080 00000036 0003d7a8 c0669f20
[   17.313337] be20: 00ffffe5 edb93000 00000007 00000002 00000000 00000000 00000000 00000000
[   17.321533] be40: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 c0a03c48
[   17.329730] be60: ec1e6800 ec1e6800 00000000 eda5e000 edb93500 c06595ac 00000000 c012e864
[   17.337928] be80: edb93500 000089a2 edb93000 ed5abef4 c0739a90 ed5abeec 00000000 c05932c0
[   17.346125] bea0: 00e0f13b c0a2b940 ed5abef4 c056bbdc ed5abef4 000000a2 000089a2 c0a2b940
[   17.354323] bec0: ed5abeec c059395c 000089a2 00000051 bed4aba8 c0a2b940 ef0dc300 ed5aa000
[   17.362519] bee0: 00000036 c05506c4 00000000 eed51d01 eea7c410 6c2d7262 00006e61 00000000
[   17.370715] bf00: 00000000 00000013 00000000 00000000 00000000 c0a03c48 bed4aba8 eedff1a0
[   17.378911] bf20: 000089a2 bed4aba8 ef0dc300 c0225788 00000000 eecf97f8 eecf9848 c07ea5a8
[   17.387108] bf40: ed5409c0 00000000 eed51d60 eea7c410 eecf97f8 40000010 ed5409c8 c0214558
[   17.395304] bf60: 00000020 00000000 00000000 ef3cde74 ef0dc300 00000008 000089a2 bed4aba8
[   17.403501] bf80: ef0dc300 ed5aa000 00000036 c022585c 00e20c40 000089a2 b6edb6d8 00000036
[   17.411699] bfa0: c0101204 c0101000 00e20c40 000089a2 00000008 000089a2 bed4aba8 bed4aba0
[   17.419896] bfc0: 00e20c40 000089a2 b6edb6d8 00000036 00e20c78 b6edb6d8 00e20de4 0003d7a8
[   17.428094] bfe0: 0003cd54 bed4ab88 000137c4 b6f5439c 80000010 00000008 00000000 00000000
[   17.436295] [<c06678c0>] (br_vlan_enabled) from [<c066d100>] (dsa_port_vlan_add+0x40/0x88)
[   17.444584] [<c066d100>] (dsa_port_vlan_add) from [<c0674dbc>] (__switchdev_port_obj_add+0x30/0x8c)
[   17.453652] [<c0674dbc>] (__switchdev_port_obj_add) from [<c0674de4>] (__switchdev_port_obj_add+0x58/0x8c)
[   17.463329] [<c0674de4>] (__switchdev_port_obj_add) from [<c0674e94>] (switchdev_port_obj_add_now+0x7c/0xf0)
[   17.473181] [<c0674e94>] (switchdev_port_obj_add_now) from [<c066b5bc>] (br_switchdev_port_vlan_add+0x3c/0x44)
[   17.483207] [<c066b5bc>] (br_switchdev_port_vlan_add) from [<c0668f64>] (__vlan_add+0x50/0x5b4)
[   17.491926] [<c0668f64>] (__vlan_add) from [<c0669df0>] (nbp_vlan_add+0x210/0x244)
[   17.499514] [<c0669df0>] (nbp_vlan_add) from [<c0669f20>] (nbp_vlan_init+0xfc/0x158)
[   17.507278] [<c0669f20>] (nbp_vlan_init) from [<c06595ac>] (br_add_if+0x3c8/0x5ac)
[   17.514868] [<c06595ac>] (br_add_if) from [<c05932c0>] (dev_ifsioc+0x36c/0x390)
[   17.522194] [<c05932c0>] (dev_ifsioc) from [<c059395c>] (dev_ioctl+0x5cc/0x63c)
[   17.529522] [<c059395c>] (dev_ioctl) from [<c05506c4>] (sock_ioctl+0x52c/0x5a8)
[   17.536849] [<c05506c4>] (sock_ioctl) from [<c0225788>] (do_vfs_ioctl+0x828/0x8c8)
[   17.544438] [<c0225788>] (do_vfs_ioctl) from [<c022585c>] (ksys_ioctl+0x34/0x58)
[   17.551851] [<c022585c>] (ksys_ioctl) from [<c0101000>] (ret_fast_syscall+0x0/0x54)
[   17.559523] Exception stack(0xed5abfa8 to 0xed5abff0)
[   17.564587] bfa0:                   00e20c40 000089a2 00000008 000089a2 bed4aba8 bed4aba0
[   17.572784] bfc0: 00e20c40 000089a2 b6edb6d8 00000036 00e20c78 b6edb6d8 00e20de4 0003d7a8
[   17.580980] bfe0: 0003cd54 bed4ab88 000137c4 b6f5439c
[   17.586044] Code: 18bd8010 e05c0002 13a00001 e8bd8010 (e5d00518) 
[   17.592168] ---[ end trace d312a86e3174f2be ]---
[   17.596800] Kernel panic - not syncing: Fatal exception
[   17.602039] CPU0: stopping
[   17.604755] CPU: 0 PID: 0 Comm: swapper/0 Tainted: G      D           4.19.82 #0
[   17.612167] Hardware name: Marvell Armada 380/385 (Device Tree)
[   17.618108] [<c010ea7c>] (unwind_backtrace) from [<c010a9bc>] (show_stack+0x10/0x14)
[   17.625871] [<c010a9bc>] (show_stack) from [<c0678cd8>] (dump_stack+0x84/0x98)
[   17.633111] [<c0678cd8>] (dump_stack) from [<c010d61c>] (handle_IPI+0xf0/0x19c)
[   17.640442] [<c010d61c>] (handle_IPI) from [<c03ba714>] (gic_handle_irq+0x74/0x78)
[   17.648032] [<c03ba714>] (gic_handle_irq) from [<c0101a0c>] (__irq_svc+0x6c/0x90)
[   17.655529] Exception stack(0xc0a01f30 to 0xc0a01f78)
[   17.660591] 1f20:                                     00000000 0004498c ef6d7304 c0114480
[   17.668788] 1f40: c0a00000 c0a03c6c 00000000 c0a03cac c0944500 00000000 00000000 c0a01f88
[   17.676984] 1f60: c0a0ecc0 c0a01f80 c01082f8 c01082fc 60000013 ffffffff
[   17.683617] [<c0101a0c>] (__irq_svc) from [<c01082fc>] (arch_cpu_idle+0x34/0x38)
[   17.691036] [<c01082fc>] (arch_cpu_idle) from [<c014c598>] (do_idle+0xd8/0x1b4)
[   17.698363] [<c014c598>] (do_idle) from [<c014c8d0>] (cpu_startup_entry+0x18/0x1c)
[   17.705952] [<c014c8d0>] (cpu_startup_entry) from [<c0900df8>] (start_kernel+0x4f4/0x504)
[   17.714149] Rebooting in 3 seconds..

finally I found a configuration that does not put the router in an endless reboot loop but that nevertheless crashes the kernel in the same way when issuing the reboot command:

config interface 'iptv'
        option proto 'none'
        option type 'bridge'
        option ifname 'eth2 eth2.12 lan4 lan4.12'

The above configuration will not crash the kernel on boot, and the iptv interface will be up. but when issuing the reboot command this happens:

root@gateway:/# reboot
root@gateway:/# [  818.621237] br-iptv: port 1(eth2) entered disabled state
[  818.652955] device eth2.12 left promiscuous mode
[  818.657586] device eth2 left promiscuous mode
[  818.662007] br-iptv: port 2(eth2.12) entered disabled state
[  818.704719] br-iptv: port 3(lan4) entered disabled state
[  818.744413] device lan4.12 left promiscuous mode
[  818.749044] device lan4 left promiscuous mode
[  818.753517] br-iptv: port 4(lan4.12) entered disabled state
[  818.759119] Unable to handle kernel NULL pointer dereference at virtual address 00000518
[  818.767236] pgd = 5685c1a5
[  818.769947] [00000518] *pgd=2d74d831, *pte=00000000, *ppte=00000000
[  818.776239] Internal error: Oops: 17 [#1] SMP ARM
[  818.780951] Modules linked in: cifsd ath9k ath9k_common pppoe ppp_async ath9k_hw ath10k_pci ath10k_core ath pptp pppox ppp_mppe ppp_generic nf_flow_table_ipv6 nf_flow_table_ipv4 nf_fl4
[  818.852080]  nf_tables nf_reject_ipv4 nf_nat_rtsp nf_nat_ipv4 nf_nat_ftp nf_nat nf_log_ipv4 nf_flow_table_hw nf_flow_table nf_conntrack_rtsp nf_conntrack_rtcache nf_conntrack_netlink t
[  818.922931]  nfnetlink nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 ip_gre gre ifb ip6_udp_tunnel udp_tunnel ip_tunnel auto]
[  818.983872] CPU: 0 PID: 1975 Comm: netifd Not tainted 4.19.82 #0
[  818.989890] Hardware name: Marvell Armada 380/385 (Device Tree)
[  818.995829] PC is at br_vlan_enabled+0x0/0x10
[  819.000195] LR is at dsa_port_vlan_del+0x48/0x90
[  819.004821] pc : [<c066a284>]    lr : [<c066fb48>]    psr: 60000013
[  819.011101] sp : ed627d60  ip : c0a2d60c  fp : 00000018
[  819.016337] r10: 00000036  r9 : ed4f5380  r8 : eda63500
[  819.021572] r7 : edbb4800  r6 : ed627dac  r5 : ef369800  r4 : eeba764c
[  819.028113] r3 : 00000004  r2 : 00000000  r1 : ed627dac  r0 : 00000000
[  819.034654] Flags: nZCv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment none
[  819.041804] Control: 10c5387d  Table: 2d7b804a  DAC: 00000051
[  819.047561] Process netifd (pid: 1975, stack limit = 0x1b8c3f18)
[  819.053580] Stack: (0xed627d60 to 0xed628000)
[  819.057947] 7d60: ed627dac 00000000 00000000 00000004 ffffffa1 c0678988 00000000 ed627d84
[  819.066144] 7d80: ffffffa1 edbb4800 ed627dac c06789b0 ed627d90 edbb4868 00000001 eda9b880
[  819.074341] 7da0: ed0933c0 c066dfb8 00000000 edbb4800 00000001 00000000 00000000 00000000
[  819.082538] 7dc0: 00010000 00000001 00000000 c066ab54 00000000 edb64c00 00000000 00000001
[  819.090735] 7de0: 00000000 c0a2b980 c0a67a78 00000001 eb3dc000 00000001 edb64c00 edbb4800
[  819.098931] 7e00: 00480020 c0a2b980 edb64c00 00000000 00000018 c05b0ce4 00480020 00000000
[  819.107128] 7e20: 00000000 edbb4800 00480020 ed093448 ed093470 eda63500 eda63500 edbb4800
[  819.115325] 7e40: 00000000 c066adf0 ed747800 ed0933c0 eda63500 c066d12c ed627ef4 eda63500
[  819.123522] 7e60: edbb4800 ed747800 eda63500 c065bbc4 eda63500 eda63000 ed627ef4 c0739c28
[  819.131719] 7e80: ed627eec 00000000 00000036 c065c53c 000089a3 eda63000 ed627ef4 c05947cc
[  819.139916] 7ea0: 00000000 ed627ef4 000000a3 000089a3 ed627ef4 000000a3 000089a3 c0a2b980
[  819.148113] 7ec0: ed627eec c0594e68 000089a3 00000051 be956c30 c0a2b980 ed411180 ed626000
[  819.156309] 7ee0: 00000036 c0551c24 ef6d9040 ee91a501 ee91a540 692d7262 00767470 00000000
[  819.164506] 7f00: 00000000 00000013 00000000 00000000 00000000 c0a03c48 be956c30 eece5360
[  819.172703] 7f20: 000089a3 be956c30 ed411180 c0225788 eb3e8018 ef6d9000 ee954540 00000000
[  819.180900] 7f40: ee91a4c0 ee993180 c0701b6c ffffe000 ed627f8c c068f5f8 ed627f74 2ed94000
[  819.189097] 7f60: c0944b90 a0000193 c0944b90 ed626000 ed411180 00000008 000089a3 be956c30
[  819.197294] 7f80: ed411180 ed626000 00000036 c022585c 00660860 000089a3 b6eb8ca8 00000036
[  819.205490] 7fa0: c0101204 c0101000 00660860 000089a3 00000008 000089a3 be956c30 be956c28
[  819.213687] 7fc0: 00660860 000089a3 b6eb8ca8 00000036 be956cf4 00000018 0063f040 00000018
[  819.221884] 7fe0: 0003cd54 be956c10 000137c4 b6f0339c 60000010 00000008 00000000 00000000
[  819.230085] [<c066a284>] (br_vlan_enabled) from [<c066fb48>] (dsa_port_vlan_del+0x48/0x90)
[  819.238375] [<c066fb48>] (dsa_port_vlan_del) from [<c0678988>] (switchdev_port_obj_del_now+0x2c/0x84)
[  819.247618] [<c0678988>] (switchdev_port_obj_del_now) from [<c06789b0>] (switchdev_port_obj_del_now+0x54/0x84)
[  819.257643] [<c06789b0>] (switchdev_port_obj_del_now) from [<c066dfb8>] (br_switchdev_port_vlan_del+0x3c/0x44)
[  819.267670] [<c066dfb8>] (br_switchdev_port_vlan_del) from [<c066ab54>] (__vlan_del+0x90/0x304)
[  819.276390] [<c066ab54>] (__vlan_del) from [<c066adf0>] (__vlan_flush+0x28/0x44)
[  819.283804] [<c066adf0>] (__vlan_flush) from [<c066d12c>] (nbp_vlan_flush+0x60/0x7c)
[  819.291568] [<c066d12c>] (nbp_vlan_flush) from [<c065bbc4>] (del_nbp+0x154/0x260)
[  819.299069] [<c065bbc4>] (del_nbp) from [<c065c53c>] (br_del_if+0x30/0xdc)
[  819.305963] [<c065c53c>] (br_del_if) from [<c05947cc>] (dev_ifsioc+0x36c/0x390)
[  819.313290] [<c05947cc>] (dev_ifsioc) from [<c0594e68>] (dev_ioctl+0x5cc/0x63c)
[  819.320618] [<c0594e68>] (dev_ioctl) from [<c0551c24>] (sock_ioctl+0x52c/0x5a8)
[  819.327945] [<c0551c24>] (sock_ioctl) from [<c0225788>] (do_vfs_ioctl+0x828/0x8c8)
[  819.335533] [<c0225788>] (do_vfs_ioctl) from [<c022585c>] (ksys_ioctl+0x34/0x58)
[  819.342946] [<c022585c>] (ksys_ioctl) from [<c0101000>] (ret_fast_syscall+0x0/0x54)
[  819.350618] Exception stack(0xed627fa8 to 0xed627ff0)
[  819.355681] 7fa0:                   00660860 000089a3 00000008 000089a3 be956c30 be956c28
[  819.363878] 7fc0: 00660860 000089a3 b6eb8ca8 00000036 be956cf4 00000018 0063f040 00000018
[  819.372074] 7fe0: 0003cd54 be956c10 000137c4 b6f0339c
[  819.377138] Code: 18bd8010 e05c0002 13a00001 e8bd8010 (e5d00518) 
[  819.383264] ---[ end trace 6cfc8f01d47fa91b ]---
[  819.387891] Kernel panic - not syncing: Fatal exception
[  819.393130] CPU1: stopping
[  819.395844] CPU: 1 PID: 0 Comm: swapper/1 Tainted: G      D           4.19.82 #0
[  819.403256] Hardware name: Marvell Armada 380/385 (Device Tree)
[  819.409195] [<c010ea7c>] (unwind_backtrace) from [<c010a9bc>] (show_stack+0x10/0x14)
[  819.416959] [<c010a9bc>] (show_stack) from [<c067c6d8>] (dump_stack+0x84/0x98)
[  819.424199] [<c067c6d8>] (dump_stack) from [<c010d61c>] (handle_IPI+0xf0/0x19c)
[  819.431530] [<c010d61c>] (handle_IPI) from [<c03ba714>] (gic_handle_irq+0x74/0x78)
[  819.439119] [<c03ba714>] (gic_handle_irq) from [<c0101a0c>] (__irq_svc+0x6c/0x90)
[  819.446618] Exception stack(0xef091f60 to 0xef091fa8)
[  819.451682] 1f60: 00000000 008028b0 ef6e2304 c0114480 ef090000 c0a03c6c 00000001 c0a03cac
[  819.459879] 1f80: c0944500 00000000 00000000 ef091fb8 c0a0ed00 ef091fb0 c01082f8 c01082fc
[  819.468074] 1fa0: 60000013 ffffffff
[  819.471573] [<c0101a0c>] (__irq_svc) from [<c01082fc>] (arch_cpu_idle+0x34/0x38)
[  819.478991] [<c01082fc>] (arch_cpu_idle) from [<c014c598>] (do_idle+0xd8/0x1b4)
[  819.486319] [<c014c598>] (do_idle) from [<c014c8d0>] (cpu_startup_entry+0x18/0x1c)
[  819.493907] [<c014c8d0>] (cpu_startup_entry) from [<001023ac>] (0x1023ac)
[  819.500711] Rebooting in 3 seconds..

finally I have tried with another port ( lan3 ) and it is the same thing.

for instance:

config interface 'iptv'
        option proto 'none'
        option type 'bridge'
        option ifname 'eth2.12 lan3.12'

results in the following panic on boot:

[   16.893737] mv88e6085 f1072004.mdio-mii:10 lan3: configuring for phy/gmii link mode
[   16.901473] IPv6: ADDRCONF(NETDEV_UP): lan3: link is not ready
[   16.908715] br-iptv: port 2(lan3.12) entered blocking state
[   16.914350] br-iptv: port 2(lan3.12) entered disabled state
[   16.920120] device lan3.12 entered promiscuous mode
[   16.925097] device lan3 entered promiscuous mode
[   16.929731] device eth1 entered promiscuous mode
[   16.936690] Unable to handle kernel NULL pointer dereference at virtual address 00000518
[   16.944816] pgd = c664e7e5
[   16.947529] [00000518] *pgd=2d1bf831, *pte=00000000, *ppte=00000000
[   16.953830] Internal error: Oops: 17 [#1] SMP ARM
[   16.958543] Modules linked in: ath9k ath9k_common pppoe ppp_async ath9k_hw ath10k_pci ath10k_core ath pptp pppox ppp_mppe ppp_generic nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_tabs
[   17.030024]  nf_reject_ipv4 nf_nat_rtsp nf_nat_ipv4 nf_nat_ftp nf_nat nf_log_ipv4 nf_flow_table_hw nf_flow_table nf_conntrack_rtsp nf_conntrack_rtcache nf_conntrack_netlink nf_conntrak
[   17.100876]  nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 ip_gre gre ifb ip6_udp_tunnel udp_tunnel ip_tunnel autofs4 nls_utc
[   17.158945] CPU: 1 PID: 1975 Comm: netifd Not tainted 4.19.82 #0
[   17.164964] Hardware name: Marvell Armada 380/385 (Device Tree)
[   17.170904] PC is at br_vlan_enabled+0x0/0x10
[   17.175270] LR is at dsa_port_vlan_add+0x40/0x88
[   17.179897] pc : [<c066a284>]    lr : [<c066fab8>]    psr: 60000013
[   17.186177] sp : ed615ca0  ip : 00000001  fp : ed615db6
[   17.191411] r10: 00000001  r9 : edbce500  r8 : ec1a2000
[   17.196646] r7 : ed615d04  r6 : ed615d24  r5 : ef3da000  r4 : ef32b1dc
[   17.203186] r3 : 00000003  r2 : ed615d04  r1 : 00000000  r0 : 00000000
[   17.209728] Flags: nZCv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment none
[   17.216879] Control: 10c5387d  Table: 2d61004a  DAC: 00000051
[   17.222636] Process netifd (pid: 1975, stack limit = 0xc606eb54)
[   17.228656] Stack: (0xed615ca0 to 0xed616000)
[   17.233023] 5ca0: ed615d24 ed615d04 00000000 00000003 ffffffa1 c06787b8 ef05aa80 ee921580
[   17.241220] 5cc0: 00000000 ffffffa1 ec1a2000 ed615d24 ed615d04 c06787e0 c0945000 ec1a2068
[   17.249418] 5ce0: c0a03db0 eb19db40 ec1a2000 ed615d24 ed4b1000 c0678890 ef05aa00 c013dd3c
[   17.257615] 5d00: ef05aa00 ed615d04 ed615d04 c0945001 eb19db40 eb19db40 ed027d80 c066df74
[   17.265812] 5d20: ed615d64 ec1a2000 00000001 00000000 00000000 00000000 00010006 00000001
[   17.274009] 5d40: 00000000 c066b924 ef05aa04 00000006 00000001 00000000 ed4b1080 00000036
[   17.282205] 5d60: ed615d84 c0148948 ef18404c ef184040 ef18404c 00000000 00000000 ed027d80
[   17.290402] 5d80: eb19db40 ed4b1000 00000001 00000000 00000006 c066a1d0 ed615db6 c066c7a8
[   17.298598] 5da0: ffffffa1 ef3da000 ed615e23 ed615e04 00000000 000182a8 ed027d80 ed615db6
[   17.306796] 5dc0: 00020003 00000008 00001000 01010000 00000000 00000000 c066a1d0 00020003
[   17.314992] 5de0: 00000008 00001000 01010000 00000000 00000000 c066a1d0 ed027dd8 00000000
[   17.323190] 5e00: ed027d80 ed4b1000 00000000 00000000 ed4b1080 00000036 0003d7a8 c066c8d8
[   17.331387] 5e20: 00974080 edbce000 00000007 00000002 00000000 00000000 00000000 00000000
[   17.339583] 5e40: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 c0a03c48
[   17.347779] 5e60: ec1a2000 ec1a2000 00000000 ed4b1000 edbce500 c065c328 00000000 c012e864
[   17.355976] 5e80: edbce500 000089a2 edbce000 ed615ef4 c0739c28 ed615eec 00000000 c05947cc
[   17.364172] 5ea0: 01cc615b c0a2b980 ed615ef4 c056d0e8 ed615ef4 000000a2 000089a2 c0a2b980
[   17.372370] 5ec0: ed615eec c0594e68 000089a2 00000051 bedadba8 c0a2b980 ef0ce840 ed614000
[   17.380566] 5ee0: 00000036 c0551c24 00000000 eed52001 eea71410 692d7262 00767470 00000000
[   17.388763] 5f00: 00000000 00000013 00000000 00000000 00000000 c0a03c48 bedadba8 eee3f360
[   17.396960] 5f20: 000089a2 bedadba8 ef0ce840 c0225788 00000000 eecfe880 eecfe8d0 c07eafec
[   17.405156] 5f40: ed631840 00000000 eed52000 eea71410 eecfe880 40000010 ed631848 c0214558
[   17.413352] 5f60: 00000020 00000000 00000000 ee921934 ef0ce840 00000008 000089a2 bedadba8
[   17.421548] 5f80: ef0ce840 ed614000 00000036 c022585c 01cd75c0 000089a2 b6f38c58 00000036
[   17.429745] 5fa0: c0101204 c0101000 01cd75c0 000089a2 00000008 000089a2 bedadba8 bedadba0
[   17.437941] 5fc0: 01cd75c0 000089a2 b6f38c58 00000036 01cd75f8 b6f38c58 01cd7764 0003d7a8
[   17.446139] 5fe0: 0003cd54 bedadb88 000137c4 b6f8339c 60000010 00000008 00000000 00000000
[   17.454340] [<c066a284>] (br_vlan_enabled) from [<c066fab8>] (dsa_port_vlan_add+0x40/0x88)
[   17.462629] [<c066fab8>] (dsa_port_vlan_add) from [<c06787b8>] (__switchdev_port_obj_add+0x30/0x8c)
[   17.471699] [<c06787b8>] (__switchdev_port_obj_add) from [<c06787e0>] (__switchdev_port_obj_add+0x58/0x8c)
[   17.481377] [<c06787e0>] (__switchdev_port_obj_add) from [<c0678890>] (switchdev_port_obj_add_now+0x7c/0xf0)
[   17.491228] [<c0678890>] (switchdev_port_obj_add_now) from [<c066df74>] (br_switchdev_port_vlan_add+0x3c/0x44)
[   17.501254] [<c066df74>] (br_switchdev_port_vlan_add) from [<c066b924>] (__vlan_add+0x50/0x5b4)
[   17.509974] [<c066b924>] (__vlan_add) from [<c066c7a8>] (nbp_vlan_add+0x210/0x244)
[   17.517562] [<c066c7a8>] (nbp_vlan_add) from [<c066c8d8>] (nbp_vlan_init+0xfc/0x158)
[   17.525326] [<c066c8d8>] (nbp_vlan_init) from [<c065c328>] (br_add_if+0x3c8/0x5ac)
[   17.532918] [<c065c328>] (br_add_if) from [<c05947cc>] (dev_ifsioc+0x36c/0x390)
[   17.540245] [<c05947cc>] (dev_ifsioc) from [<c0594e68>] (dev_ioctl+0x5cc/0x63c)
[   17.547572] [<c0594e68>] (dev_ioctl) from [<c0551c24>] (sock_ioctl+0x52c/0x5a8)
[   17.554900] [<c0551c24>] (sock_ioctl) from [<c0225788>] (do_vfs_ioctl+0x828/0x8c8)
[   17.562488] [<c0225788>] (do_vfs_ioctl) from [<c022585c>] (ksys_ioctl+0x34/0x58)
[   17.569902] [<c022585c>] (ksys_ioctl) from [<c0101000>] (ret_fast_syscall+0x0/0x54)
[   17.577574] Exception stack(0xed615fa8 to 0xed615ff0)
[   17.582637] 5fa0:                   01cd75c0 000089a2 00000008 000089a2 bedadba8 bedadba0
[   17.590835] 5fc0: 01cd75c0 000089a2 b6f38c58 00000036 01cd75f8 b6f38c58 01cd7764 0003d7a8
[   17.599030] 5fe0: 0003cd54 bedadb88 000137c4 b6f8339c
[   17.604095] Code: 18bd8010 e05c0002 13a00001 e8bd8010 (e5d00518) 
[   17.610211] ---[ end trace 9ac484c1994602dc ]---
[   17.614842] Kernel panic - not syncing: Fatal exception
[   17.620079] CPU0: stopping
[   17.622795] CPU: 0 PID: 0 Comm: swapper/0 Tainted: G      D           4.19.82 #0
[   17.630206] Hardware name: Marvell Armada 380/385 (Device Tree)
[   17.636146] [<c010ea7c>] (unwind_backtrace) from [<c010a9bc>] (show_stack+0x10/0x14)
[   17.643910] [<c010a9bc>] (show_stack) from [<c067c6d8>] (dump_stack+0x84/0x98)
[   17.651150] [<c067c6d8>] (dump_stack) from [<c010d61c>] (handle_IPI+0xf0/0x19c)
[   17.658482] [<c010d61c>] (handle_IPI) from [<c03ba714>] (gic_handle_irq+0x74/0x78)
[   17.666071] [<c03ba714>] (gic_handle_irq) from [<c0101a0c>] (__irq_svc+0x6c/0x90)
[   17.673570] Exception stack(0xc0a01f30 to 0xc0a01f78)
[   17.678632] 1f20:                                     00000000 000424d0 ef6d7304 c0114480
[   17.686829] 1f40: c0a00000 c0a03c6c 00000000 c0a03cac c0944500 00000000 00000000 c0a01f88
[   17.695025] 1f60: c0a0ed00 c0a01f80 c01082f8 c01082fc 60000013 ffffffff
[   17.701658] [<c0101a0c>] (__irq_svc) from [<c01082fc>] (arch_cpu_idle+0x34/0x38)
[   17.709076] [<c01082fc>] (arch_cpu_idle) from [<c014c598>] (do_idle+0xd8/0x1b4)
[   17.716403] [<c014c598>] (do_idle) from [<c014c8d0>] (cpu_startup_entry+0x18/0x1c)
[   17.723993] [<c014c8d0>] (cpu_startup_entry) from [<c0900df8>] (start_kernel+0x4f4/0x504)
[   17.732190] Rebooting in 3 seconds..


Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing