OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To
    Adrian Schmutzler
  • Operating System All
  • Severity Low
  • Priority Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by jul059 - 08.11.2019
Last edited by Adrian Schmutzler - 11.11.2019

FS#2580 - Installation of 19.07 rc1 fails on TP-Link TL-WR1043ND v3

While trying to sysupgrade the firmware, I get the error in the attached screenshot. The router is apparently detected as v2 but it is definetly v3, see other picture.


Closed by  Adrian Schmutzler
11.11.2019 18:09
Reason for closing:  Fixed
Additional comments about closing:  

Should be fixed.

Hannu Nyman commented on 09.11.2019 07:36
router is apparently detected as v2 but it is definetly v3

The router's type/model detection is based on the currently running firmware (which claims v2).

Perhaps you have originally flashed a wrong firmware to the device? Which exact firmware it is running now?

Project Manager
Adrian Schmutzler commented on 11.11.2019 17:54

ar71xx or ath79?

Project Manager
Adrian Schmutzler commented on 11.11.2019 18:00

Ah, forget about my last question, it's obvious from the screenshot:
You started with ar71xx and tried to install ath79.

The reason for this bug is that in ar71xx the v3 used the boardname of the v2. So, I will send a patch to update the support list for the v3 images in ath79.

Project Manager
Adrian Schmutzler commented on 11.11.2019 18:09

Patch has been applied to master. I will backport it later this week.

If you want to try already, you can build from my staging tree for openwrt-19.07:
https://git.openwrt.org/?p=openwrt/staging/adrian.git;a=shortlog;h=refs/heads/staging-19.07

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing