OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Raphaël Mélotte - 05.11.2019
Last edited by Petr Štetiar - 27.11.2019

FS#2577 - Turris omnia: the medkit from master cannot be used to replace TurrisOS 4

After building from the master branch (currently on 8184429b7b15e61f5c195ad953016b1360c076a2), the generated medkit cannot be used to replace TurrisOS 4.0.1 with OpenWrt.

Steps to reproduce:
- Flash TurrisOS 4.0.1 on the device.
- Compile OpenWrt from master.
- Boot from the initramfs from the medkit generated by OpenWrt (either through USB or tftp).
- Use sysupgrade with the image you compiled from master.
- The result is:

root@OpenWrt:/# sysupgrade -v /tmp/openwrt-mvebu-cortexa9-cznic_turris-omnia-sysupgrade.img.gz 
zcat: write error: Broken pipe
zcat: write: Broken pipe
Unable to determine upgrade device
Image check failed.

Compared to the last release (18.06.4), sysupgrade now runs additional checks and tries to save existing partitions. It uses the “root” command line parameter to get information about the current partition.
When using TurrisOS 4.0.1, the “root” command line parameter is set to “b301”, which is not taken into account by sysupgrade (specifically, “export_bootdevice” fails hence the “Unable to determine upgrade device”).

Using “sysupgrade -F”, also does not work since “platform_do_upgrade_sdcard” runs the same checks as “platform_check_image_sdcard” in the beginning, and “export_bootdevice && export_partdevice diskdev 0” fail.

In the meantime, a workaround is to first use the 18.06.4 release to replace TurrisOS (using the medkit then sysupgrade). After that, sysupgrade can be used again to flash the image from master. This works because sysupgrade from 18.06.4 blindly writes the image to “/dev/mmcblk0”.

Closed by  Petr Štetiar
27.11.2019 13:49
Reason for closing:  Fixed
Additional comments about closing:  

Requested.

Raphaël Mélotte commented on 27.11.2019 13:47

This issue can be closed, it has been fixed in: 3a4f587c465a0531b820ca1a3e90eb05c4927b68

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing