OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by zorxd - 07.10.2019

FS#2537 - Ath9k on Archer C7 v2: disassociated due to inactivity

Hello

Every few weeks I have to restart the 2.4 GHz radio or reboot my Archer C7 v2 router otherwise no client can connect to it.
All stations end up being “deauthenticated due to inactivity” and can’t reconnect.

Tested on OpenWRT 18.06.4. It is quite hard to reproduce for me as it doesn’t happen frequently.

Forum post: https://forum.openwrt.org/t/ath9k-on-archer-c7-v2-disassociated-due-to-inactivity/13328

Björn Strömberg commented on 15.11.2019 06:08

this is a pretty irritating bug, and the reproduction of it is something i have not either been able to do on cue.

on my Archer C7 v2 it happens very random, some times it "hangs" the 2.4 GHz radio once a week, sometimes it only takes a few days, and the longest running working is more then a month, by that time i was sure the issue was gone (right after flash of 18.06.2) but then it slowly started to randomly drop connection to the radio.

worth noting the 5 GHz radio never does this so its a contained issue to the 2.4 GHz. probably driver related?

i have tested it with: 17 (Lede) and 18.06 all point versions tested with same issue, and the time it takes are never the same, so it feels random.

i have thought of deploying a counter measure to run a scripted interface restart of the 2.4 GHz every week. i know its wrong to work around the problem and not fixing it but this issue seems to live on forever.

Björn Strömberg commented on 10.04.2020 06:31

tested on 19.07.1 and it still happens about once a week or so.

just flashed 19.07.2 and will see if it continues, otherwise i'll create a cron script that restarts 2.4gz wifi so i don't have to do it manually.

zorxd commented on 10.04.2020 11:56

we should make a script which restart the 2.4 GHz radio periodically, only if there is no association

Björn Strömberg commented on 12.04.2020 07:31

ofcourse it would not restart if we got associated clients on the interface..
no need to restart a working interface..

Björn Strömberg commented on 18.04.2020 12:27

is there any interest for the script?

mocked up a quick test, and can put it up on github after i clean it up, if its needed by anyone else..

pretty simple, enable cron, run it every 15 minutes and check if any wifi interface missing connected clients, then it just restarts wifi. missing the only restart only 2.4GHz interface right now, but thats cause this was more a internal test dummy for now..

zorxd commented on 18.04.2020 12:33

Yes, I would be interested
Thanks

Björn Strömberg commented on 18.04.2020 13:15

there you go.

it mitigates the issue on my end at least,
if it can help others until the bug is fixed..

Alban Bedel commented on 23.05.2020 10:55

I see a similar problem with TL-WR1043ND v2 which also use QCA9558. We are running a medium sized network with many clients coming and going all the time and this bug seems to happen every couple of days.

This bug is still present with 19.07.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing