OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Michael Heimpold - 05.10.2019

FS#2534 - ath79: no ethernet link and console on TP-Link TL-WA901ND v2

I found an older device TP-Link TL-WA901ND v2 in my rack and tried to install latest OpenWrt master (27bf8abe69)
on it. I used the ath79 target with a mostly default minimal configuration.

The device comes up, but no Ethernet link is established with my switch.
This worked of course before (I had an older OpenWrt ar7100 image on it).

Also, I get no serial console so I can only update via U-Boot and ymodem protocol (not tested whether network works in U-Boot).

I attach a full trace of the boot process. Hints are welcome :-)

Michael Heimpold commented on 07.10.2019 21:22

Just for the record, the missing serial console was due to my own stupidy: I accidentally included a self-made /etc/inittab from an other development session in the build which broke the console spawning.

Project Manager
Adrian Schmutzler commented on 06.11.2019 17:42

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing