OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by sanitariu - 24.09.2019
Last edited by Petr Štetiar - 24.09.2019

FS#2518 - make kernel_menuconfig bug

make kernel_menuconfig - for kernel configuration
does not work correctly. It was working before some releases.
make menuconfig is working okay.
The error is:

HOSTLD  scripts/kconfig/mconf

/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: scripts/kconfig/lxdialog/checklist.o: undefined reference to symbol ‘keypad’ /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: /lib64/libtinfow.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make[4]: *** [scripts/Makefile.host:111: scripts/kconfig/mconf] Error 1

Seems like somewhere is missing -ltinfo or similar linking.
Problem is not my OS because make menuconfig is working and we have
dialog menus.

This is tested on latest openwrt
Step to reproduce:
1. Download openwrt
2. do make kernel_menuconfig


Closed by  Petr ┼átetiar
24.09.2019 11:34
Reason for closing:  Duplicate
Additional comments about closing:  

Duplicate of  FS#2423 

sanitariu commented on 24.09.2019 11:15

cd build_dir/target-mipsel_24kc_musl/linux-ramips_mt76x8/linux-4.14.146
make menuconfig
works as expected.
Problem is when calling maker kernel_menuconfig from main openwrt directory

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing