OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Leo - 08.09.2019
Last edited by Christian Lamparter - 13.09.2019

FS#2486 - kmod-crypto-ctr package does not include module

On target ipq40xx the kmod-crypto-ctr package does not seem to work. E.g.

modprobe ctr
failed to find a module named ctr

whereas this works on ramips device I have.

Looking in more detail I can see on the ipq40xx device that:

opkg files kmod-crypto-ctr
Package kmod-crypto-ctr (4.14.131-1) is installed on root and has the following files:
/etc/modules.d/09-crypto-ctr

whereas on the other device:

opkg files kmod-crypto-ctr
Package kmod-crypto-ctr (4.14.95-1) is installed on root and has the following files:
/lib/modules/4.14.95/ctr.ko
/etc/modules.d/09-crypto-ctr

This can also be looked by inspecting the ipk files which do not contain a ko file within the data.tar.gz. I have checked this on build 18.06.4, but it seems to also be a problem on 18.06.3 and snapshot.

Closed by  Christian Lamparter
13.09.2019 18:24
Reason for closing:  Not a bug
Additional comments about closing:  

Various crypto modules (ciphers+support) are built into the kernel itself for the IPQ40xx target (see the target's config). That's why the "kmod" packages are empty, they only provide the dependency information for other modules or userspace packages that require them.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing