OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To
    Mathias Kresin
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by DuDu371 - 24.10.2016
Last edited by Mathias Kresin - 30.11.2016

FS#245 - Lede won't boot on HHB5

I compile the lastest trunk for the HHB5 and when i flash it, it won’t start.

This is the error:

[    1.706208] UBI: auto-attach mtd4
[    1.707898] ubi0: attaching mtd4
[    2.348403] ubi0: scanning is finished
[    2.389984] ubi0: attached mtd4 (name "ubi", size 125 MiB)
[    2.394069] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 129024 bytes
[    2.400911] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 512
[    2.407615] ubi0: VID header offset: 512 (aligned 512), data offset: 2048
[    2.414403] ubi0: good PEBs: 1003, bad PEBs: 0, corrupted PEBs: 0
[    2.420495] ubi0: user volume: 1, internal volumes: 1, max. volumes count: 128
[    2.427724] ubi0: max/mean erase counter: 763/549, WL threshold: 4096, image sequence number: 798035625
[    2.437122] ubi0: available PEBs: 0, total reserved PEBs: 1003, PEBs reserved for bad PEB handling: 20
[    2.446496] ubi0: background thread "ubi_bgt0d" started, PID 321
[    2.558727] UBIFS (ubi0:0): background thread "ubifs_bgt0_0" started, PID 323
[    2.664864] UBIFS (ubi0:0): recovery needed
[    2.775528] UBIFS (ubi0:0): recovery completed
[    2.778662] UBIFS (ubi0:0): UBIFS: mounted UBI device 0, volume 0, name "rootfs"
[    2.785954] UBIFS (ubi0:0): LEB size: 129024 bytes (126 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
[    2.795864] UBIFS (ubi0:0): FS size: 124895232 bytes (119 MiB, 968 LEBs), journal size 9033728 bytes (8 MiB, 71 LEBs)
[    2.806476] UBIFS (ubi0:0): reserved for root: 0 bytes (0 KiB)
[    2.812316] UBIFS (ubi0:0): media format: w4/r0 (latest is w4/r0), UUID B7954C8C-A34D-48A9-AAFD-A629B0B29387, small LPT model
[    2.826076] UBIFS error (ubi0:0 pid 1): ubifs_read_node: bad node type (255 but expected 0)
[    2.833023] UBIFS error (ubi0:0 pid 1): ubifs_read_node: bad node at LEB 131:117552, LEB mapping status 1
[    2.842569] Not a node, first 24 bytes:
[    2.846234] 00000000: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff                          ........................
[    2.859292] CPU: 0 PID: 1 Comm: swapper Not tainted 4.4.27 #0
[    2.865021] Stack : 805f6562 00000001 00000000 00000000 87c28280 8049ed63 80427540 00000001
	  805f37bc 87f50000 804499f0 00000000 00000001 800545d0 804499f0 00000000
	  00000001 801675d0 8042db38 87c2db2c 000000a5 8005257c 00000001 87f50000
	  00000018 00000000 00000000 00000000 00000000 00000000 00000000 00000000
	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
	  ...
[    2.900509] Call Trace:
[    2.902991] [<8001734c>] show_stack+0x50/0x84
[    2.907352] [<80144728>] ubifs_read_node+0x2f0/0x34c
[    2.912310] [<80164ba4>] ubifs_tnc_read_node+0x94/0x1a0
[    2.917526] [<80148538>] ubifs_tnc_locate+0xec/0x21c
[    2.922484] [<8013ee30>] ubifs_iget+0x98/0x6f0
[    2.926923] [<80140b48>] ubifs_mount+0x16c0/0x18e8
[    2.931722] [<800c1748>] mount_fs+0x20/0xb8
[    2.935899] [<800db0e4>] vfs_kern_mount+0x68/0x138
[    2.940682] [<800de6c4>] do_mount+0x9b0/0xc38
[    2.945029] [<800deccc>] SyS_mount+0xb0/0xf4
[    2.949300] [<804c13bc>] mount_root+0x60/0x138
[    2.953734] [<804c1654>] prepare_namespace+0x1c0/0x1f8
[    2.958868] [<804c0e00>] kernel_init_freeable+0x1f8/0x228
[    2.964279] [<80006c58>] kernel_init+0x10/0x114
[    2.968789] [<80002478>] ret_from_kernel_thread+0x14/0x1c
[    2.974174] 
[    2.975640] UBIFS error (ubi0:0 pid 1): ubifs_iget: failed to read inode 1, error -22
[    2.984912] UBIFS (ubi0:0): background thread "ubifs_bgt0_0" stops
[    2.990562] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[    2.997183] Please append a correct "root=" boot option; here are the available partitions:
[    3.005521] 1f00             256 mtdblock0  (driver?)
[    3.010563] 1f01             256 mtdblock1  (driver?)
[    3.015591] 1f02             128 mtdblock2  (driver?)
[    3.020639] 1f03            2048 mtdblock3  (driver?)
[    3.025708] 1f04          128384 mtdblock4  (driver?)
[    3.030731] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    3.041015] Rebooting in 1 seconds..

I think it’s a problem with the recent commit about ubifs becouse previusly it work just fine. I tried on 2 idential devices (HHB5) and none of them want to boot

Closed by  Mathias Kresin
30.11.2016 08:12
Reason for closing:  Fixed
Additional comments about closing:  

ht tps://git.lede-project.org/0e34459e6b4d7 b3753b27cf97f304f86e80155ca

Project Manager
Mathias Kresin commented on 28.10.2016 07:47
  • does your HH5a has bad blocks (check the u-boot output)?
  • did it worked on exactly these hubs before or are these new hubs?
  • would you please link the mentioned ubifs commit (or provide at least the commit hash)!
DuDu371 commented on 05.11.2016 00:34

- Yes, they have badblock but before, they work just fine
- I was wrong, it wasn't a ubifs commit. I think that was a kernel update commit

BTW now both are working just fine if i load the squashfs image, otherwise if i load the ubifs the wifi don't work (2.4Ghz)

Project Manager
Mathias Kresin commented on 16.11.2016 09:31

I've explained in an BT Homehub specific forum what I mean is the reason for the ubifs errors: http://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=133#p1022.

Would you please test if the issue is gone using my development repository:

  1. build an image from: https://github.com/mkresin/lede
  2. restore to the BT Firmware using this (install) initramfs image (it should be tftp booted from the OpenWrt U-boot): https://github.com/mkresin/lede/releases
  3. install the image you build from https://github.com/mkresin/lede using the (install) initramfs image mentioned in 2.

Have a look at bills guide linked in http://openwrt.ebilan.co.uk/viewtopic.php?p=1395#p1395. It is pretty much complete and explains the required steps in detail.

Project Manager
Mathias Kresin commented on 24.11.2016 08:21

Hey DuDu371,

does the LEDE version from my GitHub repository works for you? I'm planning to push the changes to LEDE soon and having a confirmation that the issue you have seen is really fixed would be great.

DuDu371 commented on 27.11.2016 18:48

The version from the GitHub of Mathias Kresin it's fully working and it fixes the badblocks bug in the nand of the BTHomeHub5. I recommended to merge mkresing changes to the mainline of Lede

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing