OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To
    Adrian Schmutzler
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by salted - 07.08.2019
Last edited by Petr Štetiar - 03.01.2020

FS#2430 - Broken sysupgrade path from ubnt-erx to ubiquiti_edgerouterx due to NAND platform checks

Openwrt stable release fails to upgrade to the latest snapshot build with the message

Invalid sysupgrade file.
Image check 'platform_check_image' failed.

Supply the following if possible:
- Device problem occurs on

 Ubiquiti EdgeRouter X

- Software versions of OpenWrt/LEDE release, packages, etc.

 openwrt 18.06 -> latest snapshot

- Steps to reproduce

  1. Run
    sysupgrade -v openwrt-ramips-mt7621-ubiquiti_edgerouterx-squashfs-sysupgrade.bin
Closed by  Petr Štetiar
03.01.2020 16:58
Reason for closing:  Won't fix
Additional comments about closing:  

I think, that it's not that big deal to upgrade from 18.06 to 19.07 and then to snapshot or use `sysupgrade -F` from 18.06, since you're going to run development snapshot anyway.

salted commented on 07.08.2019 16:35

I think setting trunk as "Reported version" would be more fitting. Unfortunately I can't change my own tasks.

Project Manager
Baptiste Jonglez commented on 03.01.2020 15:54

I can reproduce this issue.

It would seem it is cause by this commit:

https://git.openwrt.org/2f2a319f82ec86e2008fd056987d74189d5c147b

Although it adds the old name "ubnt-erx" to SUPPORTED_DEVICES, so it should work.

On a 18.06.5 initramfs image:

root@OpenWrt:/tmp# cat /tmp/sysinfo/board_name 
ubnt-erx
root@OpenWrt:/tmp# cat /tmp/sysinfo/model 
UBNT-ERX
Project Manager
Baptiste Jonglez commented on 03.01.2020 16:02

Alright, sysupgrade fails in nand_do_platform_check because of this requirement of the sysupgrade image: https://git.openwrt.org/?p=openwrt/openwrt.git;a=blob;f=package/base-files/files/lib/upgrade/nand.sh;h=e7d7bf8d13ae43e330abefbc9c678707e6a03bc9;hb=HEAD#l294

3) TAR - archive has to include "sysupgrade-BOARD" directory with a non-empty
   "CONTROL" file (at this point its content isn't verified)

The new sysupgrade image has the new boardname in the tar file:

$ tar tf openwrt-ramips-mt7621-ubiquiti_edgerouterx-squashfs-sysupgrade.bin
sysupgrade-ubiquiti_edgerouterx/
sysupgrade-ubiquiti_edgerouterx/CONTROL
sysupgrade-ubiquiti_edgerouterx/kernel
sysupgrade-ubiquiti_edgerouterx/root

So, it definitely can’t work currently. I’m not sure if there’s an easy way to fix this.

Admin
Petr Štetiar commented on 03.01.2020 16:56

I've just upgraded my ERX from 18.06.5 to 19.07.0-rc2 and then to snapshot.
I've just upgraded my ERX from 18.06.5 to snapshot with `sysupgrade -F`.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing