OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Neil Aspinall - 05.08.2019
Last edited by Hauke Mehrtens - 18.08.2019

FS#2427 - ath10k with QCA9984 causes reboot on first client connect

On a master build of OpenWrt, using kmod-ath10k (as opposed to kmod-ath10k-ct) with a device with a QCA9984 wireless chipset causes reboots of OpenWrt every time a wireless client connects.
This appears to be related to the recent bump of mac80211 to 5.2-rc7.

To reproduce:

-Run an x86 or ipq806x build from master, on a device with a QCA9984 wireless chipset (e.g. Netgear R7800)
-If already installed, remove kmod-ath10k-ct and ath10k-firmware-qca9984-ct
-Install kmod-ath10k and ath10k-firmware-qca9984 (and hostapd/wpad)
-Configure and enable wireless access point
-On first client connect, OpenWrt will reboot

 


Closed by  Hauke Mehrtens
18.08.2019 19:27
Reason for closing:  Fixed
Additional comments about closing:  

This was fixed in https:/ /git.openwrt.org/2ceee0e02362519f08be2a2 88bd8f42ca6cef257

Hannu Nyman commented on 05.08.2019 17:46

duplicate (with x86 evidence) of  FS#2414 

Project Manager
Petr Štetiar commented on 07.08.2019 07:36
duplicate (with x86 evidence) of  FS#2414 

symptoms looks same, but there's no evidence (log of the crash) as in  FS#2414  so we don't know if it's duplicate (yet).

If you're able to reproduce this on x86, then it's very likely, that you can simply run the upstream kernel 5.2 or 5.3 and thus can try to reproduce it there. If the issue is present in the upstream kernel as well, then you can ask for the help on the ath10k mailing list.

Project Manager
Hauke Mehrtens commented on 07.08.2019 18:38

This branch still contains some more backports version between 4.19 and 5.2, could you please check with which version this problem started:
https://git.openwrt.org/?p=openwrt/staging/hauke.git;a=shortlog;h=refs/heads/mac80211-5.0

Hannu Nyman commented on 08.08.2019 20:20

A brief summary of my longer test report in the IPQ806X bug report.

Thanks for pointer to those intermediate commits in your staging tree. I checked it out and built minimal versions of the firmware. baseline and three first commits worked ok, but then the chrasing starts :-(

The culprit is the bump to 5.1-rc2-1:

 commit ba5b3ce570ea3abb7a05d00fd6d4d4a32804b0e4
 mac80211: update to version 5.0.5-1
 OK
 commit a9e9bdb8ba26ae3cf9df0a230d8eacd92deac821
 mac80211: Update to version 5.1-rc2-1
 CRASH

https://git.openwrt.org/?p=openwrt/staging/hauke.git;a=commit;h=a9e9bdb8ba26ae3cf9df0a230d8eacd92deac821

Pure guess, but that commit seems to remove some airtime related patches, and like I have said earlier, the crash always happens at:
PC is at ieee80211_sta_register_airtime+0x24/0x148 [mac80211]

Project Manager
Hauke Mehrtens commented on 18.08.2019 14:13

I proposed a patch to test in the last comment of  FS#2414 

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing