OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Toolchain
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by mistepien - 02.08.2019
Last edited by Petr Štetiar - 08.08.2019

FS#2424 - generator of images cannot find wireless-regdb

Supply the following if possible:
- Device problem occurs on
- Software versions of OpenWrt/LEDE release, packages, etc.
- Steps to reproduce

 

Device:
ubnt_unifiac-lite

Version: snapshot

Steps to reproduce: make image PROFILE=ubnt_unifiac-lite PACKAGES=”luci-ssl”

I got:

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-ath10k-ct:
 * 	wireless-regdb
 * opkg_install_cmd: Cannot install package kmod-ath10k-ct.
Closed by  Petr Štetiar
08.08.2019 19:53
Reason for closing:  Fixed
Additional comments about closing:  

Should be fixed via http://lists.infradead.org/pipermail/ openwrt-devel/2019-August/018378.html

Hannu Nyman commented on 02.08.2019 14:38

Compiling it currently fails at buildbot (at least in some buildslaves) due to python reasons:
https://downloads.openwrt.org/snapshots/faillogs/arm_cortex-a15_neon-vfpv4/base/wireless-regdb/compile.txt

Applying ./patches/500-world-regd-5GHz.patch using plaintext: 
patching file db.txt
Traceback (most recent call last):
  File "/builder/shared-workdir/build/sdk/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/wireless-regdb-2019.06.03/db2fw.py", line 6, in <module>
    from dbparse import DBParser
  File "/builder/shared-workdir/build/sdk/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/wireless-regdb-2019.06.03/dbparse.py", line 3, in <module>
    from builtins import bytes
ImportError: No module named builtins
Makefile:31: recipe for target '/builder/shared-workdir/build/sdk/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/wireless-regdb-2019.06.03/.built' failed
make[3]: *** [/builder/shared-workdir/build/sdk/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/wireless-regdb-2019.06.03/.built] Error 1
time: package/feeds/base/wireless-regdb/compile#0.21#0.09#0.44

Possible fix might be coming in
https://git.openwrt.org/?p=openwrt/staging/ynezz.git;a=commitdiff;h=3b2b62d556ba2787736b11788c44400394dd933a;hp=781933f348d0541a014f935b7dc62d469f439643

Project Manager
Hauke Mehrtens commented on 07.08.2019 18:48

Do you still have this problem?

I think it is fixed with this commit:
https://git.openwrt.org/b6bae4a2c9f11f7e55319c2b4c709396ce649688

Daniel Dickinson commented on 08.08.2019 06:58

Sorry that doesn't fix it – the python script now exclusively works with python3. Python3 in $(STAGING_DIR_HOST)/bin/$(PYTHON3) is required to solve this build issue.

Admin
Petr Štetiar commented on 08.08.2019 15:50
Sorry that doesn't fix it

Please don't hijack someone else's issues, if you're experiencing some problems, please create another issue.

Admin
Petr Štetiar commented on 08.08.2019 15:55
I think it is fixed with this commit:

It seems like it needs more work, I've forget about the fact, that the packages are built with SDK, so need to take a look at the Python situation in the SDK as well.

  bash: /builder/shared-workdir/build/sdk/staging_dir/host/bin/python: No such file or directory

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing