OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Packages
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by joaohcca - 25.07.2019

FS#2404 - mac80211 causing process to be tainted with CF-E375AC AP

Supply the following if possible:
- Device problem occurs on ar71xx device CF-E375AC running custom build openwrt release 18.06-4
- Steps to reproduce: boot the ap

 

When booting the freshly installed firmware for the device points a kernel trace for mac80211 and after a few days devices presents other processes being tainted. Sometimes the AP enters a bootloop.

wireless config

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '149'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option country 'BR'
	option noscan '1'
	option htmode 'VHT20'
	option txpower '21'
	option legacy_rates '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option encryption 'none'
	option ssid '_FREE - Boulevard Londrina'
	option network 'MGT'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/qca956x_wmac'
	option htmode 'HT20'
	option country 'BR'
	option noscan '1'
	option txpower '20'
	option legacy_rates '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option encryption 'none'
	option ssid '_FREE - Boulevard Londrina'
	option network 'MGT'

config wifi-iface 'monitor'
	option mode 'monitor'
	option ifname 'wlan1'
	option device 'radio1'

dmesg

dmesg

Starting kernel ...

[    0.000000] Linux version 4.9.184 (joao@joao-Elcomasv-01) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r7808-ef686b7292) ) #0 Thu Jun 27 12:18:52 2019
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019750 (MIPS 74Kc)
[    0.000000] SoC: Qualcomm Atheros QCA956X ver 1 rev 0
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 08000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
[    0.000000] Kernel command line:  board=CF-E375AC mtdparts=spi0.0:256k(u-boot)ro,64k(art)ro,16000k(firmware),64k(art-backup)ro console=ttyS0,115200 rootfstype=squasd
[    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 125204K/131072K available (2969K kernel code, 166K rwdata, 688K rodata, 264K init, 202K bss, 5868K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:51
[    0.000000] Clocks: CPU:775.000MHz, DDR:650.000MHz, AHB:258.333MHz, Ref:25.000MHz
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 4932285024 ns
[    0.000007] sched_clock: 32 bits at 387MHz, resolution 2ns, wraps every 5541893118ns
[    0.008213] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
[    0.071024] pid_max: default: 32768 minimum: 301
[    0.075975] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.082947] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.092686] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.103093] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.110007] NET: Registered protocol family 16
[    0.115951] MIPS: machine is Vagalume Bolt VB-2x2ACW2c
[    0.355073] registering PCI controller with io_map_base unset
[    0.372363] PCI host bridge to bus 0000:00
[    0.376735] pci_bus 0000:00: root bus resource [mem 0x12000000-0x13ffffff]
[    0.383972] pci_bus 0000:00: root bus resource [io  0x0001]
[    0.389848] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.396994] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.405717] pci 0000:00:00.0: BAR 0: assigned [mem 0x12000000-0x121fffff 64bit]
[    0.413440] pci 0000:00:00.0: using irq 40 for pin 1
[    0.419261] clocksource: Switched to clocksource MIPS
[    0.425467] NET: Registered protocol family 2
[    0.430794] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.438144] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.444888] TCP: Hash tables configured (established 1024 bind 1024)
[    0.451676] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.457840] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.464673] NET: Registered protocol family 1
[    0.473479] Crashlog allocated RAM at address 0x3f00000
[    0.480033] workingset: timestamp_bits=30 max_order=15 bucket_order=0
[    0.492302] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.498444] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.516852] io scheduler noop registered
[    0.521023] io scheduler deadline registered (default)
[    0.526761] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[    0.533822] console [ttyS0] disabled
[    0.557661] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 1562500) is a 16550A
[    0.566760] console [ttyS0] enabled
[    0.566760] console [ttyS0] enabled
[    0.574311] bootconsole [early0] disabled
[    0.574311] bootconsole [early0] disabled
[    0.586037] m25p80 spi0.0: found w25q128, expected m25p80
[    0.602431] m25p80 spi0.0: w25q128 (16384 Kbytes)
[    0.607315] 4 cmdlinepart partitions found on MTD device spi0.0
[    0.613443] Creating 4 MTD partitions on "spi0.0":
[    0.618393] 0x000000000000-0x000000040000 : "u-boot"
[    0.625174] 0x000000040000-0x000000050000 : "art"
[    0.631774] 0x000000050000-0x000000ff0000 : "firmware"
[    0.664207] 2 uimage-fw partitions found on MTD device firmware
[    0.670357] 0x000000050000-0x000000190000 : "kernel"
[    0.676639] 0x000000190000-0x000000ff0000 : "rootfs"
[    0.683215] mtd: device 4 (rootfs) set to be root filesystem
[    0.689095] 1 squashfs-split partitions found on MTD device rootfs
[    0.695523] 0x000000780000-0x000000ff0000 : "rootfs_data"
[    0.702897] 0x000000ff0000-0x000001000000 : "art-backup"
[    0.710979] libphy: Fixed MDIO Bus: probed
[    0.726468] switch0: Atheros AR8337 rev. 2 switch registered on ag71xx-mdio.0
[    1.412424] libphy: ag71xx_mdio: probed
[    2.040719] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.0:00 [uid=004dd036, driver=Atheros AR8216/AR8236/AR8316]
[    2.052293] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:SGMII
[    2.059534] NET: Registered protocol family 17
[    2.064275] 8021q: 802.1Q VLAN Support v1.8
[    2.076210] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    2.084960] Freeing unused kernel memory: 264K
[    2.089572] This architecture does not have kernel memory protection.
[    2.569272] random: fast init done
[    2.760552] init: Console is alive
[    2.764248] init: - watchdog -
[    3.977559] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    4.108734] usbcore: registered new interface driver usbfs
[    4.114527] usbcore: registered new interface driver hub
[    4.120102] usbcore: registered new device driver usb
[    4.129935] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    4.138061] ehci-platform: EHCI generic platform driver
[    4.143580] ehci-platform ehci-platform.0: EHCI Host Controller
[    4.149748] ehci-platform ehci-platform.0: new USB bus registered, assigned bus number 1
[    4.160192] ehci-platform ehci-platform.0: irq 48, io mem 0x1b000000
[    4.189296] ehci-platform ehci-platform.0: USB 2.0 started, EHCI 1.00
[    4.196670] hub 1-0:1.0: USB hub found
[    4.200906] hub 1-0:1.0: 1 port detected
[    4.205265] ehci-platform ehci-platform.1: EHCI Host Controller
[    4.211453] ehci-platform ehci-platform.1: new USB bus registered, assigned bus number 2
[    4.221929] ehci-platform ehci-platform.1: irq 49, io mem 0x1b400000
[    4.249282] ehci-platform ehci-platform.1: USB 2.0 started, EHCI 1.00
[    4.256657] hub 2-0:1.0: USB hub found
[    4.260906] hub 2-0:1.0: 1 port detected
[    4.265722] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    4.283589] init: - preinit -
[    4.902115] random: procd: uninitialized urandom read (4 bytes read)
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[    5.950668] eth0: link up (1000Mbps/Full duplex)
[    7.134519] jffs2_scan_eraseblock(): End of filesystem marker found at 0x10000
[    7.142015] jffs2_build_filesystem(): unlocking the mtd device... [    7.148247] done.
[    7.150250] jffs2_build_filesystem(): erasing all blocks after the end marker... [   40.101846] done.
[   40.103865] jffs2: notice: (379) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan.
[   40.121131] mount_root: overlay filesystem has not been fully initialized yet
[   40.144134] mount_root: switching to jffs2 overlay
- config restore -
[   40.891517] urandom-seed: Seed file not found (/etc/urandom.seed)
[   41.055180] eth0: link down
[   41.067481] procd: - early -
[   41.071131] procd: - watchdog -
[   41.675949] procd: - watchdog -
[   41.679461] procd: - ubus -
[   41.836269] random: ubusd: uninitialized urandom read (4 bytes read)
[   41.843476] random: ubusd: uninitialized urandom read (4 bytes read)
[   41.850479] random: ubusd: uninitialized urandom read (4 bytes read)
[   41.857766] procd: - init -
Please press Enter to activate this console.
[   42.242647] kmodloader: loading kernel modules from /etc/modules.d/*
[   42.253640] mpls_gso: MPLS GSO support
[   42.259786] tun: Universal TUN/TAP device driver, 1.6
[   42.265003] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
[   42.344745] gre: GRE over IPv4 demultiplexor driver
[   42.351617] ip_gre: GRE over IPv4 tunneling driver
[   42.365385] Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)
[   42.389574] u32 classifier
[   42.392378]     input device check on
[   42.396157]     Actions configured
[   42.402000] Mirror/redirect action on
[   42.411848] nf_conntrack version 0.5.0 (2048 buckets, 8192 max)
[   42.435201] Loading modules backported from Linux version wt-2017-11-01-0-gfe248fc2c180
[   42.443511] Backport generated by backports.git v4.14-rc2-1-31-g86cf0e5d
[   42.698554] xt_time: kernel timezone is -0000
[   42.749861] ip_tables: (C) 2000-2006 Netfilter Core Team
[   42.874032] PPP generic driver version 2.4.2
[   42.880654] NET: Registered protocol family 24
[   42.912501] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[   42.918648] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
[   43.134524] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:00:00.0.bin failed with error -2
[   43.145628] ath10k_pci 0000:00:00.0: Falling back to user helper
[   84.055863] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA9888/hw2.0/firmware-6.bin failed with error -2
[   84.066949] ath10k_pci 0000:00:00.0: Falling back to user helper
[   84.170018] firmware ath10k!QCA9888!hw2.0!firmware-6.bin: firmware_loading_store: map pages failed
[   84.913900] ath10k_pci 0000:00:00.0: qca9888 hw2.0 target 0x01000000 chip_id 0x00000000 sub 0000:0000
[   84.923457] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
[   84.943976] ath10k_pci 0000:00:00.0: firmware ver 10.4-3.5.3-00053 api 5 features no-p2p,mfp,peer-flow-ctrl,allows-mesh-bcast,no-ps crc32 a9603656
[   85.261989] ath10k_pci 0000:00:00.0: board_file api 2 bmi_id 0:16 crc32 d65c17b1
[   87.464734] ath10k_pci 0000:00:00.0: htt-ver 2.2 wmi-op 6 htt-op 4 cal pre-cal-file max-sta 512 raw 0 hwcrypto 1
[   87.713530] ieee80211 phy1: Atheros AR9561 Rev:0 mem=0xb8100000, irq=47
[   87.726840] kmodloader: done loading kernel modules from /etc/modules.d/*
[   88.378445] urandom_read: 5 callbacks suppressed
[   88.378452] random: jshn: uninitialized urandom read (4 bytes read)
[   98.603267] br-MGT: port 1(eth0.2) entered blocking state
[   98.608854] br-MGT: port 1(eth0.2) entered disabled state
[   98.614759] device eth0.2 entered promiscuous mode
[   98.619749] device eth0 entered promiscuous mode
[   99.630857] eth0: link up (1000Mbps/Full duplex)
[   99.635911] br-MGT: port 1(eth0.2) entered blocking state
[   99.641529] br-MGT: port 1(eth0.2) entered forwarding state
[  100.263145] ath: EEPROM regdomain: 0x804c
[  100.267293] ath: EEPROM indicates we should expect a country code
[  100.273629] ath: doing EEPROM country->regdmn map search
[  100.279110] ath: country maps to regdmn code: 0x3b
[  100.284066] ath: Country alpha2 being used: BR
[  100.288651] ath: Regpair used: 0x3b
[  100.292254] ath: regdomain 0x804c dynamically updated by user
[  100.298263] ath: EEPROM regdomain: 0x804c
[  100.302410] ath: EEPROM indicates we should expect a country code
[  100.308695] ath: doing EEPROM country->regdmn map search
[  100.314179] ath: country maps to regdmn code: 0x3b
[  100.319115] ath: Country alpha2 being used: BR
[  100.323702] ath: Regpair used: 0x3b
[  100.327297] ath: regdomain 0x804c dynamically updated by user
[  104.596722] br-MGT: port 2(wlan1-1) entered blocking state
[  104.602515] br-MGT: port 2(wlan1-1) entered disabled state
[  104.608471] device wlan1-1 entered promiscuous mode
[  104.613654] br-MGT: port 2(wlan1-1) entered blocking state
[  104.619344] br-MGT: port 2(wlan1-1) entered forwarding state
[  110.212741] br-MGT: port 3(wlan0) entered blocking state
[  110.218260] br-MGT: port 3(wlan0) entered disabled state
[  110.224106] device wlan0 entered promiscuous mode
[  110.595493] br-MGT: port 3(wlan0) entered blocking state
[  110.601046] br-MGT: port 3(wlan0) entered forwarding state
[  110.634029] ------------[ cut here ]------------
[  110.639103] WARNING: CPU: 0 PID: 2163 at backports-2017-11-01/net/mac80211/driver-ops.h:167 ieee80211_channel_switch+0x73c/0x145c [mac80211]
[  110.652478] Modules linked in: ath9k ath9k_common pppoe ppp_async ath9k_hw ath10k_pci ath10k_core ath pppox ppp_generic mac80211 iptable_nat iptable_mangle iptable_n
[  110.741498] CPU: 0 PID: 2163 Comm: iw Not tainted 4.9.184 #0
[  110.747337] Stack : 804676c2 00000030 00000000 00000001 864407cc 803fac07 803c5af0 00000873
[  110.756208]         80463800 000000a7 00000000 00000008 00000000 800a98ec 803cb430 80400000
[  110.765050]         00000003 000000a7 803c95a8 86635b04 00000000 800d7cfc 804676c2 00000080
[  110.773930]         00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[  110.783024]         00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[  110.791867]         ...
[  110.794457] Call Trace:
[  110.797073] [<8006b210>] show_stack+0x70/0x8c
[  110.801705] [<80080244>] __warn+0x110/0x118
[  110.806033] [<800802e0>] warn_slowpath_null+0x1c/0x2c
[  110.811521] [<8779da7c>] ieee80211_channel_switch+0x73c/0x145c [mac80211]
[  110.818570] ---[ end trace 2ca9776b1b5452c5 ]---
[  111.969383] random: crng init done


after some time running my dmesg gets flooded with aftera wireless interface event such as interfaces going up or down

 [85176.137055] ------------[ cut here ]------------
[85176.142034] WARNING: CPU: 0 PID: 0 at backports-2017-11-01/net/mac80211/rx.c:629 ieee80211_rx_napi+0x8a4/0x8cc [mac80211]
[85176.153375] Modules linked in: pppoe ppp_async ath9k pppox ppp_generic nf_tables_inet nf_nat_pptp nf_conntrack_pptp iptable_nat ipt_REJECT ipt_MASQUERADE ebtable_nat ebtable_filter ebtable_broute ath9k_common ath10k_pci ath10k_core xt_time xt_tcpudp xt_tcpmss xt_string xt_statistic xt_state xt_recent xt_quota xt_pkttype xt_owner xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_iface xt_hl xt_helper xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_addrtype xt_TCPMSS xt_REDIRECT xt_NETMAP xt_LOG xt_LED xt_HL xt_DSCP xt_CT xt_CLASSIFY ts_fsm ts_bm slhc nft_set_rbtree nft_set_hash nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir_ipv4 nft_redir nft_quota nft_numgen nft_nat nft_meta nft_masq_ipv4 nft_masq nft_log nft_limit nft_exthdr nft_ct nft_counter
[85176.227405]  nft_chain_route_ipv6 nft_chain_route_ipv4 nft_chain_nat_ipv4 nf_tables_ipv6 nf_tables_ipv4 nf_tables nf_reject_ipv4 nf_nat_tftp nf_nat_snmp_basic nf_nat_sip nf_nat_redirect nf_nat_proto_gre nf_nat_masquerade_ipv6 nf_nat_masquerade_ipv4 nf_nat_irc nf_conntrack_ipv6 nf_nat_ipv6 nf_conntrack_ipv4 nf_nat_ipv4 nf_nat_h323 nf_nat_ftp nf_nat_amanda nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_tftp nf_conntrack_snmp nf_conntrack_sip nf_conntrack_rtcache nf_conntrack_proto_gre nf_conntrack_netlink nf_conntrack_irc nf_conntrack_h323 nf_conntrack_ftp nf_conntrack_broadcast ts_kmp nf_conntrack_amanda mac80211 iptable_raw iptable_mangle iptable_filter ipt_ECN ip_tables ebtables ebt_vlan ebt_stp ebt_redirect ebt_pkttype ebt_mark_m ebt_mark ebt_limit ebt_ip6 ebt_among ebt_802_3 crc_itu_t crc_ccitt ath9k_hw ath arptable_filter arpt_mangle arp_tables sch_cake act_connmark nf_conntrack act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_tbf sch_htb sch_hfsc sch_ingress ledtrig_oneshot ledtrig_heartbeat ledtrig_gpio batman_adv libcrc32c cfg80211 compat xt_set ip_set_list_set ip_set_hash_netiface ip_set_hash_netport ip_set_hash_netnet ip_set_hash_net ip_set_hash_netportnet ip_set_hash_mac ip_set_hash_ipportnet ip_set_hash_ipportip ip_set_hash_ipport ip_set_hash_ipmark ip_set_hash_ip ip_set_bitmap_port ip_set_bitmap_ipmac ip_set_bitmap_ip ip_set nfnetlink ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables x_tables bonding ip6_gre ip_gre gre ifb ip6_tunnel tunnel6 ip_tunnel tun mpls_gso mpls_iptunnel mpls_router eeprom_93cx6 vxlan udp_tunnel ip6_udp_tunnel ledtrig_transient ehci_platform ehci_hcd gpio_button_hotplug button_hotplug input_core usbcore nls_base usb_common crc16 crc32c_generic crypto_hash
[85176.390181] CPU: 0 PID: 0 Comm: swapper Tainted: G        W       4.9.120 #0
[85176.397457] Stack : 804b7672 00000040 00000000 00000001 804455fc 80445267 8040dd88 00000000
[85176.406156]         804b37c0 00000275 00000004 86b35f18 00000000 800a957c 804135f8 80440000
[85176.414856]         00000003 00000275 804117b0 87c09d2c 00000000 800d8cfc 804b7672 0000006d
[85176.423556]         804573d0 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[85176.432256]         00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[85176.440957]         ...
[85176.443494] Call Trace:
[85176.446019] [<8006b280>] show_stack+0x70/0x8c
[85176.450541] [<800802f4>] __warn+0x110/0x118
[85176.454863] [<80080390>] warn_slowpath_null+0x1c/0x2c
[85176.460255] [<870256f4>] ieee80211_rx_napi+0x8a4/0x8cc [mac80211]
[85176.466657] [<8680719c>] ath_rx_tasklet+0xba0/0xcd8 [ath9k]
[85176.472442] [<868047d4>] ath9k_tasklet+0x1a8/0x218 [ath9k]
[85176.478112] [<800833e4>] tasklet_action+0x8c/0xc4
[85176.482979] [<80082cbc>] __do_softirq+0x164/0x294
[85176.487839] [<801f3e88>] plat_irq_dispatch+0xf8/0x110
[85176.493081] [<80066378>] handle_int+0x138/0x144
[85176.497764] [<80067e6c>] r4k_wait_irqoff+0x18/0x24
[85176.502724] [<800a43c8>] cpu_startup_entry+0xa8/0xe0
[85176.507867] [<80469b90>] start_kernel+0x444/0x464
[85176.512738] ---[ end trace 730d2fbada3594cc ]---

opkg-list installed

arptables - 2015-05-20-f4ab8f63-1
ath9k-htc-firmware - 2017-09-06-a61ac5cf-1
base-files - 192-r7258-5eb055306f
batctl - 2018.1-0
busybox - 1.28.3-4
ca-bundle - 20180409
ca-certificates - 20180409
coova-chilli - 1.3.0+20141128-6
curl - 7.60.0-3
dnsmasq-full - 2.80test3-1
dropbear - 2017.75-5
ethtool - 4.15-1
firewall - 2018-07-26-aa8846bb-1
freeradius3 - release_3_0_11-3
freeradius3-common - release_3_0_11-3
fstools - 2018-04-16-e2436836-1
fwtool - 1
gre - 1-8
hostapd-common - 2018-04-09-fa617ee6-5
ip-bridge - 4.16.0-4
ip-full - 4.16.0-4
ip6tables - 1.6.2-1
iperf3 - 3.5-1
iptables - 1.6.2-1
iptables-mod-conntrack-extra - 1.6.2-1
iptables-mod-extra - 1.6.2-1
iptables-mod-filter - 1.6.2-1
iptables-mod-iface - 2.14-4
iptables-mod-ipopt - 1.6.2-1
iptables-mod-led - 1.6.2-1
iw - 4.14-1
iwinfo - 2018-07-24-94b1366d-1
jshn - 2018-07-25-c83a84af-1
jsonfilter - 2018-02-04-c7e938d6-1
kernel - 4.9.120-1-a2e1b2cfaa4dcfcd239532722f434a93
kmod-arptables - 4.9.120-1
kmod-ath - 4.9.120+2017-11-01-1
kmod-ath10k - 4.9.120+2017-11-01-1
kmod-ath9k - 4.9.120+2017-11-01-1
kmod-ath9k-common - 4.9.120+2017-11-01-1
kmod-batman-adv - 4.9.120+2018.1-2
kmod-bonding - 4.9.120-1
kmod-button-hotplug - 4.9.120-3
kmod-cfg80211 - 4.9.120+2017-11-01-1
kmod-crypto-crc32c - 4.9.120-1
kmod-crypto-hash - 4.9.120-1
kmod-ebtables - 4.9.120-1
kmod-ebtables-ipv6 - 4.9.120-1
kmod-eeprom-93cx6 - 4.9.120-1
kmod-gpio-button-hotplug - 4.9.120-2
kmod-gre - 4.9.120-1
kmod-gre6 - 4.9.120-1
kmod-hwmon-core - 4.9.120-1
kmod-ifb - 4.9.120-1
kmod-input-core - 4.9.120-1
kmod-ip6-tunnel - 4.9.120-1
kmod-ip6tables - 4.9.120-1
kmod-ipt-conntrack - 4.9.120-1
kmod-ipt-conntrack-extra - 4.9.120-1
kmod-ipt-core - 4.9.120-1
kmod-ipt-extra - 4.9.120-1
kmod-ipt-filter - 4.9.120-1
kmod-ipt-iface - 4.9.120+2.14-4
kmod-ipt-ipopt - 4.9.120-1
kmod-ipt-ipset - 4.9.120-1
kmod-ipt-led - 4.9.120-1
kmod-ipt-nat - 4.9.120-1
kmod-ipt-nat-extra - 4.9.120-1
kmod-ipt-raw - 4.9.120-1
kmod-iptunnel - 4.9.120-1
kmod-iptunnel6 - 4.9.120-1
kmod-leds-gpio - 4.9.120-1
kmod-ledtrig-default-on - 4.9.120-1
kmod-ledtrig-gpio - 4.9.120-1
kmod-ledtrig-heartbeat - 4.9.120-1
kmod-ledtrig-netdev - 4.9.120-1
kmod-ledtrig-oneshot - 4.9.120-1
kmod-ledtrig-timer - 4.9.120-1
kmod-ledtrig-transient - 4.9.120-1
kmod-lib-crc-ccitt - 4.9.120-1
kmod-lib-crc-itu-t - 4.9.120-1
kmod-lib-crc16 - 4.9.120-1
kmod-lib-crc32c - 4.9.120-1
kmod-lib-textsearch - 4.9.120-1
kmod-libphy - 4.9.120-1
kmod-mac80211 - 4.9.120+2017-11-01-1
kmod-mpls - 4.9.120-1
kmod-nf-conntrack - 4.9.120-1
kmod-nf-conntrack-netlink - 4.9.120-1
kmod-nf-conntrack6 - 4.9.120-1
kmod-nf-ipt - 4.9.120-1
kmod-nf-ipt6 - 4.9.120-1
kmod-nf-nat - 4.9.120-1
kmod-nf-nat6 - 4.9.120-1
kmod-nf-nathelper - 4.9.120-1
kmod-nf-nathelper-extra - 4.9.120-1
kmod-nf-reject - 4.9.120-1
kmod-nf-reject6 - 4.9.120-1
kmod-nfnetlink - 4.9.120-1
kmod-nft-core - 4.9.120-1
kmod-nft-nat - 4.9.120-1
kmod-nls-base - 4.9.120-1
kmod-ppp - 4.9.120-1
kmod-pppoe - 4.9.120-1
kmod-pppox - 4.9.120-1
kmod-sched-cake - 4.9.120+2018-07-16-f39ab9a4-1
kmod-sched-connmark - 4.9.120-1
kmod-sched-core - 4.9.120-1
kmod-slhc - 4.9.120-1
kmod-swconfig - 4.9.120-1
kmod-tun - 4.9.120-1
kmod-udptunnel4 - 4.9.120-1
kmod-udptunnel6 - 4.9.120-1
kmod-usb-core - 4.9.120-1
kmod-usb-ehci - 4.9.120-1
kmod-usb2 - 4.9.120-1
kmod-vxlan - 4.9.120-1
libattr - 20170915-1
libbfd - 2.27-1
libblobmsg-json - 2018-07-25-c83a84af-1
libc - 1.1.19-1
libcap - 2.25-2
libcares - 1.14.0-1
libcurl - 7.60.0-3
libgcc - 7.3.0-1
libgmp - 6.1.2-1
libiconv-full - 1.11.1-3
libintl-full - 0.19.8.1-1
libip4tc - 1.6.2-1
libip6tc - 1.6.2-1
libiwinfo - 2018-07-24-94b1366d-1
libiwinfo-lua - 2018-07-24-94b1366d-1
libjson-c - 0.12.1-1
libjson-script - 2018-07-25-c83a84af-1
libltdl - 2.4.6-1
liblua - 5.1.5-1
liblzo - 2.10-1
libmbedtls - 2.12.0-1
libmnl - 1.0.4-1
libmosquitto-ssl - 1.5-3
libncurses - 6.1-1
libnetfilter-conntrack - 2017-07-25-e8704326-1
libnetsnmp - 5.7.3-9
libnettle - 3.3-1
libnfnetlink - 1.0.1-1
libnl-core - 3.3.0-1
libnl-genl - 3.3.0-1
libnl-tiny - 0.1-5
libopcodes - 2.27-1
libopenssl - 1.0.2p-1
libpcap - 1.8.1-1
libpcre - 8.41-2
libpthread - 1.1.19-1
libreadline - 7.0-1
librrd1 - 1.0.50-2
librt - 1.1.19-1
libtalloc - 2.1.11-1
libubox - 2018-07-25-c83a84af-1
libubus - 2018-07-26-40e0931e-1
libubus-lua - 2018-07-26-40e0931e-1
libuci - 2018-08-11-4c8b4d6e-1
libuci-lua - 2018-08-11-4c8b4d6e-1
libuclient - 2018-08-03-ae1c656f-1
libustream-openssl - 2018-05-22-5322f9db-1
libuuid - 2.32-2
libwebsockets-openssl - 2.4.1-2
libxtables - 1.6.2-1
logd - 2018-02-14-128bc35f-2
lua - 5.1.5-1
luafilesystem - 1.6.2-1
luci - git-17.060.28258-2685855-1
luci-app-firewall - git-17.060.28258-2685855-1
luci-app-openvpn - git-17.060.28258-2685855-1
luci-app-qos - git-17.060.28258-2685855-1
luci-app-uhttpd - 1.0.0-1
luci-base - git-17.060.28258-2685855-1
luci-lib-ip - git-17.060.28258-2685855-1
luci-lib-json - git-17.060.28258-2685855-1
luci-lib-jsonc - git-17.060.28258-2685855-1
luci-lib-nixio - git-17.060.28258-2685855-1
luci-mod-admin-full - git-17.060.28258-2685855-1
luci-mod-rpc - git-17.060.28258-2685855-1
luci-proto-ipv6 - git-17.060.28258-2685855-1
luci-proto-ppp - git-17.060.28258-2685855-1
luci-theme-bootstrap - git-17.060.28258-2685855-1
mosquitto-client-ssl - 1.5-3
mosquitto-ssl - 1.5-3
mtd - 23
mtr - 0.85+newdns-dd2b75080bc5406ba0b438953b36b72204ba114b-2
netifd - 2018-07-30-a0a1e52e-1
ntpclient - 2010_365-1
odhcp6c - 2018-07-14-67ae6a71-14
odhcpd-ipv6only - 1.10-1
openssl-util - 1.0.2p-1
openvpn-openssl - 2.4.5-4
openwisp-config-openssl - 0.4.5-2
openwrt-keyring - 2018-05-18-103a32e9-1
opkg - 2017-12-07-3b417b9f-2
ppp - 2.4.7-12
ppp-mod-pppoe - 2.4.7-12
procd - 2018-03-28-dfb68f85-1
qos-scripts - 1.3.1-1
relayd - 2016-02-07-ad0b25ad-2
resolveip - 2
rpcd - 2018-08-16-41333abe-1
rpcd-mod-file - 2018-08-16-41333abe-1
rpcd-mod-iwinfo - 2018-08-16-41333abe-1
rpcd-mod-rpcsys - 2018-08-16-41333abe-1
rrdtool1 - 1.0.50-2
snmp-utils - 5.7.3-9
snmpd - 5.7.3-9
sqm-scripts - 1.2.3-1
sqm-scripts-extra - 2016-06-08-1
swconfig - 11
tc - 4.16.0-4
tcpdump-mini - 4.9.2-1
terminfo - 6.1-1
uboot-envtools - 2018.03-1
ubox - 2018-02-14-128bc35f-2
ubus - 2018-07-26-40e0931e-1
ubusd - 2018-07-26-40e0931e-1
uci - 2018-08-11-4c8b4d6e-1
uclient-fetch - 2018-08-03-ae1c656f-1
uhttpd - 2018-06-26-796d42bc-1
uhttpd-mod-ubus - 2018-06-26-796d42bc-1
usign - 2015-07-04-ef641914-1
wifischedule - 1-2
wireless-regdb - 2017-10-20-4343d359
wireless-tools - 29-5
wpa-cli - 2018-04-09-fa617ee6-5
wpad-mesh - 2018-04-09-fa617ee6-5
zabbix-agentd - 3.2.7-2
zabbix-extra-mac80211 - 3.2.7-2
zabbix-extra-network - 3.2.7-2
zabbix-extra-wifi - 3.2.7-2
zlib - 1.2.11-2

If I disable the wireless interfaces the messages stop. Also sometimes the AP reboot on its own I’m attaching a dmesg I manage so get when the AP reboots.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing