OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by EpeR1 - 14.07.2019
Last edited by Petr Štetiar - 17.07.2019

FS#2385 - Some of AR71xx devices enters a reboot-loop in wifi client (sta) mode

Dear OpenWRT Team,

Some of my ar71xx devices enters in a reboot-loop, when Ap’s signal is lost, in Client (sta) mode. I do not know what I am doing wrong, but I tested with:

8devices Carambola2 (AR9331-AL1F cpu, 16MB flash, 64MB RAM)
8devices Centipede (AR9331-AL1A cpu, 16MB flash, 64MB RAM)
TP-Link TL-WR740N/v4 (AR9331-AL3A cpu, 4MB flash, 32MB RAM)

And I tested on LEDE v17.01.4, v17.01.6, OpenWRT v18.06.1, v18.06.4 versions, but no difference. (Downloaded from openwrt’s “Stable Builds” page)

What I did:
Switched these devices to ‘sta’ mode, adjusted wpa2 password, BSSID, network device, etc..
Everything is working correctly, I was able to ping google, etc.
Then I switched off my Ap (pulled out of the socket)
About 3 minutes after, the Carambola2, and Centipede rebooted.
Circa 10 minutes later the TP-Link is also rebooted.

If I did not switched on my Ap, the Carambola2 and Centipede rebooted in every 3 minutes, and the TP-Link in every 15 minutes.
A few seconds before every reboot, the system on these boards was fully freezed, I could not press enter, or type anything. (I was using a USB-serial adapter)

After circa 6-8 reboot, the Carambola2 was fully freezed, and never reboots anymore.

If switched on my Ap, while devices was rebooting, then everything worked correctly, and well.

I observed that, If the wireless network was opened (passwordless), the frequency of rebooting, was slower, Carambola2 was rebooted in every 5-8 minutes, instead of 3 minutes.

My Ap is a TL-WR1043ND with OpenWRT/LEDE v17.01.3 ooperating system.

I am not sure it Is a power supply problem on Carambola2/Centipede, because if I switched to Ap mode these devices, the system was stable, I could connect with my mobile phone, I could done some speed-test, and the device never rebooted. On TP-Link, I used an original AC adapter.

I tryed Carambola2 with OpenWRT ATH79xx Snapshot version, but if I switched to sta mode (on Luci page), the whole system was fully freezed, and never rebooted, and I could not continue adjusting password, networtk, etc.
Later I checked (with: “ubus call system watchdog” command) the watchdog was offline (by default), so it does not rebooted.

+1 Information:
The Leds on Carambola2, in ATH79xx snapshot image, is switched, so eth0’s led is blinking on eth1’s socket, and reverse.

Here is some (re)boot-log, with my comments:
https://pastebin.com/1EQtBuV8

https://pastebin.com/jivjVhqh

Closed by  Petr Štetiar
17.07.2019 13:16
Reason for closing:  Works for me
Project Manager
Petr Štetiar commented on 17.07.2019 13:14
About 3 minutes after, the Carambola2, and Centipede rebooted.

I've just tested this on my C2 on snapshot and 18.06.4 release and I'm not able to reproduce it. I've my C2 powered from the laptop's USB socket.

After circa 6-8 reboot, the Carambola2 was fully freezed, and never reboots anymore.

Probably bootloader issue for details see https://github.com/openwrt/openwrt/pull/747

The Leds on Carambola2, in ATH79xx snapshot image, is switched, so eth0's led is blinking on eth1's socket, and reverse.

I'm not seeing this in the latest ath79 snapshot image.

Later I checked (with: "ubus call system watchdog" command) the watchdog was offline (by default), so it does not rebooted.

Ok, I've fixed this in https://git.openwrt.org/d50a2b6f7d57212ec2d9a111a8a7dd35e0533c35

EpeR1 commented on 24.07.2019 12:19

Thank you for repairing watchdog, now is working correctly.

The status of the interface LEDS in not clear, I think they are still swapped, and the documentation on 8device's page is wrong:
(attached image)

Or the whole interfaces are swapped in OpenWRT. (also in previous versions of OpenWRT)

Please test it again.

I have a Carambola2 development board with hardware version: 0700_0003
( https://www.8devices.com/media/products/carambola2/downloads/carambola2-dev_board-schematics.pdf )

With the wireless issue, I don't have any progress, just a workaround, I added one UPS to my wifi Ap.

Project Manager
Petr Štetiar commented on 24.07.2019 16:32

From schematics and datasheet it's following:

  • GPIO13/LED2 → ETH0
  • GPIO14/LED3 → ETH1

I don't see swapped interfaces between releases, my status LEDs blink correctly (run ping and I see orange LED blinking on correct port), so it's probably 8Devices who has eth0=J3/eth1=J4 swapped in Development board details and should correct it.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing