OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Packages
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Tom - 12.07.2019
Last edited by Petr Štetiar - 14.07.2019

FS#2382 - OpenVPN restart places 1-2 new protocols in config file, causing VPN to break.

Supply the following if possible:
- Device problem occurs on
- Software versions of OpenWrt/LEDE release, packages, etc.
- Steps to reproduce

 

Using OpenWRT .06, newest. Install the following to get OpenVPN running via Software tab:

openvpn-openssl
luci-app-openvpn
openssl-util

I go in to OpenVPN → Advanced and fill out everything (under client to client configuration). Only authentication I use is a user/pass in addition to a CA certificate.

THE ISSUE: Any time I make a change in the GUI or the VPN goes down, it will not restart itself until I SSH in to the config file and remove sometimes both, or just one line.

Error in System Log:

Fri Jul 12 00:28:59 2019 daemon.err openvpn(Mullvad_client)[3649]: Options error: specify only one of –tls-server, –tls-client, or –secret
Fri Jul 12 00:28:59 2019 daemon.warn openvpn(Mullvad_client)[3649]: Use –help for more information.

Protocol 1 that gets added by itself each time a change is made or VPN restarts:
secret shared-secret.key

Protocol 2:
Unable to paste it due to Terminal Log exhausted and reset.

But each of the two lines are for authentication, and I am using a text file for Authentication in the openvpn folder /etc/openvpn/userpass.txt

I have done factory Resets and it is a pain each time I need to make a change or VPN goes down, I must SSH and remove a line, the same ones each time.

Closed by  Petr ┼átetiar
14.07.2019 19:32
Reason for closing:  Different project
Additional comments about closing:  

Problems to be reported here are for the OpenWrt/LEDE Project targets, sources, toolchain, core packages, build procedures, distribution and infrastructure. Guidelines for submitting a good bug report can be found at the OpenWrt/LEDE Project website. Problems related to LuCI or OpenWrt packages need to be reported in their repositories:

  LuCI -
https://github.com/openwrt/luci/issues
  Packages -
https://github.com/openwrt/packages/issu
es
Tom commented on 12.07.2019 00:44

Proper Build:
OpenWrt 18.06.4 r7808-ef686b7292

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing