OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Etienne CHAMPETIER - 03.07.2019

FS#2349 - gl-ar150 lan port always up when using ath79 & 19.07 (ar71xx ok)

Hello Team

Testing using OpenWrt 19.07-SNAPSHOT r10233-4a7a8d93fa, ath79 image, connected via wifi

removing both eth0 & eth1 from their interface, rebooting, then doing
# ip l set up eth0
# ip l set up eth1

eth0 (lan port) is always up even if no cables are connected (state UP, no NO-CARRIER)
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000

  link/ether e4:95:6e:45:32:f8 brd ff:ff:ff:ff:ff:ff

3: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000

  link/ether e4:95:6e:45:32:f8 brd ff:ff:ff:ff:ff:ff

I would say it’s a know bug because the led is configured to look at the switch and not the interface
ar71xx images are working ok

here part of the dmesg for ath79
[ 0.745353] ag71xx 19000000.eth: Could not connect to PHY device. Deferring probe.
[ 1.480124] ag71xx 1a000000.eth: connected to PHY at fixed-0:00 [uid=00000000, driver=Generic PHY]
[ 1.488671] eth0: Atheros AG71xx at 0xba000000, irq 5, mode: gmii
[ 1.865945] ag71xx 19000000.eth: connected to PHY at mdio-bus.0:1f:04 [uid=004dd041, driver=Generic PHY]
[ 1.875354] eth1: Atheros AG71xx at 0xb9000000, irq 4, mode: mii

and for ar71xx
[ 1.571027] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[ 2.244049] eth1: Atheros AG71xx at 0xba000000, irq 5, mode:GMII

the 2 ports are switched between ar71xx and ath79 images

I’ve tried to randomly change the dts, but I have no idea what I’m doing ...

Project Manager
Petr Štetiar commented on 04.07.2019 12:09
the 2 ports are switched between ar71xx and ath79 images

For the details about this change please see PR#2066 and following comment https://github.com/openwrt/openwrt/pull/2066#issuecomment-497351095

Etienne CHAMPETIER commented on 06.07.2019 02:53

Hi Petr,

Thanks for the link,
any pointer for for the always up port ? is it a know regression ?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing