OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Packages
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by nobk - 24.06.2019
Last edited by Petr Štetiar - 03.10.2019

FS#2337 - libgpg-error compile error with gawk-5.0+

Supply the following if possible:
- Device problem occurs on
build host with gawk 5.0+ installed.
- Software versions of OpenWrt/LEDE release, packages, etc.
git master
- Steps to reproduce
1. upgrade host gawk to 5.0+
2. make package/libgpg-error/clean
3. make -j1 V=s package/libgpg-error/compile

--CUT--
./mkerrcodes | gawk -f ./mkerrcodes2.awk >code-from-errno.h
gawk: ./mkerrcodes2.awk:94: warning: regexp escape sequence `\#' is not a known regexp operator
gawk -f ./mkstrtable.awk -v textidx=2 -v nogettext=1 \
        ./err-sources.h.in >err-sources-sym.h
gawk: ./mkstrtable.awk:113: warning: regexp escape sequence `\#' is not a known regexp operator
gawk -f ./mkstrtable.awk -v textidx=2 -v nogettext=1 \
        ./err-codes.h.in >err-codes-sym.h
gawk: ./mkstrtable.awk:113: warning: regexp escape sequence `\#' is not a known regexp operator
gawk -f ./mkstrtable.awk -v textidx=2 -v nogettext=1 \
        -v prefix=GPG_ERR_ -v namespace=errnos_ \
        ./errnos.in >errnos-sym.h
gawk: fatal: cannot use gawk builtin `namespace' as variable name
make[5]: *** [Makefile:1616: errnos-sym.h] Error 2
--CUT--
Closed by  Petr ┼átetiar
03.10.2019 19:12
Reason for closing:  Different project
Additional comments about closing:  

Problems to be reported here are for the OpenWrt/LEDE Project targets, sources, toolchain, core packages, build procedures, distribution and infrastructure. Guidelines for submitting a good bug report can be found at the OpenWrt/LEDE Project website. Problems related to LuCI or OpenWrt packages need to be reported in their repositories:

  LuCI -
https://github.com/openwrt/luci/issues
  Packages -
https://github.com/openwrt/packages/issu
es
Frederick Zhang commented on 03.10.2019 15:40

I can confirm this issue.

There is already a patch available at https://dev.gnupg.org/T4459 and I managed to build after applying it (src/Makefile.am hunk failed perhaps due to indentation, simple enough to manually replace 'namespace=' with 'pkg_namespace=' in the file) and running autogen.sh.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing