OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by AbraxasDMG - 19.06.2019

FS#2329 - openvpn: Options error: You must define TUN/TAP device (--dev)

Hi!

Installation of OpenWrt 18.06.2 On Linksys E900 router.
Nothing extraordinary in relation to flashing and initial configuration.

Configure first lan port as a connection towards the internal network. Everything working as expected.
Installed openvpn-openssl. Tried to configure it and ran into the error “Options error: You must define TUN/TAP device (–dev)”.

Nothing I tried resulted in disappearance of that error message.

Below are relevant configuration snippets.

/etc/config/network
config interface ‘loopback’ option ifname ‘lo’ option proto ‘static’ option ipaddr ‘127.0.0.1’ option netmask ‘255.0.0.0’

config globals ‘globals’ option ula_prefix ‘fdd3:5676:7153::/48’

config interface ‘lan’ option type ‘bridge’ option ifname ‘eth0.1’ option proto ‘static’ option netmask ‘255.255.255.0’ option ipaddr ‘192.168.100.2’ option dns ‘192.168.100.1’ option gateway ‘192.168.100.1’ option delegate ‘0’

config interface ‘wan’ option ifname ‘eth0.2’ option proto ‘dhcp’ option auto ‘0’

config interface ‘wan6’ option ifname ‘eth0.2’ option proto ‘dhcpv6’ option auto ‘0’

config switch
option name ‘switch0’ option reset ‘1’ option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’ option vlan ‘1’ option ports ‘0 1 2 3 5t’

config switch_vlan
option device ‘switch0’ option vlan ‘2’ option ports ‘4 5t’

config interface ‘vpn’ option proto ‘none’ option ifname ‘tun0’ option auto ‘1’

/etc/config/openvpn
config openvpn ‘udp1194’ option keepalive ‘10 60’ option server ‘192.168.168.0 255.255.255.0’ option persist_tun ‘1’ option persist_key ‘1’ option tls_auth ‘/etc/openvpn/ta.key’ option ca ‘/etc/openvpn/ca.crt’ option cert ‘/etc/openvpn/server.crt’ option key ‘/etc/openvpn/server.key’ option dh ‘/etc/openvpn/dh.pem’ option key_direction ‘0’ list push ‘redirect-gateway def1’ list push ‘dhcp-option DNS 8.8.4.4’ list push ‘dhcp-option DNS 8.8.8.8’ list push ‘block-outside-dns’ option cipher ‘AES-256-CBC’ option auth ‘SHA256’ option proto ‘udp’ option port ‘1194’ option enabled ‘1’ option verb ‘9’ option log_append ‘/tmp/openvpn-udp1194.log’ option dev ‘tun’

Thank you very much in advance.

 


AbraxasDMG commented on 19.06.2019 15:18

I am experiencing the disappearance of "package openvpn" from the first line of /etc/config/openvpn when manipulating the configuration (and saving/applying) via luci.

It might be that due to the lack of "package openvpn" the service start is attempted with "invalid configuration", where the service is not fed the appropriate details from the config file (dev tun/tap being one of the major ones). I edited the configuration through the ssh directly and restarted the router and the service started...

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing