OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Medium
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Kevin 'ldir' Darbyshire-Bryant - 18.06.2019
Last edited by Yousong Zhou - 03.11.2019

FS#2327 - /boot mounted multiple times

Supply the following if possible:
- Device problem occurs on- seen on x86 APU2 - may be others.
- Software versions of OpenWrt master
- Steps to reproduce - boot system

root@Router:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                14080     14080         0 100% /rom
tmpfs                  2011892       156   2011736   0% /tmp
/dev/loop0              246016     15140    161244   9% /overlay
overlayfs:/overlay      246016     15140    161244   9% /
/dev/sda1                16112      4172     11616  26% /boot
/dev/sda1                16112      4172     11616  26% /boot
tmpfs                      512         0       512   0% /dev
root@Router:/etc/config# block info
/dev/loop0: UUID="cbbd153a-60b0-40e0-800e-b79833957b9f" VERSION="1.12" MOUNT="/overlay" TYPE="f2fs"
/dev/sda1: UUID="57f8f4bc-abf4-655f-bf67-946fc0f9f25b" VERSION="1.0" MOUNT="/boot" TYPE="ext4"
/dev/sda2: UUID="b9caa0dd-b7eb255f-2c2775da-3aa40e49" VERSION="4.0" MOUNT="/rom" TYPE="squashfs"
/dev/sda3: UUID="e92b8416-fe49-409b-a4cf-c71476027159" VERSION="1.12" MOUNT="/mnt/sda3" TYPE="f2fs"
root@Router:/etc/config# cat /etc/config/fstab 

config global
	option anon_swap '0'
	option anon_mount '0'
	option auto_swap '1'
	option auto_mount '1'
	option delay_root '5'
	option check_fs '1'

config mount
	option target '/mnt/loop0'
	option uuid 'dd87006a-ba8e-44f4-a40b-f2cb6181dc4e'
	option enabled '0'

config mount
	option target '/mnt/sda1'
	option uuid '57f8f4bc-abf4-655f-bf67-946fc0f9f25b'
	option enabled '0'

config mount
	option target '/mnt/sda2'
	option uuid '8a1c0748-3d6b7bd1-0192e5c4-7fe0165c'
	option enabled '0'

config mount
	option target '/mnt/sda3'
	option uuid 'e92b8416-fe49-409b-a4cf-c71476027159'
	option enabled '1'
root@Router:/etc/config# uname -a
Linux Router 4.14.126 #0 SMP Tue Jun 18 09:45:23 2019 x86_64 GNU/Linux   

 
Closed by  Yousong Zhou
03.11.2019 05:14
Reason for closing:  Not a bug
Jeffery Wilkins commented on 25.07.2019 05:49

can confirm this on my APU2 as well

Project Manager
Yousong Zhou commented on 29.10.2019 09:01

This should be expected.

The boot partition itself has directory structure "/boot" inside it. When it was mounted on "/boot", we have "/boot/boot". Then we do "mount –bind /boot/boot /boot" to make eliminate the extra level.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing