OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by LGA1150 - 12.06.2019
Last edited by Ted Hess - 29.06.2019

FS#2317 - odhcpd: unstable NDP relay

odhcpd 2019-05-17-41a74cba, kernel 4.19.50

NDP relay sometimes does not work on some LAN clients, breaking their IPv6 connectivity
- Restarting odhcpd does not seem to help
- Can be temporarily solved by

ifup lan


Closed by  Ted Hess
29.06.2019 13:29
Reason for closing:  Not a bug
LGA1150 commented on 13.06.2019 06:02

Update:
- I found how to reproduce it: ping the router WAN interface gateway from a LAN client, IPv6 connection will break within 10 seconds
- WLAN client's connection is unaffected
- Switch driver is mv88e6xxx DSA
- Use brctl to remove the LAN port from the br-lan bridge and add it back immediately also temporarily fixes the connection

Now I think it's not related to odhcpd, but the DSA driver

Update 2:
Switched to swconfig, the issue is gone, so it was definitely DSA's bug

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing