OpenWrt/LEDE Project

  • Status Waiting on reporter
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Richard Tweed - 08.06.2019
Last edited by Petr Štetiar - 08.06.2019

FS#2314 - Random crashes on ZBT-WG3526 (16M) and OpenWrt 18.06.2 [ramips_mt7621]

Supply the following if possible:
- Device problem occurs on
ZBT-WG3526 (16M)
https://openwrt.org/toh/hwdata/zbt/zbt_wg3526_16m

- Software versions of OpenWrt/LEDE release, packages, etc.
Firmware
http://downloads.openwrt.org/releases/18.06.2/targets/ramips/mt7621/openwrt-18.06.2-ramips-mt7621-zbt-wg3526-16M-squashfs-sysupgrade.bin

- Steps to reproduce
Not known

I’ve attached the full list of installed packages and the crashlog I managed to recover. Possible relevant highlight below from the crashlog.

Also attached is the backup archive generated, with sensitive bits redacted (ie passwords)

I love OpenWrt and can’t wait to have a non crashing router.

If anything else is needed please let me know.

Thanks!


Project Manager
Petr Štetiar commented on 08.06.2019 04:59

From the logs it looks like you're running out of memory. Could you please try if the situation improves if you flash your router with the latest snapshot image? It should as well provide hopefully a better crashlog.

Richard Tweed commented on 08.06.2019 10:41

Sure, I'll try the snapshot. I'd be surprised if it's running out of memory since it has 512MB but it's worth a shot.

Thanks for the reply!

Richard Tweed commented on 08.06.2019 10:57

I had to roll back as luci isn't working on the snapshot. I kept getting connection refused. Thankfully ssh still worked.

Project Manager
Petr Štetiar commented on 09.06.2019 11:22
I'd be surprised if it's running out of memory since it has 512MB

If there is some memory leak issue in some package and/or kernel, then even 128GB wouldn't help you. You now have to find out which package is causing the issue you're experiencing, so ideally install one by one and check the memory.

I had to roll back as luci isn't working on the snapshot.

From https://openwrt.org/docs/guide-quick-start/developmentinstallation:

On snapshots, LuCi has to be installed manually (if needed).

Manual LuCi installation by package may require more free flash storage than a 4MB flash device can handle, see 4/32 device warning.

To manually install LuCi, follow the External LinkLuCI installation guide.

Richard Tweed commented on 12.06.2019 22:29

Petr, thanks for the suggestions. I've just flashed the snapshot and will update you on how that goes.

Thanks again

Richard Tweed commented on 30.06.2019 02:07

Managed to get a crashlog from the snapshot image. Please let me know if there's anything else that may help.

Regards,

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing