OpenWrt/LEDE Project

  • Status Waiting on reporter
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by pedro gapski - 31.05.2019
Last edited by Koen Vandeputte - 06.06.2019

FS#2303 - wpad-mesh crashes with encryption enabled

device is wdr3600

DISTRIB_ID=’OpenWrt’ DISTRIB_RELEASE=’18.06.2’ DISTRIB_REVISION=’r7676-cddd7b4c77’ DISTRIB_TARGET=’ar71xx/generic’ DISTRIB_ARCH=’mips_24kc’ DISTRIB_DESCRIPTION=’OpenWrt 18.06.2 r7676-cddd7b4c77’ DISTRIB_TAINTS=’’ r7676-cddd7b4c77

the rom is built with package builder:
PROFILE=tl-wdr3600-v1 PACKAGES=”luci luci-app-sqm conntrack kmod-usb2 kmod-usb-storage block-mount kmod-fs-ext4 e2fsprogs badblocks openssh-sftp-server luci-app-ddns libustream-openssl luci-app-openvpn openvpn-openssl -wpad-mini wpad-mesh-wolfssl”

my log is full of:
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.369096] ————[ cut here ]———— Fri May 31 10:15:26 2019 kern.warn kernel: [15298.373874] WARNING: CPU: 0 PID: 9955 at backports-2017-11-01/net/mac80211/wpa.c:431 0×87708734 [mac80211@87700000+0x5fc20]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.385196] Modules linked in: ath9k ath9k_common pppoe ppp_async ath9k_hw ath pppox ppp_generic nf_conntrack_netlink nf_conntrack_ipv6 mac80211 iptable_nat ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_helper xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_HL xt_DSCP xt_CT xt_CLASSIFY slhc nfnetlink nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_conntrack_ipv4 nf_nat_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache iptable_mangle iptable_filter ipt_ECN ip_tables crc_ccitt compat sch_cake nf_conntrack act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_tbf sch_htb
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.457266] sch_hfsc sch_ingress ledtrig_usbport ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables x_tables ifb tun usb_storage ehci_platform sd_mod scsi_mod ehci_hcd gpio_button_hotplug ext4 jbd2 mbcache usbcore nls_base usb_common crc16 crc32c_generic crypto_hash
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.484154] CPU: 0 PID: 9955 Comm: kworker/u2:1 Tainted: G W 4.9.152 #0
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.492028] Workqueue: phy1 0x876ec0a0 [ath9k@876e0000+0×16370]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.498054] Stack : 00000123 863d3af8 877cade0 800a931c 00000000 00000000 00000000 00000000
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.506616] 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.515169] 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.523713] 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.532259] 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.540812] ...
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.543314] Call Trace:
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.545666] [<800a931c>] 0x800a931c
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.549209] [<8006ad4c>] 0x8006ad4c
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.552762] [<8006ad4c>] 0x8006ad4c
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.556319] [<8007fd84>] 0x8007fd84
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.559868] [<87708734>] 0×87708734 [mac80211@87700000+0x5fc20]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.565911] [<8007fe20>] 0x8007fe20
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.569458] [<87708734>] 0×87708734 [mac80211@87700000+0x5fc20]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.575519] [<876e8ef8>] 0x876e8ef8 [ath9k@876e0000+0×16370]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.581343] [<87727ee0>] 0x87727ee0 [mac80211@87700000+0x5fc20]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.587439] [<8772ab3c>] 0x8772ab3c [mac80211@87700000+0x5fc20]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.593621] [<876e96e4>] 0x876e96e4 [ath9k@876e0000+0×16370]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.599368] [<87717930>] 0×87717930 [mac80211@87700000+0x5fc20]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.605451] [<876e97a8>] 0x876e97a8 [ath9k@876e0000+0×16370]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.611215] [<80065ea0>] 0x80065ea0
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.614822] [<87717490>] 0×87717490 [mac80211@87700000+0x5fc20]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.620903] [<876e9e1c>] 0x876e9e1c [ath9k@876e0000+0×16370]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.626721] [<876ea320>] 0x876ea320 [ath9k@876e0000+0×16370]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.632529] [<876ea410>] 0x876ea410 [ath9k@876e0000+0×16370]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.638353] [<87729fcc>] 0x87729fcc [mac80211@87700000+0x5fc20]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.644409] [<87727250>] 0×87727250 [mac80211@87700000+0x5fc20]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.650470] [<8772bcc4>] 0x8772bcc4 [mac80211@87700000+0x5fc20]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.656499] [<8027eb6c>] 0x8027eb6c
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.660132] [<8772d630>] 0x8772d630 [mac80211@87700000+0x5fc20]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.666162] [<802ad588>] 0x802ad588
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.669702] [<80450000>] 0×80450000 Fri May 31 10:15:26 2019 kern.warn kernel: [15298.673256] [<80082e74>] 0x80082e74
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.676808] [<8008274c>] 0x8008274c
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.680384] [<876ec15c>] 0x876ec15c [ath9k@876e0000+0×16370]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.686137] [<80082940>] 0×80082940 Fri May 31 10:15:26 2019 kern.warn kernel: [15298.689697] [<876ec088>] 0x876ec088 [ath9k@876e0000+0×16370]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.695462] [<800829f8>] 0x800829f8
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.699010] [<87682e5c>] 0x87682e5c [ath9k_hw@87680000+0×51020]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.705047] [<876ec16c>] 0x876ec16c [ath9k@876e0000+0×16370]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.710847] [<80092c70>] 0x80092c70
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.714427] [<800927f0>] 0x800927f0
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.718005] [<80093a7c>] 0x80093a7c
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.721542] [<80093788>] 0×80093788 Fri May 31 10:15:26 2019 kern.warn kernel: [15298.725094] [<80093788>] 0×80093788 Fri May 31 10:15:26 2019 kern.warn kernel: [15298.728651] [<80098220>] 0×80098220 Fri May 31 10:15:26 2019 kern.warn kernel: [15298.732204] [<80098144>] 0×80098144 Fri May 31 10:15:26 2019 kern.warn kernel: [15298.735759] [<80065ef8>] 0x80065ef8
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.739305]
Fri May 31 10:15:26 2019 kern.warn kernel: [15298.740822] —[ end trace 07a56879b3fe468f ]—

And wifi connectivity on radio0 is gone. There is another router on the mesh (WR740v4 with openwrt 18.06.2). I have tried with wpad-mesh-openssl but results were the same.

This mesh was configured about one week ago and was working fine for a few days, but since yesterday is show this behaviour. A reboot on this router does not solve the problem.

Configuration is as follows:
/etc/config/network:

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '10.10.0.1'

/etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ar934x_wmac'
        option country 'BR'
        option legacy_rates '1'
        option txpower '17'
        option channel '9'
        option htmode 'HT40'
        option disabled 0

config wifi-iface 'default_radio0'
        option device 'radio0'
        option ifname 'wlan0'
        option network 'lan'
        option mode 'ap'
        option ssid 'AP'
        option wds '0'
        option encryption 'psk2/aes'
        option key 'password'
        option wpa_disable_eapol_key_retries '1'
        option disabled 0

config wifi-iface 'mesh0'
        option network 'lan'
        option ifname 'mesh0'
        option device 'radio0'
        option mode 'mesh'
        option mesh_id 'meshid'
        option encryption 'psk2/aes'
        option key 'password'
        option mesh_fwding '1'
        option disabled 0
pedro gapski commented on 31.05.2019 13:27

sorry for the messed formating:

Fri May 31 10:26:25 2019 kern.warn kernel: [15957.703357] ------------[ cut here ]------------
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.708133] WARNING: CPU: 0 PID: 3 at backports-2017-11-01/net/mac80211/wpa.c:431 0x87708734 [mac80211@87700000+0x5fc20]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.719189] Modules linked in: ath9k ath9k_common pppoe ppp_async ath9k_hw ath pppox ppp_generic nf_conntrack_netlink nf_conntrack_ipv6 mac80211 iptable_nat ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_helper xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_HL xt_DSCP xt_CT xt_CLASSIFY slhc nfnetlink nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_conntrack_ipv4 nf_nat_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache iptable_mangle iptable_filter ipt_ECN ip_tables crc_ccitt compat sch_cake nf_conntrack act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_tbf sch_htb
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.791249]  sch_hfsc sch_ingress ledtrig_usbport ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables x_tables ifb tun usb_storage ehci_platform sd_mod scsi_mod ehci_hcd gpio_button_hotplug ext4 jbd2 mbcache usbcore nls_base usb_common crc16 crc32c_generic crypto_hash
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.818136] CPU: 0 PID: 3 Comm: ksoftirqd/0 Tainted: G        W       4.9.152 #0
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.825642] Stack : 804976e2 00000044 00000000 00000001 00000000 00000000 00000000 00000000
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.834201]         00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.842764]         00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.851326]         00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.859870]         00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.868424]         ...
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.870914] Call Trace:
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.873266] [<8006ad4c>] 0x8006ad4c
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.876835] [<8006ad4c>] 0x8006ad4c
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.880379] [<8007fd84>] 0x8007fd84
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.883925] [<87708734>] 0x87708734 [mac80211@87700000+0x5fc20]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.889978] [<8007fe20>] 0x8007fe20
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.893537] [<87708734>] 0x87708734 [mac80211@87700000+0x5fc20]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.899551] [<802b868c>] 0x802b868c
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.903160] [<87727ee0>] 0x87727ee0 [mac80211@87700000+0x5fc20]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.909282] [<8772ab3c>] 0x8772ab3c [mac80211@87700000+0x5fc20]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.915304] [<876e8ef8>] 0x876e8ef8 [ath9k@876e0000+0x16370]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.921221] [<876e96e4>] 0x876e96e4 [ath9k@876e0000+0x16370]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.927022] [<876e97a8>] 0x876e97a8 [ath9k@876e0000+0x16370]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.932808] [<87717490>] 0x87717490 [mac80211@87700000+0x5fc20]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.938907] [<876e9e1c>] 0x876e9e1c [ath9k@876e0000+0x16370]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.944676] [<87717490>] 0x87717490 [mac80211@87700000+0x5fc20]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.950758] [<876ea320>] 0x876ea320 [ath9k@876e0000+0x16370]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.956613] [<876ea410>] 0x876ea410 [ath9k@876e0000+0x16370]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.962408] [<87729fcc>] 0x87729fcc [mac80211@87700000+0x5fc20]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.968472] [<87727250>] 0x87727250 [mac80211@87700000+0x5fc20]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.974516] [<8772bcc4>] 0x8772bcc4 [mac80211@87700000+0x5fc20]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.980549] [<8027eb6c>] 0x8027eb6c
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.984161] [<8772d630>] 0x8772d630 [mac80211@87700000+0x5fc20]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.990202] [<802ad588>] 0x802ad588
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.993781] [<876e481c>] 0x876e481c [ath9k@876e0000+0x16370]
Fri May 31 10:26:25 2019 kern.warn kernel: [15957.999537] [<80450000>] 0x80450000
Fri May 31 10:26:25 2019 kern.warn kernel: [15958.003078] [<80082e74>] 0x80082e74
Fri May 31 10:26:25 2019 kern.warn kernel: [15958.006637] [<8008274c>] 0x8008274c
Fri May 31 10:26:25 2019 kern.warn kernel: [15958.010178] [<8009ff7c>] 0x8009ff7c
Fri May 31 10:26:25 2019 kern.warn kernel: [15958.013756] [<800828a4>] 0x800828a4
Fri May 31 10:26:25 2019 kern.warn kernel: [15958.017323] [<8009b6b0>] 0x8009b6b0
Fri May 31 10:26:25 2019 kern.warn kernel: [15958.020862] [<8009b828>] 0x8009b828
Fri May 31 10:26:25 2019 kern.warn kernel: [15958.024416] [<8009b6b0>] 0x8009b6b0
Fri May 31 10:26:25 2019 kern.warn kernel: [15958.027968] [<803ab6f0>] 0x803ab6f0
Fri May 31 10:26:25 2019 kern.warn kernel: [15958.031549] [<8009b6b0>] 0x8009b6b0
Fri May 31 10:26:25 2019 kern.warn kernel: [15958.035100] [<80098220>] 0x80098220
Fri May 31 10:26:25 2019 kern.warn kernel: [15958.038709] [<80098144>] 0x80098144
Fri May 31 10:26:25 2019 kern.warn kernel: [15958.042269] [<80065ef8>] 0x80065ef8
Fri May 31 10:26:25 2019 kern.warn kernel: [15958.045826]
Fri May 31 10:26:25 2019 kern.warn kernel: [15958.047355] ---[ end trace 07a56879b3fe46d3 ]---
Admin
Petr Štetiar commented on 31.05.2019 13:35

Please try to reproduce the problem with the latest development snapshots http://downloads.openwrt.org/snapshots/targets/ath79/generic/ as then you can increase your chances, that someone could take a look at this.

pedro gapski commented on 31.05.2019 13:55

This seems to be the same bug:
 FS#1372  - 802.11s Mesh with SAE / using wpad-mesh crashing randomly
https://bugs.openwrt.org/index.php?do=details&task_id=1372

pedro gapski commented on 31.05.2019 14:11

As suggested, I downloaded the snapshot, prepared an image and flashed the router to
DISTRIB_DESCRIPTION='OpenWrt SNAPSHOT r10102-678ee30'

I will post here if I see this wpa crash on this snapshot.

pedro gapski commented on 07.06.2019 12:51

This report has been altered to "Waiting on reporter." Please let me know which input are you waiting for.

Regarding the experiment on the r10102-678ee30 snapshot: I flashed the wdr3600 with the image generated from the image builder from the snapshot, and no change was made on the wr740. The image was generated as described above, but replacing '-wpad-mini' with '-wpad-basic'.

I did not see wpad-mesh crash during the ~24h that this configuration was online. However, although the mesh was up, there was no network connectivity: wifi client devices were assigned DHCP addresses but could not talk to other hosts, local or not. The configuration used was the same described above (that is, it was not changed).

Based on those results I reverted to my previous WDS setup.

My ultimate goal was to run the 802.11s encrypted mesh. Please advise on the best setup to achieve this goal.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing