OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version All
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Krystian Kozak - 17.04.2019

FS#2240 - Lantiq: AVM FRITZ!Box 7320 only one ETH port is working

Router has 2 ethernet ports, but the only first one is working.

Krystian Kozak commented on 21.05.2019 13:18

ETH1 is working only when connected on boot. ETH2 is not visible.
In attachment there is dump of dmesg.

   dmesg.txt (12.4 KiB)
Petr Štetiar commented on 21.05.2019 15:04

Do you know last working version/commit?

Krystian Kozak commented on 23.05.2019 15:28

Unfortunately, I do not know the version that works correctly.

I tested OpenWrt 18.06.2 and LEDE 17.01.6. In these versions, the same problem occurs. If you want, I can test OpenWrt 15.05 also.

Petr Štetiar commented on 24.05.2019 09:53
If you want, I can test OpenWrt 15.05 also

I've looked at the 15.05 bootlogs and there's only eth0, so it seems like the 2nd port isn't supported for some reason since the beginning (maybe the driver included in OpenWrt doesn't have support for it), although the vendor firmware supports it.

everloop2 commented on 11.07.2019 11:18

update: sorry false positive - FritzBox7320 has other network controllers.

there are 2 Lantiq PEF7071V V1.3 NICs (LAN1 and LAN2)

LAN1 is working, LAN2 does not work.

2nd LAN port would be nice

im no coder - played around with /firmware/openwrt/target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ7320.dts ,no luck so far

following belongs to FritzBox7330SL:

(search for ar8035 & ar8030 datasheet)
specs: LAN1 > Atheros AR8035
> single port 10/100/1000 Mbps Ethernet PHY
> RGMII MAC interface
> Co-layout support with 802.3az 10/100M PHY-AR8030 LAN2 > Atheros AR8030-A, SK4P7.4D 1242 CN
> single port 10/100 Mbps Ethernet PHY
> RMII MAC interface Is there an internal switch? OEM_EVA_AVM bootlog:
Atheros 8035 detected
Atheros 8030 detected
Unknown SPI device: 0xFF 0xFF 0xFF
ifx_spi_flash_init: Found no serial flash device
SWAPI: Registered character device [switch_api] with major no [81]
[avmnet] No config found for HWRev 188, HWSubRev 2, Profile-ID 0, trying base config for HWSubRev
[avmnet] No config found for HWRev 188, HWSubRev 2, trying base config for HWRev
{avmnet_mac_ar9_init} Init on module mac_ar9_0 called.
{avmnet_mac_ar9_init} Init on module mac_ar9_1 called.
[avmnet] [avmnet_mac_ar9_setup] IFX_AR9_ETH_CTL(0): 0x424001
[avmnet] [avmnet_mac_ar9_setup] mac_nr: 0, vlan_reg: 0x4070001
[avmnet] [avmnet_mac_ar9_setup] IFX_AR9_ETH_CTL(1): 0x424001
[avmnet] [avmnet_mac_ar9_setup] mac_nr: 1, vlan_reg: 0x4070001
[avmnet_set_macaddr] Setup Mac Addr for Device(eth0): 24:65:11:bd:fc:27
[avmnet_set_macaddr] Setup Mac Addr for Device(eth1): 24:65:11:bd:fc:28
eth: port 0 force normal CON t0
[avm_power] eth: port 1 force throttle CON t0
[avm_power] eth: port 2 force throttle CON t0
[avmnet] [avmnet_power_config] tried to set mode for port 2
[avm_power] : ethernet switch failed
[avm_power] eth: port 3 force throttle CON t0
[avmnet] [avmnet_power_config] tried to set mode for port 3
[avm_power] : ethernet switch failed
.. OpenWrt patches: Dont know if its already upstream: This patch Atheros phy AR8035-A switch support (Philippe DUCHEIN, 4 years ago) OpenWrt ar8035 patches dual-PHY-on-single-MDIO-bus?

rabbit83ka commented on 01.03.2020 09:29

On OpenWRT 19.07.1, on a Fritzbox 7330, ETH2 still isn't working and ETH1 has to be connected on boot to work.

Konstantinos Kostarellis commented on 05.03.2020 14:24

I can confirm that for OpenWrt 19.07.2 on Fritzbox 7320

rabbit83ka commented on 13.04.2020 07:21

Here is a fix for LAN1 to work also when not connected during boot which has to be tested.

everloop2 commented on 05.05.2020 09:40


OpenWRT Snapshot (2020.04.04), on a Fritzbox 7320, ETH2 isn't working.

ETH1 has to be connected on boot to work.

edit: 7330 → 7320


Available keyboard shortcuts


Task Details

Task Editing