OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by mhm322 - 10.04.2019
Last edited by Petr Štetiar - 17.04.2019

FS#2232 - Wifi LED on W8970 Not Working (v18.06.2)

Wifi led on tp-link w8970 not work. even in configuration section there is not a wlan led present
Device : TP-LINK W8970 v1.2
OpenWRT : 18.06.2
Reproduce : As i upgrade from v15 to 18.06.2 it goes off and not work anymore. wifi works well, but LED is off all time

 


Closed by  Petr Štetiar
17.04.2019 12:56
Reason for closing:  Fixed
Additional comments about closing:  

Thanks, fixed in https://git.o penwrt.org/?p=openwrt/openwrt.git;a=comm it;h=bd3a18bbe433cc53b6f86dd708477f97ac4 06abc

Admin
Petr Štetiar commented on 10.04.2019 08:17

I've attempted to fix this in https://git.openwrt.org/?p=openwrt/staging/ynezz.git;a=commit;h=8443c229f48332f9d56743f0fc6d6aff163619b6 could you please by any chance test this?

mhm322 commented on 12.04.2019 01:10

i dont know how to test this file ...
please help me, i'm newbie

Damian Janarek commented on 14.04.2019 11:17

Yup. Wifi led it's not working in 18.06.2 but in 18.06.1 it's working fine. In 18.06.1 in the LED configuration it looks ok (LED name tdw89x0:green:wifi) but in 18.06.2 is LED name tdw89x0:green:dsl and i can't change it to tdw89x0:green:wifi because tdw89x0:green:wifi not exist.

Admin
Petr Štetiar commented on 14.04.2019 22:28

I've built images for testing http://ynezz.true.cz/openwrt/fs2232/xrx200.tar but please note, that this images doesn't contain LuCI web interface, so you would need to enable the WiFi from SSH (command line) in order to test it (or you would need to install the LuCI packages manually).

Damian Janarek commented on 15.04.2019 15:51

I test the image and it works fine. So if i want to compile the image from sources i need change only one file (target/linux/lantiq/files-4.14/arch/mips/boot/dts/TDW89X0.dtsi) ?

Admin
Petr Štetiar commented on 15.04.2019 16:15
I test the image and it works fine.

Great, can i get your `Tested-by: Real Name real@email.com` so I can add it to the commit which fixes this issue?

So if i want to compile the image from sources i need change only one file (target/linux/lantiq/files-4.14/arch/mips/boot/dts/TDW89X0.dtsi)

Yes it's just this change https://git.openwrt.org/?p=openwrt/staging/ynezz.git;a=blobdiff;f=target/linux/lantiq/files-4.14/arch/mips/boot/dts/TDW89X0.dtsi;h=71e051a3164057530f2d3ed1413d76a792323155;hp=233b7e33342c86f9d84c88de1ef4c37c77f09cc9;hb=8443c229f48332f9d56743f0fc6d6aff163619b6;hpb=5bc2c8eecbf73e1b58c9a2cc460d84219f682f0b

Damian Janarek commented on 15.04.2019 16:17

Yes, you can add my real name and e-mail :)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing