OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by scxhwhb - 02.04.2019
Last edited by Petr Štetiar - 17.04.2019

FS#2219 - dhcp can not working with some client on v18.06.2

Supply the following if possible:
- Device problem occurs on

 D-Team Newifi D2 (Newifi3)

- Software versions of OpenWrt/LEDE release, packages, etc.

 v18.06.2

- Steps to reproduce

  I have a floor sweeper that can't connect to the Internet through the openwrt router, but it works under other routers.It is always discover DHCP by viewing the log.
      Tue Apr  2 20:53:02 2019 daemon.info dnsmasq-dhcp[9130]: DHCPDISCOVER(br-lan) b2:59:47:0e:6c:bd
      Tue Apr  2 20:53:02 2019 daemon.info dnsmasq-dhcp[9130]: DHCPOFFER(br-lan) 192.168.1.178 b2:59:47:0e:6c:bd
      Tue Apr  2 20:53:05 2019 daemon.info dnsmasq-dhcp[9130]: DHCPDISCOVER(br-lan) b2:59:47:0e:6c:bd
      Tue Apr  2 20:53:05 2019 daemon.info dnsmasq-dhcp[9130]: DHCPOFFER(br-lan) 192.168.1.178 b2:59:47:0e:6c:bd
      Tue Apr  2 20:53:08 2019 daemon.info dnsmasq-dhcp[9130]: DHCPDISCOVER(br-lan) b2:59:47:0e:6c:bd
      Tue Apr  2 20:53:08 2019 daemon.info dnsmasq-dhcp[9130]: DHCPOFFER(br-lan) 192.168.1.178 b2:59:47:0e:6c:bd
      Tue Apr  2 20:53:11 2019 daemon.info dnsmasq-dhcp[9130]: DHCPDISCOVER(br-lan) b2:59:47:0e:6c:bd
      Tue Apr  2 20:53:11 2019 daemon.info dnsmasq-dhcp[9130]: DHCPOFFER(br-lan) 192.168.1.178 b2:59:47:0e:6c:bd
      


Closed by  Petr ┼átetiar
17.04.2019 12:45
Reason for closing:  Not a bug
Additional comments about closing:  

Closing as requested.

Project Manager
Hans Dedecker commented on 02.04.2019 15:38

Looking into the tcpdump traces the NTP option is requested by the client but not present in the DHCP offer.This could be the reason why the client refuses to accept the DHCP offer messages; you could specify 192.168.1.1 as NTP server in the DHCP config

scxhwhb commented on 03.04.2019 12:58

I've tried it but it didn't work. The DHCP offer only on the lo interface but not exists on br-lan interface.I don't think it reached the client at all.

Project Manager
Hans Dedecker commented on 03.04.2019 14:05

What about other wireless devices; do they get an IP address via DHCP ? If yes you can exclude that DHCP messages do not reach the problematic client.

scxhwhb commented on 03.04.2019 15:07

DHCP offer for other wireless devices is via the br-lan interface, but the problematic client is via lo interface.

wulfy23 commented on 06.04.2019 08:11

[bad udp cksum 0xc2f8 → 0x335e!] @ tos 0xc0

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing