OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Ahmar Aftab - 18.03.2019
Last edited by Mathias Kresin - 07.11.2019

FS#2193 - netdev LED Trigger for pppoe-wan

Hi there, I am having a little issue with

netdev

LED trigger for DSL based routers. The issue occurs when the pppoe-wan connection gets connected but the assigned LED doesn’t light up and shows no activity either. I have two HH5As and one TP-Link TDW8980 and these devices are based on xrx200 chips.

The issue is appearing in master/snapshots builds, either manually compiled from source or downloaded from downloads.openwrt.org. Also the issue appears on all of the devices mentioned above.

To reproduce you can disconnect the pppoe-wan connection and connect it again. Once connected the LED wouldn’t light up but if you issue a

service led reload

command then LED starts working as it should.

Closed by  Mathias Kresin
07.11.2019 07:30
Reason for closing:  Fixed
Additional comments about closing:  

Fixed with https:/ /git.openwrt.org/edbadec843a77286d4f690a 3641b7bca97f4c998

Alan Swanson commented on 04.04.2019 11:47

Same issue here and as reported on mailing list http://lists.infradead.org/pipermail/openwrt-devel/2019-February/015740.html. Couldn't see where the suggested commits would break it, the ledtrig-netdev code is the essentially the same. It's almost as if the underlying device ID changes whilst device name doesn't?

[LINK UP - LED OFF]
# cd /sys/devices/platform/gpio-leds/leds/bthomehubv5a:blue:broadband/
# cat device_name
pppoa-wan
# echo pppoa-wan > device_name
[LED ON]
[LINK DROPS - LED OFF]
[LINK RECONNECTS - LED REMAINS OFF]

Ahmar commented on 20.04.2019 04:57

I have no idea what's going on and yes you captured the LED behaviour as it is. It won't turn on when link gets established but it gets turned off when the link gets disconnected which is very strange.

Also I observed something else, if I set a netdev trigger for vpn interface tun0 then the trigger works fine for it. The problem is that it does not work for wan interface only. Netdev trigger does work for other interfaces though.

Mauro Mozzarelli commented on 27.05.2019 12:04

I have the same issue on BtHomeHub5, however a "service led reload" has no effect.
This bug was introduced sometimes after "OpenWrt SNAPSHOT r8495-18c5e7b" which is the last build I have with a working LED.

This is my internet LED configuration in /etc/config/system

config led 'led_internet'

  option name 'internet'
  option sysfs 'bthomehubv5a:blue:broadband'
  option default '0'
  option trigger 'netdev'
  option dev 'pppoa-wan'
Alan Swanson commented on 30.05.2019 12:22

Per duplicate bug  FS#2239 , the commit (now upstream) causing the problem was https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=eea538204bb973d73d3bc3d38947d7f85214d486 removing the NETDEV_CHANGENAME handling to fix a refcnt leak.

Mauro Mozzarelli commented on 07.06.2019 17:17

Alan, I tried to remove that patch (patchfile: target/linux/generic/backport-4.14/401-v5.2-leds-trigger-netdev-fix-refcnt-leak-on-interface-ren.patch) and rebuild, but the LED still fails to work as expected. Is there anything else I might have missed?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing