OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Vivek - 14.03.2019
Last edited by Yousong Zhou - 18.03.2019

FS#2185 - DSA driver performance issue


Device: Linksys EA9500
Trunk: Kernel v4.19.25

I’ve compiled my own kernel and used DSA driver instead of swconfig
one for this router. Note: Kernel v4.19 enables broadcom tags for
B53 family of switches in this DSA driver

Here are some of my observations:

1. Lan to Lan speed is indeed 1Gbps (file copy)
2. However, Lan to Wan port is capped at ~500Mbps

 i. My internet is limited to 200Mbps, please see by test 
    setup below
ii. One of the users who has 1GBps internet had initially
    reported this issue

I’ve tried all the lan ports but the result is same. Note that this
router has 8 lan ports and 1 wan port. Where, switch bcm53012
covers lan4, lan7, lan8 and wan ports. While bcm53125 covers lan1,
lan2, lan3, lan5 and lan6 ports. bcm53125’s cpu port(8) hangs of
bcm53012 at port(0). bcm53012 is connected to GMAC.

When I load factory firmware, I do get 1Gbps from lan to wan port

Test setup:


Router ⇔ pfsense box ⇔ Modem

             ||
            SSD

File copy is limited to ~500Mbps

Thanks,

Vivek


Closed by  Yousong Zhou
18.03.2019 07:52
Reason for closing:  Duplicate

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing