OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by easyteacher - 10.03.2019
Last edited by Petr Štetiar - 03.04.2019

FS#2175 - ramips: BUG: scheduling while atomic: mmcqd/0/593/0x00000004

- Device problem occurs on
Newifi D1 MT7621
- Software versions of OpenWrt/LEDE release, packages, etc.
OpenWrt SNAPSHOT r9420
- Steps to reproduce
After kmod-sdhci-mt7620 is installed, dmesg is filled with these messages:

[18272.072042] BUG: scheduling while atomic: mmcqd/0/593/0x00000004
[18272.078074] Modules linked in: mt76x2e mt76x2_common mt76x02_lib mt7603e mt76 mac80211 iptable_nat ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_tcpmss xt_string xt_statistic xt_state xt_socket xt_recent xt_quota xt_pkttype xt_owner xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_ipp2p xt_hl xt_helper xt_hashlimit xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_bpf xt_addrtype xt_TPROXY xt_TCPMSS xt_REDIRECT xt_NETMAP xt_LOG xt_HL xt_FLOWOFFLOAD xt_DSCP xt_CT xt_CLASSIFY ts_kmp ts_fsm ts_bm nf_socket_ipv6 nf_socket_ipv4 nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_conntrack_ipv4 nf_nat_ipv4 nf_log_ipv4 nf_flow_table_hw nf_flow_table nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack_netlink macvlan iptable_raw iptable_mangle iptable_filter
[18272.148930]  ipt_ECN ip_tables crc_ccitt compat_xtables compat br_netfilter sch_cake act_simple sch_teql sch_qfq sch_multiq em_nbyte sch_dsmark act_gact sch_pie sch_gred em_meta act_ipt sch_prio sch_codel em_text sch_hhf sch_sfq act_police em_cmp sch_drr sch_fq sch_red act_connmark cls_matchall act_skbedit act_csum libcrc32c act_pedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw cls_basic sch_tbf sch_htb sch_hfsc sch_ingress ledtrig_usbport cryptodev xt_set ip_set_list_set ip_set_hash_netiface ip_set_hash_netport ip_set_hash_netnet ip_set_hash_net ip_set_hash_netportnet ip_set_hash_mac ip_set_hash_ipportnet ip_set_hash_ipportip ip_set_hash_ipport ip_set_hash_ipmark ip_set_hash_ip ip_set_bitmap_port ip_set_bitmap_ipmac ip_set_bitmap_ip ip_set nfnetlink ip6t_NPT ip6t_MASQUERADE nf_nat_masquerade_ipv6
[18272.221414]  ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 nf_nat nf_conntrack ip6t_rt ip6t_frag ip6t_hbh ip6t_eui64 ip6t_mh ip6t_ah ip6t_ipv6header ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables x_tables ifb tun authenc mmc_block mtk_sd mmc_core leds_gpio xhci_mtk xhci_plat_hcd xhci_pci xhci_hcd sd_mod scsi_mod gpio_button_hotplug f2fs ext4 jbd2 mbcache usbcore nls_base usb_common crc32c_generic crc32_generic
[18272.263235] CPU: 0 PID: 593 Comm: mmcqd/0 Tainted: G        W       4.14.102 #0
[18272.270524] Stack : 00000000 8ff7caa0 8ff84e74 80077c54 805d0000 80575750 00000000 00000000
[18272.278869]         805402c4 8e633904 8feffa3c 805aea07 8053aeac 00000001 8e6338a8 ac07f57f
[18272.287212]         00000000 00000000 80610000 00019ea8 00000000 00006f1e 00000008 00000000
[18272.295544]         00000000 805b0000 00040443 00000000 00000000 00000000 805d0000 8060af80
[18272.303877]         00000001 00000000 00000000 8ff7caa0 00000002 802b7950 00325a6f 0030c0af
[18272.312211]         ...
[18272.314648] Call Trace:
[18272.317115] [<80010a40>] show_stack+0x58/0x100
[18272.321561] [<8047a2ec>] dump_stack+0x9c/0xe0
[18272.325923] [<80057cfc>] __schedule_bug+0x60/0x7c
[18272.330627] [<80494188>] __schedule+0x70/0x88c
[18272.335052] [<80494a1c>] schedule+0x78/0x9c
[18272.339221] [<80497ff0>] schedule_timeout+0x188/0x1c4
[18272.344252] [<80495768>] wait_for_common+0x130/0x1f8
[18272.349294] [<8e605bcc>] 0x8e605bcc
[18272.353484] BUG: scheduling while atomic: mmcqd/0/593/0x00000003
[18272.359538] Modules linked in: mt76x2e mt76x2_common mt76x02_lib mt7603e mt76 mac80211 iptable_nat ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_tcpmss xt_string xt_statistic xt_state xt_socket xt_recent xt_quota xt_pkttype xt_owner xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_ipp2p xt_hl xt_helper xt_hashlimit xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_bpf xt_addrtype xt_TPROXY xt_TCPMSS xt_REDIRECT xt_NETMAP xt_LOG xt_HL xt_FLOWOFFLOAD xt_DSCP xt_CT xt_CLASSIFY ts_kmp ts_fsm ts_bm nf_socket_ipv6 nf_socket_ipv4 nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_conntrack_ipv4 nf_nat_ipv4 nf_log_ipv4 nf_flow_table_hw nf_flow_table nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack_netlink macvlan iptable_raw iptable_mangle iptable_filter
[18272.430490]  ipt_ECN ip_tables crc_ccitt compat_xtables compat br_netfilter sch_cake act_simple sch_teql sch_qfq sch_multiq em_nbyte sch_dsmark act_gact sch_pie sch_gred em_meta act_ipt sch_prio sch_codel em_text sch_hhf sch_sfq act_police em_cmp sch_drr sch_fq sch_red act_connmark cls_matchall act_skbedit act_csum libcrc32c act_pedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw cls_basic sch_tbf sch_htb sch_hfsc sch_ingress ledtrig_usbport cryptodev xt_set ip_set_list_set ip_set_hash_netiface ip_set_hash_netport ip_set_hash_netnet ip_set_hash_net ip_set_hash_netportnet ip_set_hash_mac ip_set_hash_ipportnet ip_set_hash_ipportip ip_set_hash_ipport ip_set_hash_ipmark ip_set_hash_ip ip_set_bitmap_port ip_set_bitmap_ipmac ip_set_bitmap_ip ip_set nfnetlink ip6t_NPT ip6t_MASQUERADE nf_nat_masquerade_ipv6
[18272.503058]  ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 nf_nat nf_conntrack ip6t_rt ip6t_frag ip6t_hbh ip6t_eui64 ip6t_mh ip6t_ah ip6t_ipv6header ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables x_tables ifb tun authenc mmc_block mtk_sd mmc_core leds_gpio xhci_mtk xhci_plat_hcd xhci_pci xhci_hcd sd_mod scsi_mod gpio_button_hotplug f2fs ext4 jbd2 mbcache usbcore nls_base usb_common crc32c_generic crc32_generic
[18272.544739] CPU: 0 PID: 593 Comm: mmcqd/0 Tainted: G        W       4.14.102 #0
[18272.552029] Stack : 00000000 800535fc 8f70bc20 80077c54 805d0000 80575750 00000000 00000000
[18272.560373]         805402c4 8e633ddc 8feffa3c 805aea07 8053aeac 00000001 8e633d80 ac07f57f
[18272.568707]         00000000 00000000 80610000 0001ab68 00000000 00006f32 00000008 00000000
[18272.577039]         00000000 805b0000 00084fe3 00000000 00000000 00000000 805d0000 8060af80
[18272.585370]         00000001 00000000 80610000 800535fc 00000002 802b7950 00000000 80610000
[18272.593703]         ...
[18272.596140] Call Trace:
[18272.598608] [<80010a40>] show_stack+0x58/0x100
[18272.603039] [<8047a2ec>] dump_stack+0x9c/0xe0
[18272.607395] [<80057cfc>] __schedule_bug+0x60/0x7c
[18272.612099] [<80494188>] __schedule+0x70/0x88c
[18272.616523] [<80494a1c>] schedule+0x78/0x9c
[18272.620786] [<8ed8be60>] mmc_blk_issue_rq+0x874/0xa78 [mmc_block]


Closed by  Petr ┼átetiar
03.04.2019 18:13
Reason for closing:  Not a bug
easyteacher commented on 10.03.2019 03:05

Accessing folders in the TF card becomes slower than before.
The problem didn't occur when the kernel version is 4.14.90.

neheb commented on 13.03.2019 02:12

The driver in OpenWrt is based on an older version of the one in kernel.org's staging directory. This issue may or may have not been fixed there.

The real solution is to switch to the driver that is not in kernel.org's staging directory. Unfortunately that will happen with kernel 4.19 at the earliest.

easyteacher commented on 29.03.2019 07:49

r9743 the warnings have gone. Thanks for your work. Please close this ticket.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing