OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To
    Petr Štetiar
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version All
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Adam - 06.03.2019
Last edited by Petr Štetiar - 05.11.2019

FS#2168 - Switch no longer work after restart on Linksys EA8500

Got error when I try to post with all followings, so I have to post the task first then supply those information below.

There is a problem with the EA8500, the switch will not work after soft reboot, the only way to get it work is power cycle it manually, tested on 18.06.2 and latest source code.

There is already a topic for this https://forum.openwrt.org/t/ea8500-reboot-fails-only-with-power-switch-on-off-successful/18234

I will copy what I replied to the topic to this issue.

have the same issue, looks like something not reset properly, or clock not initialize properly.

on successful boot it will show
[ ] libphy: GPIO Bitbanged MDIO: probed
[ ] switch0: Atheros AR8337 rev. 2 switch registered on gpio-0
[ ] ar8327: qca,phy-rgmii-en is not specified

after soft reboot it will become
[ ] libphy: GPIO Bitbanged MDIO: probed
[ ] mdio_bus gpio-0: MDIO device at address 0 is missing.
[ ] mdio_bus gpio-0: MDIO device at address 4 is missing.

after reading code and google, found following information
the switch reset pin is connect to gpio63, tried manually reset by control gpio via /sys, dose see the port light off then on, reset dose work, but after restart network service still no switch.
then read boot log, there is error for initialize dma for ipq806x-gmac-dwmac 37200000.ethernet, then go to the actual code change it to print more information, found the dma reset bit will never clear.

I don’t think this is a switch related issue, it should be a soc driver issue, either mdio bus or eth driver, personally I think it is the clock for mdio bus.

Did another test, flashed the official FW in Openwrt, then auto reboot, the official FW cannot working properly for the same reason, cannot find the switch.
After power cycle official FW working properly, and I can soft restart by issue a reboot cmd in serial port, after reboot everything still works.
Therefore there must be something got disabled during Openwrt shutdown process that should not be disabled.

Success boot log (on cold boot / manual power cycle)
success_log.txt

Fail boot log (on restart / reboot)
fail_log.txt

Fail boot log (sysupgrade -v -n -F flashed official FW then auto reboot)
fail_boot_linksys_fw.txt

Closed by  Petr Štetiar
05.11.2019 23:31
Reason for closing:  Fixed
Carlos H commented on 11.03.2019 00:40

Hi guys, I am having this same issue on my EA8500. soft reboot would not release the switch and there is absolutely no external access to the internet as all DNS queries are unable to be routed to the external servers. Please let me know if you need my help to reproduce the issue. Same condition also that stock firmware on soft reboot all communication works properly, this only happens on an OpenWRT soft reboot.

Duplicates task #2148.

Adam commented on 11.03.2019 14:41
Duplicates task #2148.

that one I already request to close since the class is not set properly, and I have no right to change.

Admin
Petr Štetiar commented on 25.05.2019 12:16

I don't have the device, but I've tried to come up with some potential fix and looking for someone who could actually test it, for the details please see following comment https://github.com/openwrt/openwrt/pull/2047#issuecomment-494177418

Admin
Petr Štetiar commented on 18.06.2019 13:51

BTW I've just manually added revert to openwrt-18.06 in https://github.com/openwrt/openwrt/commit/5fe809d7183d25ba60b379b22fea013e54ab27fe as 18.06.3 should be out soon and we still didn't found a proper way to fix this issue...

Carlos H commented on 13.08.2019 13:16

Thanks Petr, just noticed this reply, I can certainly test the fix on my EA8500.

Carlos H commented on 21.09.2019 19:01

Just upgraded to 18.06.4 r7808-ef686b7292 last night and the issue is not there anymore by the way, switch is now working after a soft reboot via either the Luci GUI or via ssh.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing