OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Other
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Elysweyr - 28.02.2019

FS#2154 - ath10k: not supported (-95) (DFS)

Forum discussion: https://forum.openwrt.org/t/ath10k-issues-5ghz-interface-not-starting-18-06-2/32214/13

Supply the following if possible:
- Device problem occurs on

Netgear R7800-100PES

- Software versions of OpenWrt/LEDE release, packages, etc.

OpenWrt 18.06.2 r7676-cddd7b4c77
hostapd	2018-05-21-62566bc2-5
hostapd-common	2018-05-21-62566bc2-5
ath10k-firmware-qca9984	2018-05-12-952afa49-1
kmod-ath	4.14.95+2017-11-01-9
kmod-ath10k	4.14.95+2017-11-01-9

- Steps to reproduce

  - Flashed factory image: https://openwrt.org/toh/netgear/r7800
  - opkg update
  - opkg remove wpad-mini
  - opkg install hostapd
  - wifi down
  - applied config file from below
  - wifi up

/etc/config/wireless

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option country 'AT'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option disabled '0'
        option legacy_rates '0'
        option channel '100'
        option htmode 'VHT160'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option wpa_disable_eapol_key_retries '1'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option key 'XXX'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'


full system log

https://pastebin.com/JrVw32t3

relevant system log

Thu Feb 28 22:32:40 2019 user.notice mac80211: Failed command: iw phy phy0 set antenna all all
Thu Feb 28 22:32:40 2019 daemon.notice netifd: radio0 (804): command failed: Not supported (-95)
Thu Feb 28 22:32:40 2019 user.notice mac80211: Failed command: iw phy phy0 set distance 0
Thu Feb 28 22:32:40 2019 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Thu Feb 28 22:33:23 2019 kern.info kernel: [   41.023462] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Thu Feb 28 22:33:23 2019 kern.info kernel: [   41.029465] br-lan: port 2(wlan0) entered blocking state
Thu Feb 28 22:33:23 2019 kern.info kernel: [   41.029497] br-lan: port 2(wlan0) entered disabled state
Thu Feb 28 22:33:23 2019 kern.info kernel: [   41.034197] device wlan0 entered promiscuous mode
Thu Feb 28 22:33:23 2019 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Thu Feb 28 22:33:23 2019 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->HT_SCAN
Thu Feb 28 22:33:23 2019 user.notice dnsmasq: found already running DHCP-server on interface 'br-lan' refusing to start, use 'option force 1' to override
Thu Feb 28 22:33:23 2019 daemon.info dnsmasq[530]: read /etc/hosts - 4 addresses
Thu Feb 28 22:33:23 2019 daemon.info dnsmasq[530]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Thu Feb 28 22:33:23 2019 daemon.notice hostapd: wlan0: interface state HT_SCAN->DFS
Thu Feb 28 22:33:23 2019 daemon.notice hostapd: wlan0: DFS-CAC-START freq=5500 chan=100 sec_chan=1, width=2, seg0=114, seg1=0, cac_time=60s
Thu Feb 28 22:33:23 2019 daemon.err hostapd: DFS start_dfs_cac() failed, -1
Thu Feb 28 22:33:23 2019 daemon.err hostapd: Interface initialization failed
Thu Feb 28 22:33:23 2019 daemon.notice hostapd: wlan0: interface state DFS->DISABLED
Thu Feb 28 22:33:23 2019 daemon.notice hostapd: wlan0: AP-DISABLED
Thu Feb 28 22:33:23 2019 daemon.notice hostapd: wlan0: interface state DISABLED->DISABLED
Thu Feb 28 22:33:23 2019 daemon.notice hostapd: wlan0: AP-DISABLED
Thu Feb 28 22:33:23 2019 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Thu Feb 28 22:33:23 2019 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Thu Feb 28 22:33:23 2019 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Thu Feb 28 22:33:23 2019 kern.info kernel: [   41.423511] device wlan0 left promiscuous mode
Thu Feb 28 22:33:23 2019 kern.info kernel: [   41.423650] br-lan: port 2(wlan0) entered disabled state
Thu Feb 28 22:33:23 2019 kern.warn kernel: [   41.474131] ath10k_pci 0000:01:00.0: peer-unmap-event: unknown peer id 1
Thu Feb 28 22:33:23 2019 daemon.notice hostapd: ELOOP: remaining socket: sock=21 eloop_data=0xb6ec9bf0 user_data=0 handler=0x3cef4
Thu Feb 28 22:33:23 2019 daemon.notice netifd: radio0 (804): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory
Thu Feb 28 22:33:23 2019 daemon.notice netifd: radio0 (804): WARNING (wireless_add_process): executable path /usr/sbin/hostapd does not match process  path ()
Thu Feb 28 22:33:23 2019 daemon.notice netifd: radio0 (804): Command failed: Invalid argument

iw list

https://pastebin.com/NrYtQtqe

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing