Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#2139 - broadcom-wl don't work on rt-n16 #8408

Open
openwrt-bot opened this issue Feb 21, 2019 · 6 comments
Open

FS#2139 - broadcom-wl don't work on rt-n16 #8408

openwrt-bot opened this issue Feb 21, 2019 · 6 comments
Labels
flyspray release/19.07 pull request/issue targeted (also) for OpenWrt 19.07 release

Comments

@openwrt-bot
Copy link

Afo:

wifi on lede 17.01.6, with the same config, works great
install openwrt 18.06
opkg remove kmod-b43 kmod-b43legacy kmod-mac80211 kmod-cfg80211 kmod-brcmsmac
opkg install kmod-brcm-wl nas wlc wl
wl -i wl0 chanspec -c 9 -b 2 -w 40 -s -1

config wifi-device 'wl0'
option type 'broadcom'
option channel '9'
option hwmode '11ng'
option htmode 'HT40'
option txpower '16'
option txantenna '3'
option rxantenna '3'

config wifi-iface
option device 'wl0'
option network 'lan'
option mode 'ap'
option ssid 'point'
option encryption 'psk2'
option key 'pass'
option wmm '1'
option disabled '0'

After, my laptop (windows) does not connect and the phone on the android
connects for 15-20 minutes, disconnects, manually connects from the third fourth attempt
and disconnects again after a while

ifconfig shows that the interface wl0-1 is automatically created with non-existent mac address E2:CB:4E:C0:18:14 (wl0 E0:CB:4E:C0:18:13)
Wi-Fi scanner shows two access points with the same name, channels, but different MAC addresses (E2:CB:4E:C0:18:14, E0:CB:4E:C0:18:13)

I compiled two firmware with
CONFIG_TARGET_brcm47xx=y
CONFIG_TARGET_brcm47xx_mips74k=y
CONFIG_TARGET_brcm47xx_mips74k_DEVICE_asus-rt-n16=y
and
CONFIG_TARGET_brcm47xx=y
CONFIG_TARGET_brcm47xx_mips74k=y
CONFIG_TARGET_brcm47xx_mips74k_Broadcom-mips74k-wl=y

but it did not help

@openwrt-bot
Copy link
Author

ooVizieRoo:

I have the same issue.

@openwrt-bot
Copy link
Author

RAX7:

I have same issue. Looks like I found the reason for this behavior. The //nas// process die after few seconds after it start.
If start nas manually with:
start-stop-daemon -S -b -p /var/run/nas.wl0.pid -x /usr/sbin/nas -- -P /var/run/nas.wl0.pid -H 34954 -i wl0-1 -A -m 4 -w 2 -s NAME -g 3600 -F -k password
it works fine but after some time crash with error:
#0 (0x4b8be0)->0x4b8bc0: 3590 sec 999720 usec 0x403c24
#1 (0x4b8bc0)->0x4b8bc0: 0 sec 0 usec 0x403c24
// many lines later
#1087 (0x4b8bc0)->0x4b8bc0: 0 sec 0 usec 0x403c24
#1088 (0x4b8bc0)->0x4b8bc0: 0 sec 0 usec 0x403c24
...(giving up)

I reproduce this bug on 19.07 but it have same issue on any version higher than 17.01.7.

@openwrt-bot
Copy link
Author

DisloyalSnow911:

I have the same problem. If you find a solution, write how you did it.

@openwrt-bot
Copy link
Author

oferreiro:

Same problem here with my netgear wrn3500l v1.
wl not works on openwrt 18.06.8 or 19.07.2.

With openwrt, nas command is running with duplicate parameters:
/usr/sbin/nas -P /var/run/nas.wl0.pid -H 34954 -i wl0-1 -A -m 128 -w 4 -s OpenWrt -g 3600 -F -k test123test123 -P /var/run/nas.wl0.pid -H 34954 -i wl0-1 -A -m 128 -w 4 -s OpenWrt -g 3600 -F -k test123test123

And wl0-1 is created even if I use only one wifi interface.

with lede 17.01.7 works well.
nas command is:
/usr/sbin/nas -P /var/run/nas.wl0.pid -H 34954 -i wl0 -A -m 128 -w 4 -s LEDE -g 3600 -F -k test123test123

I tried find changes on /lib/wifi/broadcom.sh, but it is basically the same file:

diff broadcom-17.01.7.sh broadcom-19.07.02.sh 472c472 < set wireless.default_wl${i}.ssid=Lede${i#0} --- > set wireless.default_wl${i}.ssid=OpenWrt${i#0}

When I tried RAX7 suggestion, running nas manually:
start-stop-daemon -S -b -p /var/run/nas.wl0-1.pid -x /usr/sbin/nas -- -P /var/run/nas.wl0.pid -H 34954 -i wl0-1 -A -m 128 -w 4 -s OpenWrt -g 3600 -F -k test123test123

I can connect my notebook but wifi speed is not good. And after some time it disconnect.

@openwrt-bot
Copy link
Author

oferreiro:

Hi guys.
I have good news.
I found partial solution to use kmod-brcm-wl on openwrt 19.07.2
Basically we need add one vif disabled at end of config.

config wifi-device 'wl0' option type 'broadcom' option channel '1' option txantenna '3' option rxantenna '3' option country 'BR' option frameburst '1' option htmode 'HT40' option txpower '14' option hwmode '11g'

config wifi-iface 'default_wl0'
option device 'wl0'
option network 'lan'
option mode 'ap'
option wmm '1'
option ssid 'My SSID'
option encryption 'psk2+ccmp'
option key 'mypassword'

config wifi-iface 'wifinet1'
option device 'wl0'
option mode 'ap'
option ssid 'TrickToFixNasParams'
option encryption 'none'
option disabled '1'

After that, nas is started with correct params:

/usr/sbin/nas -P /var/run/nas.wl0.pid -H 34954 -i wl0 -A -m 128 -w 4 -s My SSID -g 3600 -F -k mypassword

Luci interface don't show informations. But wifi works well.

And the speed is similar if I use lede 17.01.7.

Server listening on 5201

Accepted connection from 192.168.12.203, port 49262
[ 5] local 192.168.12.33 port 5201 connected to 192.168.12.203 port 49263
[ ID] Interval Transfer Bitrate
[ 5] 0.00-1.00 sec 7.85 MBytes 65.8 Mbits/sec
[ 5] 1.00-2.00 sec 6.37 MBytes 53.4 Mbits/sec
[ 5] 2.00-3.00 sec 6.03 MBytes 50.6 Mbits/sec
[ 5] 3.00-4.00 sec 8.61 MBytes 72.2 Mbits/sec
[ 5] 4.00-5.00 sec 8.20 MBytes 68.8 Mbits/sec
[ 5] 5.00-6.00 sec 8.50 MBytes 71.3 Mbits/sec
[ 5] 6.00-7.00 sec 7.77 MBytes 65.2 Mbits/sec
[ 5] 7.00-8.00 sec 8.05 MBytes 67.5 Mbits/sec
[ 5] 8.00-9.00 sec 7.61 MBytes 63.8 Mbits/sec
[ 5] 9.00-10.00 sec 7.81 MBytes 65.5 Mbits/sec
[ 5] 10.00-10.22 sec 1.78 MBytes 68.8 Mbits/sec


[ ID] Interval Transfer Bitrate
[ 5] 0.00-10.22 sec 78.6 MBytes 64.5 Mbits/sec receiver

I have tested with another VIF. Works, but the speed is a bit unstable.

config wifi-device 'wl0' option type 'broadcom' option channel '1' option txantenna '3' option rxantenna '3' option country 'BR' option frameburst '1' option htmode 'HT40' option txpower '14' option hwmode '11g'

config wifi-iface 'default_wl0'
option device 'wl0'
option network 'lan'
option mode 'ap'
option wmm '1'
option ssid 'My SSID'
option encryption 'psk2+ccmp'
option key 'mypassword'

config wifi-iface 'wifinet1'
option device 'wl0'
option network 'lan'
option mode 'ap'
option wmm '1'
option ssid 'My another SSID'
option encryption 'psk2+ccmp'
option key 'mypassword'

config wifi-iface 'wifinet2'
option device 'wl0'
option mode 'ap'
option ssid 'TrickToFixNasParams'
option encryption 'none'
option disabled '1'

/usr/sbin/nas -P /var/run/nas.wl0.pid -H 34954 -i wl0 -A -m 128 -w 4 -s My SSID -g 3600 -F -k mypassword -i wl0-1 -A -m 128 -w 4 -s My another SSID -g 3600 -F -k mypassword

I think the bug is: wrong referenced array index. I don't know where…
wifi command shows "sh: out of range".
Without the trick, openwrt creates additional vif(wl0-1, wl0-2), one more than necessary, and duplicate nas params to last wifi-iface.

@aparcar aparcar added the release/19.07 pull request/issue targeted (also) for OpenWrt 19.07 release label Feb 22, 2022
@WGH-
Copy link

WGH- commented Aug 14, 2022

This is still a problem as of 21.02.3.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
flyspray release/19.07 pull request/issue targeted (also) for OpenWrt 19.07 release
Projects
None yet
Development

No branches or pull requests

3 participants