OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Alexander E. Patrakov - 06.02.2019
Last edited by Petr Štetiar - 03.04.2019

FS#2105 - nfs-kernel-server: exportfs always segfaults

This happens on the latest snapshot (2019-02-07) on TP-Link Archer C7. It did not happen on a snapshot from 2019-01-28.

To reproduce:

1. Create /etc/exports as follows:

/mnt/bigdisk	192.168.1.0/255.255.255.0(rw,mp,all_squash,no_subtree_check,insecure,sync)

2. install nfs-kernel-server

Or just run: exportfs -a

Result: exportfs segfaults.

I believe this is a kernel problem, because downgrading nfs-kernel-server to the version in OpenWRT 18.06.2 does not help.

Closed by  Petr ┼átetiar
03.04.2019 18:26
Reason for closing:  Fixed
mistepien commented on 10.02.2019 20:41

I think this is musl. I uses buildroot for audio and I tried to recompile my embedded system with musl 1.1.21 and this is what I got. With 1.1.21 there were segfaults with binaries from nfs-utils.

Musl was updated to 1.1.21 in openwrt-git on 5th of February.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing