Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#2101 - WDS bridge and PPPoE MTU problem #6958

Open
openwrt-bot opened this issue Feb 5, 2019 · 3 comments
Open

FS#2101 - WDS bridge and PPPoE MTU problem #6958

openwrt-bot opened this issue Feb 5, 2019 · 3 comments
Labels

Comments

@openwrt-bot
Copy link

enryIT:

Device: Netgear R7800
This issue is not present with original Netgear firmware and is not present with LEDE 17 (older kernel).

Preface:
I have very strange issue with interfaces MTU and it looks to be introduced with newer kernel (4.14).

My network is attached as a png:

  1. my ISP uses VDSL, i just have a PPPoE (MTU=1492) on the ethernet interface through the ISP modem
  2. all other internal clients and routers interfaces have MTU=1500

Ping from R7800 to 1.1.1.1 with 2000 packet size and fragmentation allowed = success
Ping from ArcherC7v2 to R7800 with 2000 packet size and fragmentation allowed = success
Ping from PC1 to R7800 with 2000 packet size and fragmentation allowed = success
Ping from PC2 to R7800 with 2000 packet size and fragmentation allowed = success
Ping from PC1 to 1.1.1.1 with 2000 packet size and fragmentation allowed = failure
Ping from PC2 to 1.1.1.1 with 2000 packet size and fragmentation allowed = success

Now the fun part:
Ping from PC1 to 1.1.1.1 with 1473 packet size and fragmentation allowed = failure
Ping from PC1 to 1.1.1.1 with 1472 packet size (1492-20) and fragmentation allowed = success

It seems a WDS (4addr) problem combined with PPPoE being at MTU=1492 at this point, but:
Ping from ArcherC7v2 to 1.1.1.1 with 2000 packet size and fragmentation allowed = success

I've messed up with MTU on all the interfaces, the only thing that fix the issue is setting the br-lan interface of the R7800 to MTU=1491, as soon as the bridge has MTU>1491 the pings fail.

R7800 network config

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 6t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '5 0t'

config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option stp '1'
option mtu '1500'
option ifname 'eth1.1'

config interface 'TIM_FTTC'
option proto 'pppoe'
option ifname 'eth0.2'
option username ''
option password '
'
option ipv6 'auto'
option metric '1'
option peerdns '0'
option keepalive '5 6'

R7800 wireless config

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11a'
option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
option htmode 'VHT80'
option channel '136'
option txpower '23'
option country 'US'
option legacy_rates '0'
option noscan '1'

config wifi-iface 'default_radio0'
option device 'radio0'
option mode 'ap'
option ssid ''
option encryption 'psk2+ccmp'
option key '
'
option wps_pushbutton '0'
option network 'lan'
option wds '1'

ArcherC7v2 network config

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 6t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '5 0t'

config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.2'
option netmask '255.255.255.0'
option stp '1'
option mtu '1500'
option ifname 'eth1.1'

ArcherC7v2 wireless config

config wifi-device 'radio0'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'pci0000:01/0000:01:00.0'
option htmode 'VHT80'
option txpower '23'
option country 'US'
option legacy_rates '0'
option noscan '1'

config wifi-iface 'default_radio0'
option device 'radio0'
option mode 'sta'
option wds '1'
option ssid ''
option encryption 'psk2+ccmp'
option key '
'
option wps_pushbutton '0'
option network 'lan'

WAN zone on firewall on R7800 has option mtu_fix '1'

@openwrt-bot
Copy link
Author

enryIT:

Taking down the PPPoE thus routing the outbound traffic through the ISP modem (eth interface 1500mtu) wich itself act as a PPPoE client (1492 mtu) result in the same behaviour.

@openwrt-bot
Copy link
Author

enryIT:

The problem exists with both ath10k stock and candela-tech driver/firmware.

@openwrt-bot
Copy link
Author

enryIT:

Addendum: no WDS clients connected on WDS AP don't have any issue.

This is confirming the fact that the problem comes from a combination of fragmentation and WDS frame.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant