OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version All
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Enrico - 05.02.2019
Last edited by Ted Hess - 20.02.2019

FS#2100 - WDS bridge and PPPoE MTU problem

Device: Netgear R7800
This issue is not present with original Netgear firmware and is not present with LEDE 17 (older kernel).

Preface:
I have very strange issue with interfaces MTU and it looks to be introduced with newer kernel (4.14).

My network is attached as a png:
1. my ISP uses VDSL, i just have a PPPoE (MTU=1492) on the ethernet interface through the ISP modem
2. all other internal clients and routers interfaces have MTU=1500

Ping from R7800 to 1.1.1.1 with 2000 packet size and fragmentation allowed = success
Ping from ArcherC7v2 to R7800 with 2000 packet size and fragmentation allowed = success
Ping from PC1 to R7800 with 2000 packet size and fragmentation allowed = success
Ping from PC2 to R7800 with 2000 packet size and fragmentation allowed = success
Ping from PC1 to 1.1.1.1 with 2000 packet size and fragmentation allowed = failure
Ping from PC2 to 1.1.1.1 with 2000 packet size and fragmentation allowed = success

Now the fun part:
Ping from PC1 to 1.1.1.1 with 1473 packet size and fragmentation allowed = failure
Ping from PC1 to 1.1.1.1 with 1472 packet size (1492-20) and fragmentation allowed = success

It seems a WDS (4addr) problem combined with PPPoE being at MTU=1492 at this point, but:
Ping from ArcherC7v2 to 1.1.1.1 with 2000 packet size and fragmentation allowed = success

I’ve messed up with MTU on all the interfaces, the only thing that fix the issue is setting the br-lan interface of the R7800 to MTU=1491, as soon as the bridge has MTU>1491 the pings fail.

R7800 network config

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option stp '1'
        option mtu '1500'
        option ifname 'eth1.1'

config interface 'TIM_FTTC'
        option proto 'pppoe'
        option ifname 'eth0.2'
        option username '***'
        option password '***'
        option ipv6 'auto'
        option metric '1'
        option peerdns '0'
        option keepalive '5 6'

R7800 wireless config

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option channel '136'
        option txpower '23'
        option country 'US'
        option legacy_rates '0'
        option noscan '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid '***'
        option encryption 'psk2+ccmp'
        option key '***'
        option wps_pushbutton '0'
        option network 'lan'
        option wds '1'

ArcherC7v2 network config

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.2'
        option netmask '255.255.255.0'
        option stp '1'
        option mtu '1500'
        option ifname 'eth1.1'

ArcherC7v2 wireless config

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:01/0000:01:00.0'
        option htmode 'VHT80'
        option txpower '23'
        option country 'US'
        option legacy_rates '0'
        option noscan '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'sta'
        option wds '1'
        option ssid '***'
        option encryption 'psk2+ccmp'
        option key '***'
        option wps_pushbutton '0'
        option network 'lan'

WAN zone on firewall on R7800 has “option mtu_fix ‘1’”

Closed by  Ted Hess
20.02.2019 13:40
Reason for closing:  Invalid report

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing