OpenWrt/LEDE Project

  • Status Waiting on reporter
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by tpahula - 01.01.2019
Last edited by Koen Vandeputte - 06.06.2019

FS#2039 - Sierra Wireless EM7565 not working with Linksys WRT3200ACM


I have problems with Sierra Wireless EM7565 wireless module and USB 3.0 M.2 adapter. Device is detected correctly and works with TP-Link Archer C7 v2 which have older kernel version. I am using 18.06-SNAPSHOT r7405 version and kernel 4.14.82. I am connecting with QMI mode. I have tested also MBIM mode without success. 

I have verified connection using following command:

uqmi -d /dev/cdc-wdm0 –get-data-status –get-current-settings –get-capabilities –get-signal-info –get-serving-system “connected”

I have also tried changing RAW IP-mode. I have read following article:

https://techship.com/faq/how-to-step-by-step-set-up-a-data-connection-over-qmi-interface-using-qmicli-and-in-kernel-driver-qmi-wwan-in-linux/


tpahula commented on 05.01.2019 16:41

I updated EM7565 firmware to release 12. Update solved my problem if I use USB 2.0 mode. USB 3.0 mode is not working. I have added following lines to my rc.local file:

# Disable the network interfaces exposed by the cellular module:
ip link set dev wwan0 down
# Trigger the Raw-IP support:
echo Y > /sys/class/net/wwan0/qmi/raw_ip
# Enable the network interfaces again:
ip link set dev wwan0 up

Project Manager
Koen Vandeputte commented on 06.06.2019 21:26

Hi,

The explanation above is a bit unclear.
Could you please describe for both devices separately
what is actually working and what is not?
Also specify the kernel in use for each.

I have a lot of these modems in the office so maybe I can help here.

Thanks,

Koen

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing