OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Average Joe - 30.12.2018

FS#2036 - Seems there is noticeable memleak in trunk - brcm47xx - WL500gpv1

I’ve gave a try to “trunk” build from ~25 DEC on WL500GPv1 (brcm47xx - legacy). It generally worked (except for swap). But it seems to have memleak. Haven’t happened in early versions.

To reproduce:
1) Install trunk on WL500GP V1. As non-standard difference I have ath9k card installed in minipci, therefore kmod-ath9k package is installed.
2) Login by ssh and look on “free” output (ofc line including buff/cache).

  1. I had about 16 MB of free RAM total with freshly booted firmware at this point (no luci, etc, just stock trunk package set + ath9k).

3) Let it run for a while without reboots. I ran it about 5 days.
4) Repeat step 2 and look free RAM again.

  1. At this point I had just 10 MB free RAM without obvious users of rather large 6MB chunk. Let’s remind, it inlcudes buffers/cache.

In 5 days about 6MB RAM gone to unknown use I failed to identify. It does not seems to be attributed to processes, ps gives nothing useful. I would surely spot 6MB-sized process but there was none.


Available keyboard shortcuts


Task Details

Task Editing