OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Packages
  • Assigned To
    Hans Dedecker
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Adam Turner - 21.12.2018
Last edited by Hans Dedecker - 18.05.2019

FS#2019 - odhcpd IPv6 RA Flags

Supply the following if possible:
- Device problem occurs on
- Software versions of OpenWrt/LEDE release, packages, etc.
- Steps to reproduce

 

This problem occurs on the TP-Link TL-WDR3600 v1 with OpenWrt 18.06.1

Steps to reproduce: Configure /etc/config/dhcp as follows:

[...]
config dhcp ‘lan’

      option interface 'lan'
      option ra 'server'
      option ignore '1'
      option ra_management '2'
      option dhcpv6 'disabled'

[...]

Expected behaviour: Router gives out RAs with M and O flags set and A flag not set.
Actual behaviour: RAs do not have any of the three flags set

The M flag only indicates that a DHCPv6 server is available but it does not necessarily have to be at the same address as the router. Therefore the M flag should be able to be set whilst the internal DHCPv6 server is enabled.

Closed by  Hans Dedecker
18.05.2019 07:11
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in commit https://git.op enwrt.org/?p=project/odhcpd.git;a=commit ;h=d11180932b2fb8784aaad0830c032e42b8bb6 4ac

Adam Turner commented on 21.12.2018 13:48

My apologies for the poor formatting and typos in this:

The last paragraph should read:

Therefore the M flag should be able to be set whilst the internal DHCPv6 server is enabled disabled.

Project Manager
Hans Dedecker commented on 21.12.2018 13:58

This behavior is in place since an issue was logged no M/O flags must be set if the DHCPv6 server is not enabled; see https://bugs.openwrt.org/index.php?do=details&task_id=1457

Adam Turner commented on 21.12.2018 14:28

Surely that previous example is just a misconfiguration? The user has deliberately told odhcpd to advertise DHCPv6 as available by setting

option ra_management '1'

Which is documented as setting the M flag in an RA. Then they have disabled the DHCPv6 server explicitly in the configuration too. If the user disables the OpenWrt DHCPv6 server and then also enables the M flag, the behaviour that the router advises that DHCPv6 is available but the server is disabled is exactly what they have asked for...

Note that this is exactly the functionality I am trying to replicate!

Adam Turner commented on 21.12.2018 14:35

If the user did not want DHCPv6 to be advertised by the router then they should have set

option ra_management '0'

Which would only set the A flag and as such not indicate the presence of a DHCPv6 server on the network!

Project Manager
Hans Dedecker commented on 21.12.2018 15:18

Experience has learned me very few devices respect the M/O flags in the RAs and still start DHCPv6 even if the M/O flags are not set. So using the M/O flags to disable DHCPv6 is not an option in the real world

Adam Turner commented on 29.12.2018 15:13

Even so, should we not try to adhere to IETF standards wherever possible? The intent behind the O and M flags is to indicate to the client that a DHCPv6 server is available somewhere on the network – it need not be on the router. A misconfiguration reported as an issue should not lead OpenWrt to disregard the IETF standards.

Even if other devices don't adhere to the standards, this should not be a reason as to why we should not.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing