OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Packages
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by mpratt14 - 20.12.2018

FS#2017 - [wpad] cannot use encryption on 802.11s mesh

TLDR:
option encryption ‘none’ works perfectly

option encryption ‘# literally anything else’ wpad assumes encryption = none and everything works
OR
breaks config, mesh interface never comes up
(more than just the UI, also tested with iw)

Router A: ENS202EXT (Atheros/mac80211)
Router B: ENS202EXT (Atheros/mac80211)

Openwrt 18.06.1

wpad 2018-05-21-62566bc2-5 (current as of post)
also tried other versions of wpad (mesh, mesh-openssl)

I have tried both Mesh only and Mesh + AP.
I have not tried wpa_supplicant.

Currently have a mesh point that is working, but unencrypted. Along with an AP

LuCI does not allow the option to add encryption
If I force encryption in the configuration, mesh does not start up.
the package authSAE doesn’t exist anymore...so I assume that I am not missing requirements...

With Unencrypted mesh, LuCI shows association between the routers
Routers show up on each other’s Associated Stations list
everything seems to be working, with manual range testing since I can’t ping between routers, I guess because of firewall.

the most closely related issue I could find is this

another relevant links:
https://forum.openwrt.org/t/setting-up-authenticated-mesh-with-wpad-mesh/12399/49

they claim it’s good but it isn’t
Not sure if this is by design or never resolved.
Please advise how to better show the problem, what to post, etc...
I will be testing this on other routers as well

Working mesh config in wireless:

config wifi-iface

      option device 'radio0'
      option encryption 'none'
      option mode 'mesh'
      option mesh_id '$ID'
      option mesh_fwding '1'
      option network 'WLAN'

Mesh Config that fails:

config wifi-iface ‘SDMesh’

      option network 'WLAN'
      option device 'radio0'
      option mode 'mesh'
      option mesh_fwding '1'
      option mesh_id '$ID'
      option encryption 'psk2+ccmp'
      option key '$KEY'

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing