OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by mpratt14 - 20.12.2018
Last edited by Mathias Kresin - 28.12.2018

FS#2016 - [wpad] cannot use encryption on 802.11s mesh

Router A: ENS202EXT (Atheros/mac80211)
Router B: ENS202EXT (Atheros/mac80211)

Openwrt 18.06.1

wpad 2018-05-21-62566bc2-5 (current as of post)
also tried other versions of wpad (mesh, mesh-openssl)

I have tried both Mesh only and Mesh + AP.
I have not tried wpa_supplicant.

Currently have a mesh point that is working, but unencrypted. Along with an AP

LuCI does not allow the option to add encryption
If I force encryption in the configuration, mesh does not start up.
the package authSAE doesn’t exist anymore...so I assume that I am not missing requirements...

With Unencrypted mesh, LuCI shows association between the routers
Routers show up on each other’s Associated Stations list
everything seems to be working, with manual range testing since I can’t ping between routers, I guess because of firewall.

the most closely related issue I could find is this

Not sure if this is by design or never resolved.

output of:

iw dev wlan0 mpath dump:
(normal)

DEST ADDR NEXT HOP IFACE SN METRIC QLEN EXPTIME DTIM DRET FLAGS
88:dc:96:5b:91:7a 88:dc:96:5b:91:7a wlan0 333 275 0 0 100 0 0×4

iw dev wlan0 station dump:
(normal)

Station 88:dc:96:5b:91:7a (on wlan0)

      inactive time:  80 ms
      rx bytes:       7914213
      rx packets:     92631
      tx bytes:       3602325
      tx packets:     5569
      tx retries:     747
      tx failed:      0
      rx drop misc:   2752
      signal:         -36 [-67, -36] dBm
      signal avg:     -37 [-68, -37] dBm
      Toffset:        2990478 us
      tx bitrate:     58.5 MBit/s MCS 6
      rx bitrate:     65.0 MBit/s MCS 6 short GI
      expected throughput:    24.536Mbps
      mesh llid:      35917
      mesh plid:      18683
      mesh plink:     ESTAB
      mesh local PS mode:     ACTIVE
      mesh peer PS mode:      ACTIVE
      mesh non-peer PS mode:  ACTIVE
      authorized:     yes
      authenticated:  yes
      associated:     yes
      preamble:       long
      WMM/WME:        yes
      MFP:            no
      TDLS peer:      no
      DTIM period:    2
      beacon interval:100
      short slot time:yes
      connected time: 4331 seconds

/etc/config/wireless

config wifi-device ‘radio0’

      option type 'mac80211'
      option hwmode '11g'
      option path 'platform/ar934x_wmac'
      option htmode 'HT20'
      option disabled '0'
      option country 'US'
      option distance '100'
      option channel '1'
      option legacy_rates '0'

config wifi-iface

      option device 'radio0'
      option encryption 'none'
      option mode 'mesh'
      option mesh_id '$ID'
      option mesh_fwding '1'
      option network 'WLAN'

config wifi-iface

      option device 'radio0'
      option mode 'ap'
      option ssid '$SSID'
      option network 'WLAN'
      option encryption 'psk2+ccmp'
      option key '$KEY'
      option wpa_disable_eapol_key_retries '1'
      option wps_pushbutton '0'

Mesh Config that fails:

config wifi-iface ‘SDMesh’

      option network 'WLAN'
      option device 'radio0'
      option mode 'mesh'
      option mesh_fwding '1'
      option mesh_id '$ID'
      option encryption 'psk2+ccmp'
      option key '$KEY'
Closed by  Mathias Kresin
28.12.2018 09:48
Reason for closing:  Duplicate
Additional comments about closing:  

Duplicate of FS#2017

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing