Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#1998 - WiFi MTU setting not applied #6884

Closed
openwrt-bot opened this issue Dec 13, 2018 · 3 comments
Closed

FS#1998 - WiFi MTU setting not applied #6884

openwrt-bot opened this issue Dec 13, 2018 · 3 comments
Labels

Comments

@openwrt-bot
Copy link

n8v8R:

  • Device problem occurs on
  • Turris Omnia ARMv7 Processor rev 1 (v7l)
  • Software versions of OpenWrt/LEDE release, packages, etc.
  • Chaos Calmer r47055 | target:mvebu/generic | description:OpenWrt omnia 15.05

  • OpenWRT latest stable

  • Steps to reproduce

setting dev iface mtu according to https://www.mail-archive.com/openwrt-devel@lists.openwrt.org/msg41851.html

config interface 'wl100'
option proto 'none'
option mtu '2000'

Bring the iface up and ip l show wl100 displaying the MTU as 1500. Seems that either UCI is not parsing the setting or netifd neglecting it.

Cross referencing OpenWRT forum https://forum.openwrt.org/t/how-to-set-mtu-on-bare-wireless-interface-using-config-uci/20164/3

and downstream bug ticket https://gitlab.labs.nic.cz/turris/turris-os-packages/issues/211#note_93831

@openwrt-bot
Copy link
Author

n8v8R:

For completeness sake:

  • Turris OS 3.11

  • netifd 2016-12-23

@openwrt-bot
Copy link
Author

jow-:

Use config device sections to set per-interface MTU.

The following snippets work for me:

config device option name wlan0 option mtu 1511

config device
option name wlan1
option mtu 1512

Results in:

# ip link show wlan0 ; ip link show wlan1
166: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1511 qdisc noqueue master br-lan state UP mode DEFAULT group default qlen 1000
link/ether 04:f0:21:0f:78:bd brd ff:ff:ff:ff:ff:ff
175: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1512 qdisc noqueue master br-lan state UP mode DEFAULT group default qlen 1000
link/ether 04:f0:21:0f:77:6e brd ff:ff:ff:ff:ff:ff

@openwrt-bot
Copy link
Author

montvid:

Please open the bug report again. Jo-Philipp Wich clearly you are not using openwrt default settings!!! The settings that also Luci manipulates with a default openwrt 19 install are:

config interface 'lan'
option type 'bridge'
option ifname 'eth1.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option mtu '9000'

config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'
option peerdns '0'
option mtu '9000'
Waiting for a bugfix as the mtu does not change with these default luci manipulated settings.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant