OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version All
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by tiagogaspar8 - 27.11.2018

FS#1973 - odhcp6c Isn't able to request a DHCPv6 Prefix from WAN on Linksys WRT3200ACM

Supply the following if possible:
- Device problem occurs on:

Linksys WRT3200ACM

- Software versions of OpenWrt/LEDE release, packages, etc.

All versions were tested and report the same problem

- Steps to reproduce

Flash any version of OpenWRT and watch the log for a message saying:

Thu Jan  1 00:37:11 1970 daemon.err odhcp6c[1573]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
 

I’ve searched all over but found no solution.

One thing that I noticed, I configured the device to use vlan 12 as WAN (in switch), but when I type

swconfig dev switch0 show

in the command-line the cpu wan and actual wan port have

Port 4:
        mask: 0x0000: (4)
        qmode: 3
        pvid: 0
        link: port:4 link:up speed:1000baseT full-duplex
Port 5:
        mask: 0x0000: (5)
        qmode: 3
        pvid: 0
        link: port:5 link:up speed:1000baseT full-duplex
Port 6:
        mask: 0x0000: (6)
        qmode: 3
        pvid: 0
        link: port:6 link:up speed:1000baseT full-duplex


As you can see the pvid is 0
Also, the WAN6 interface receives a global ip from the untagged interface, even when asked to be tagged as vlan 12.

PS: once, I got a error saying permission denied instead of address not available.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing