OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by pteranodonte - 24.11.2018

FS#1968 - ltq_etop 1e180000.etop eth0: tx ring full

Firmware: OpenWrt 18.06.1, r7258-5eb055306f
Device: Buffalo WBMR-HP-G300H

This device does not use dsl as wan, it is configured as having a wireless ISP. Never noticed with previous official builds, but since 18.06 I keep having many dmesg entries reporting tx ring overflow:

root@OpenWrt:~# dmesg|tail
[4756635.140560] ltq_etop 1e180000.etop eth0: tx ring full
[4756635.176086] ltq_etop 1e180000.etop eth0: tx ring full
[4756635.197766] ltq_etop 1e180000.etop eth0: tx ring full
[4756635.206317] ltq_etop 1e180000.etop eth0: tx ring full
[4758261.349957] ltq_etop 1e180000.etop eth0: tx ring full
[4758261.448177] ltq_etop 1e180000.etop eth0: tx ring full
[4759642.372351] ltq_etop 1e180000.etop eth0: tx ring full
[4759642.389778] ltq_etop 1e180000.etop eth0: tx ring full
[4759645.389712] ltq_etop 1e180000.etop eth0: tx ring full
[4759855.427093] ltq_etop 1e180000.etop eth0: tx ring full

root@OpenWrt:~# ifconfig
br-lan Link encap:Ethernet HWaddr 00:24:A5:BD:D6:EE

        inet addr:192.168.15.1  Bcast:192.168.15.255  Mask:255.255.255.0
        inet6 addr: fe80::224:a5ff:febd:d6ee/64 Scope:Link
        UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
        RX packets:938243 errors:0 dropped:28 overruns:0 frame:0
        TX packets:2085323 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:1000 
        RX bytes:104241479 (99.4 MiB)  TX bytes:2503213569 (2.3 GiB)

eth0 Link encap:Ethernet HWaddr 00:24:A5:BD:D6:EE

        inet6 addr: fe80::224:a5ff:febd:d6ee/64 Scope:Link
        UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
        RX packets:52460047 errors:0 dropped:0 overruns:0 frame:0
        TX packets:125128647 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:1000 
        RX bytes:3038212072 (2.8 GiB)  TX bytes:3509411414 (3.2 GiB)

eth0.1 Link encap:Ethernet HWaddr 00:24:A5:BD:D6:EE

        UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
        RX packets:766348 errors:0 dropped:0 overruns:0 frame:0
        TX packets:1624083 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:1000 
        RX bytes:69575676 (66.3 MiB)  TX bytes:1897287106 (1.7 GiB)

lo Link encap:Local Loopback

        inet addr:127.0.0.1  Mask:255.0.0.0
        inet6 addr: ::1/128 Scope:Host
        UP LOOPBACK RUNNING  MTU:65536  Metric:1
        RX packets:948270 errors:0 dropped:0 overruns:0 frame:0
        TX packets:948270 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:1 
        RX bytes:96883426 (92.3 MiB)  TX bytes:96883426 (92.3 MiB)

wlan0 Link encap:Ethernet HWaddr 00:24:A5:BD:D6:EE

        inet addr:192.168.1.175  Bcast:192.168.1.255  Mask:255.255.255.0
        inet6 addr: fe80::224:a5ff:febd:d6ee/64 Scope:Link
        UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
        RX packets:196110 errors:0 dropped:0 overruns:0 frame:0
        TX packets:145503 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:1000 
        RX bytes:254527505 (242.7 MiB)  TX bytes:17859979 (17.0 MiB)

root@OpenWrt:~# cat /etc/config/network

config interface ‘loopback’

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals ‘globals’

option ula_prefix 'fd8e:cc00:56cc::/48'

config dsl ‘dsl’

option firmware '/lib/firmware/adsl.bin'
option xfer_mode 'atm'
option annex 'a2p'

config interface ‘lan’

option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.15.1'
option netmask '255.255.255.0'
option delegate '0'
option type 'bridge'

config switch

option name 'switch0'
option reset '1'

config switch_vlan

option device 'switch0'
option vlan '1'
option vid '1'
option ports '0t 2 3 4 5'

config interface ‘wwan’

option proto 'dhcp'
option hostname 'WBMR-HP-G300H'
option peerdns '0'
option dns '208.67.222.123 208.67.220.123'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device ‘radio0’

option type 'mac80211'
option hwmode '11g'
option path 'pci0000:00/0000:00:0e.0'
option htmode 'HT20'
option country 'IT'
option legacy_rates '0'
option disabled '0'
option channel 'auto'

config wifi-iface

option network 'wwan'
option ssid 'MyOwnWISP'
option encryption 'psk2'
option device 'radio0'
option mode 'sta'
option bssid '**:**:**:**:**:**'
option key 'secret'

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing